Vraag & Antwoord

Anders (software)

Probleem met logische test in Excel

3 antwoorden
  • Ik wil een logische test uitvoeren, waarbij als een van de argumenten ONWAAR is de berekening niet doorgaat. Het gaat om het volgende Als een van de volgende dagen (ma t/m vr) in de "weekdag"cel(b11) staat en de aanvangstijd (L11) is groter als 06:00 uur en de eindtijd (M11) kleiner als 22:00 uur Celwaarde overnemen (=N11) zoniet geen actie (" ") Mijn formule ziet er als volgt uit: [color=red:d0bf1dfad7]Als(OF(b11="ma";b11="di";b11="'wo";b11="do";b11=vr[/color:d0bf1dfad7];EN[color=blue:d0bf1dfad7](L11>="06:00";M11<="22:00"));[/color:d0bf1dfad7]n11;" ") [color=red:d0bf1dfad7]rood=WAAR[/color:d0bf1dfad7] [color=blue:d0bf1dfad7]blauw=ONWAAR[/color:d0bf1dfad7] Dan zou het resultaat toch ONWAAR moeten zijn en er niets ingevuld worden in de betreffende cel omdat een argument (L11=05:00) ONWAAR is Maar het werkt niet, waar zit de fout??? Mogelijk staan dehaakjes niet helmaal goed in het voorbeeld, maar concreet kan ik EN gebruiken genest in OF?? Of hoe moet ik het anders doen.
  • Volgens mij moet het zoiets worden: =ALS(EN(B11="ma";L11>="6:00";M11<="22:00")=WAAR;N11;ALS(EN(B11="di";L11>="6:00";M11<="22:00")=WAAR;N11;ALS(EN(B11="wo";L11>="6:00";M11<="22:00")=WAAR;N11;ALS(EN(B11="do";L11>="6:00";M11<="22:00")=WAAR;N11;ALS(EN(B11="vr";L11>="6:00";M11<="22:00")=WAAR;N11;" ")) Groeten, Wouter
  • ik ben het met wouter eens :D Peter

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.