Vraag & Antwoord

Anders (software)

[Excel] Opzoeken en koppelen

11 antwoorden
  • Omdat ik nergens anders een oplossing kan vinden zoek ik mijn toevlucht op het forum: Ik heb tabel met horizontaal 4 producten en verticaal een staffel: [code:1:3e13d3a0cb]Aantal m2 Product1 Product2 Product3 Product4 5 € 18,50 € 24,50 € 26,50 € 29,50 10 € 18,50 € 24,50 € 26,50 € 29,50 15 € 18,50 € 24,50 € 26,50 € 29,50 20 € 18,50 € 24,50 € 26,50 € 29,50 25 € 16,00 € 22,50 € 24,00 € 27,50 30 € 16,00 € 22,50 € 24,00 € 27,50 35 € 16,00 € 22,50 € 24,00 € 27,50 40 € 16,00 € 22,50 € 24,00 € 27,50 45 € 16,00 € 22,50 € 24,00 € 27,50 50 € 15,50 € 21,50 € 23,50 € 26,50 55 € 15,50 € 21,50 € 23,50 € 26,50 60 € 15,50 € 21,50 € 23,50 € 26,50 65 € 15,50 € 21,50 € 23,50 € 26,50 70 € 15,50 € 21,50 € 23,50 € 26,50[/code:1:3e13d3a0cb] Ik zou graag een formule willen maken dat wanneer je in een invoerveld het producttype [1,2,3 of 4] en het aantal ingeeft; deze wordt gekoppeld met de bijbehorende prijs uit de tabel. Weet iemand hoe ik dit voor elkaar kan krijgen?
  • Jaja, ik ben ongeduldig... :D Niemand een idee? Verwacht echt geen complete formule maar zou het zeer waarderen als ik op weg wordt geholpen...
  • Al geprobeerd met een combinatie van de formules voor verticaal zoeken en horizontaal zoeken?
  • [quote:572d10abb5="PS"]Al geprobeerd met een combinatie van de formules voor verticaal zoeken en horizontaal zoeken?[/quote:572d10abb5] Heb ik geprobeerd; maar kwam er niet uit...: [img:572d10abb5]http://www.kleinesingel.demon.nl/downloads/probleem-excel.gif[/img:572d10abb5] [b:572d10abb5]B5 [/b:572d10abb5]= cel met ingevoerde hoeveelheid [b:572d10abb5]data!A2:B401[/b:572d10abb5] = 2 kolomen data; 1e kolom hoeveelheden; 2e kolom bijbehorende prijzen [b:572d10abb5]1[/b:572d10abb5] = nummer kolom met hoeveelheden :-?
  • Ten eerste ervoor zorgen dat je aantal dat je ingeeft PRECIES gelijk is aan een factor 5. Ten tweede een viertal VLOOKUP'S opzetten, voor elke kolom dus, want ik neem aan dat je per produkt het aantal ingeeft (appels en peren-verhaal, je weet wel :wink: ). Ten slotte de vier opgezochte prijzen vermenigvuldigen met de juiste hoeveelheid en de boel optellen.
  • Ga ik proberen; thanks! Die cel B5 is altijd factor vijf [want = afgrond op 5]... :D
  • [quote:818915b504="Ederveen"] Ga ik proberen; thanks! Die cel B5 is altijd factor vijf [want = afgrond op 5]... :D [/quote:818915b504] Ok, als je maar echt een factor 5 in de vlookup gebruikt en geen afgeronde factor 5 (met ROUND-functie) anders herkent ie 'm dus nie ... :roll:
  • Wat is de Nederlandse funtienaam van [b:45069610eb]'vlookup'[/b:45069610eb]? Het is mij inmiddels wel gelukt om d.m.v. verticaal zoeken invoer te koppelen...
  • Geen idee: vopzoek? :lol: Ow w8 ff, Google: VERT.ZOEKEN :wink:
  • En de cirkel is rond.... :D
  • Was ook benieuwd naar de oplossing, heb het op een ander forum gezet en dit is de uitslag. =VERT.ZOEKEN(H1;A1:E100;G1+1;0) met in H1 het aantal en in G1 het producttype Pierre

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.