Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

Anders (software)

Optelling met 2 vergelijkingen in excel

Droopy
11 antwoorden
  • Ik heb in excel een aantal kolommen.

    A. ordernumer
    B. Naam opdrachtgever
    C. Bedrag order
    D. datum opdracht

    F. alfabetische lijst alle mogelijke opdrachtgevers
    G t/m R de maanden van het jaar

    de vraag nu is hoe luidt de formule als ik van een opdrachtgever bv Jansen van een bepaalde maand bv oktober wil weten hoeveel het totaal bedraagd van de orders.

    met de opdracht =som.als() kom ik er niet uit.
  • Kwa SOM.ALS: kombineer de gegevens eerst in een aparte kolom bijv.:

    =B1&maand(D1) en doe de som.als op dié kolom;

    of (Data >) Autofilter in combinatie met SUBTOTAAL()
  • FLvan SOn bedankt voor je antwoord. maar dit kan niet ineen keer?

    Anders zal ik deze zeker gaan gebruiken
  • Wel 's gehoord van draaitabellen/pivot tables? :wink:
  • Wel van gehoord maar geen idee hoe dat werkt.

    leg eens uit als je wilt.
  • [quote:d42fffec7c="Droopy"]G t/m R de maanden van het jaar[/quote:d42fffec7c]hmmm…:
    als je in g t/m r alle bedragen van specifieke maanden ziet kun je daar die som.als toch op doen????? :o
  • Ik heb jouw formule in S gezet
    en daarna som.als() met wat in S dan staat (Opdrachgever met maandnr) gedaan waardoor ik permaand per opdrachtgever een omzet kreeg.

    Maar dat gaat dus via een omwegje nl kolom S

    Vraag of dit ineen keer kan kwam een antwoord van een draaitabel

    Was jouw antwoord FLvanSON als reactie op Obi-wan-kenobi,
    of bedoelt als het resultaat van jouw aanreiking?
  • Meer voortschrijdend inzicht t.a.v. wat je zelf aanreikt; In G2 heb je denkelijk =ALS(MAAND($D2)=1;$C2;"") etc.; dan heb je alle orderbedragen van januari in kolom G; dan kun je toch =SOM.ALS(B2:B??;"naam opdrachtgever";G2:G??) doen??
  • [quote:ae8cb65f56="Droopy"]
    Wel van gehoord maar geen idee hoe dat werkt. leg eens uit als je wilt.
    [/quote:ae8cb65f56]
    Wel 's gehoord van Excel Help? :P
    Beetje suf om hier alles in te kopiëren :wink:
  • Ik heb de tip van FlvanSon opgevolgd en die werkt prima.

    Wat excel help betreft, vind ik die niet altijd even duidelijk.
    Ik heb natuurliujk wel eerst de help geprobeerd, maar toch daarna
    teruggevallen naar de hulp op dit forum.
  • Als je op twee of meer voorwaarden wilt checken kan je de volgende matrix-formule gebruiken:

    {=SOM(ALS(A2:A10="jansen";1;0)*ALS(MAAND(B2:B10)=10;1;0)*C2:C10)}
    In kolom A staat de naam
    in kolom B staat de datum
    in kolom C staat het orderbedrag
    Met de als functie test ik of de voorwaarde Ja is, dan is de waarde 1
    doormiddel van de matrix tel ik alle bedragen op die beide waar zijn.
    som( 1 x 1 x orderbedrag)

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.