Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

Anders (software)

Excel formule

Anoniem
Peter Vooges
9 antwoorden
  • In een excel werkblad moeten in twee kolommen getallen worden ingevuld.
    De bedoeling is dat er een controle plaatsvind om te checken of dat betreffende getal uniek is, dus niet al eerder is vermeld in één van de twee kolommen ( kolom B en kolom D)
    Er hoeft met de getal niet gerekend te worden, dus ik kan ze ook als tekst invoeren.
    Ik heb inmiddels wat zitten puzzelen, maar zie daar zo snel geen oplossing voor.
    Is er iemand die dat wel kan ?
  • Voorbeeld gehele B en D kolom: Selecteer B1 > Opmaak > Voorwaardelijke opmaak > Formule is > [code:1:402a3eb58c]=ALS(AANTAL.ALS($B:$B;B1)+AANTAL.ALS($D:$D;B1)>1;WAAR)[/code:1:402a3eb58c] > Opmaak > Ok > Kopieer de opmaak naar de andere cellen(selecteer B1 > dubbelklik op kwast > schilderen maar > klik nogmaals op kwast om weer uit te schakelen).

    Zoiets?
  • ga ik even proberen.
  • Ik heb de formule even moeten wijzingen, de kolommen blijken uiteindelijk C en E te zijn en de eerst in te vullen regel is regel 5.
    Het moet er volgens mij dan zo uitzien:

    ALS(AANTAL.ALS($C:$C;C5)+AANTAL.ALS($E:$E;C5)>1;WAAR)

    Dat heb ik als formule bij voorwaardelijke opmaak ingevuld, maar ik kan daarna nog steeds alle getallen invullen in de kolommen C en E, terwijl die dan wel gebruikt zijn.
  • Dat zei je er niet bij. Heb je wel Opmaak ingesteld? Valideren moet denk ik met VB(boven mijn pet :oops: ).
  • Ja, je hebt gelijk, ik kreeg de basis op grond waarvan ik het formulier moet maken wat later binnen dan dat ik deze topic opende, vandaar dat ik de kolommen en regels niet goed had.

    De opmaak had ik wel ingesteld met een leuk rood kleurtje, maar dat deed niets.
  • Selecteer C5 > Opmaak > Voorwaardelijke opmaak > Formule is >
    [code:1:802dbeec2c]ALS(AANTAL.ALS($C:$C;C5)+AANTAL.ALS($E:$E;C5)>1;WAAR)[/code:1:802dbeec2c]
    > Opmaak > Ok > Kopieer de opmaak naar de andere cellen(selecteer C5 > dubbelklik op kwast > schilderen maar > klik nogmaals op kwast om weer uit te schakelen).

    Waarom bij mij dan wel
    :cry:
  • Ik snap het ook niet. Je formule begrijp ik en dat is goed.
    Vind je het wat als ik je het bestandje mail ?
  • Nee, dat moet niet hoeven in dit geval.
    Check even of er misschien aanhalingstekens zijn geplaatst(gebeurt als je geen = voor de formule zet)[code:1:c6a9ec573e]="ALS(AANTAL.ALS($C:$C;C5)+AANTAL.ALS($E:$E;C5)>1;WAAR)"[/code:1:c6a9ec573e]; die aanhalingstekens moeten weg.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.