Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

Anders (software)

Cel met formule automatisch kopieren

Eric33
5 antwoorden
  • beste kenners,

    kan iemand mij helpen?

    Ik wil graag een formule die bijv. in cel B1 staat kopieren naar B2, maar alléén als er in de kolom ervoor een waarde ingevoerd is.

    ik hoop dat ik duidelijk genoeg ben, anders hoor ik het graag.

    groeten.
  • In cel C1 zet je de formule:

    =ALS(A1<>"";?????;"")

    Op de plaats van de vraagtekens zet je de formule uit cel B1
  • Ik bedoel dus de hele kolom A, en het moet automatisch gebeuren.

    Wanneer ik dus een waarde invul in bijvoorbeeld A8 moet er in B8 de formule komen en dus de uitkomst. Kan ik hier een macro voor maken en hoe doe ik dat?

    Alvast bedankt.
  • Macro is volgens mij overbodig. Je wilt in kolom B een waarde krijgen als er in kolom A een getal wordt ingevoerd.

    De formule in kolom B wordt dan:
    =ALS(A1<>"";A1*10;"") voor rij 1. Deze formule kan je naar beneden doorvoeren zover als je wilt.

    Als cel in kolom A leeg is, zal de cel in kolom B ook leeg zijn. Als de cel in kolom A een waarde heeft zal in kolom B ook een waarde verschijnen (n het bovenstaande voorbeeld het tienvoudige van de waarde in kolom A).
  • Maar een macro kan natuurlijk ook. Klik met de rechtermuisknop op het tabblad. Klik op programmacode weergeven en plak onderstaande code op de plaats van de knipperende cursor.

    [code:1:b8a60295af]Private Sub Worksheet_SelectionChange(ByVal Target As Range)
    On Error Resume Next
    Dim Cell As Range
    For Each Cell In Target
    With Cell

    If .Column = Range("A:A").Column Then
    'in dit voorbeeld plaats ik in kolom B de waarde uit kolom A x 10
    If Cells(.Row - 1, "A").Value <> "" Then

    Cells(.Row - 1, "B").Value = Cells(.Row - 1, "A").Value * 10
    End If
    End If
    End With
    Next Cell
    End
    End Sub

    [/code:1:b8a60295af]

    Welke formule wil je hebben in kolom B?

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.