Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

Anders (software)

installatie van phpMyAdmin

debrabandere
3 antwoorden
  • Ik weet niet of dit de beste plaats is om dit te posten.

    Ik probeer phpMyAdmin 2.6.4 te installeren.

    Ik heb tot nu toe het volgende gedaan:
    Apache 2.0.55 geinstalleerd (dit werkt voor zover ik weet goed, ik ben enkel nog niet echt ver gevorderd in PHP, maar alle eenvoudige pagina's worden goed weergegeven).
    Ik heb Php 5.0 geinstalleerd
    Ik heb MySQL Server 5.0 geïnstalleerd (dit werkt volgens mij ook goed. ik zit in het leren van PHP nu zo ver dat ik wil database gaan gebruiken. Men had mij aangeraden om voor te beginnen gebruik maken van php met databases eerst de basis van het werken met MySQL te leren. Dit werkte perfect vanaf de command line)

    Nu probeer ik dus phpMyAdmin te installeren.
    Ik heb de zipfile die ik gedownload heb uitgepakt en die map in de documentRoot van apache geplaatst.
    Als ik naar http://localhost/phpMyAdmin/index.php ga krijg ik het volgende:
    [quote:28def89b0e]Kan de mysql extentie niet laden,
    Controleer de PHP Configuratie[/quote:28def89b0e]
    met een link naar de volgende passage in de documentatie:
    [quote:28def89b0e] [1.20] I receive the error "cannot load MySQL extension, please check PHP Configuration".

    To connect to a MySQL server, PHP needs a set of MySQL functions called "MySQL extension". This extension may be part of the PHP distribution (compiled-in), otherwise it needs to be loaded dynamically. Its name is probably mysql.so or php_mysql.dll. phpMyAdmin tried to load the extension but failed.

    Usually, the problem is solved by installing a software package called "PHP-MySQL" or something similar. [/quote:28def89b0e]

    Ik heb al een beetje gezocht en gevonden dat ik in het bestand php.ini de regel [code:1:28def89b0e]extension=php_mysql.dll[/code:1:28def89b0e] en er stond bij dat ik bij extension_dir de locatie van dit dllbestand moest aanwijzen.
    Zoeken met de verkenner levert echter niets op, ik kan dit dll bestand nergens vinden. Kan iemand mij hierbij helpen.
    Alvast Bedankt.
  • Ik ben zelf gister met deze bezig geweest. En dit werkt nu prima
  • Heb je de PHP installer gebruikt? Dan denk ik dat je ook het zip bestand moet hebben. Met de installer worden namelijk geen dll's geinstalleerd.
    Je kan de zip volgens mij gewoon uitpakken in de PHP directory.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.