Vraag & Antwoord

Anders (software)

Excel: Waarden vanuit blad2 plaatsen in blad1 bij gevonden

2 antwoorden
  • In Excel heb ik twee bladen gevuld met verschillende artikelgegevens. zoals dit: blad1: A B C A120 12345 bel blad2: A B C D rood 12345 6 Nu wil ik middels een formule in de kolom D, de waarde van cel A1 plaatsen. Wanneer artikel 12345 echter niet wordt gevonden op blad1, dan moet en een tekst komen als Niet gevonden. Wanneer ik onderstaande formule gebruik, krijg ik als uitkomst #N/B. Wat doe ik niet goed? =VERT.ZOEKEN(B1;Blad1!$A$1:$C$2000;1;ONWAAR)
  • =ALS(ISFOUT(VERT.ZOEKEN((B1;Blad1!$A$1:$C$2000;1;ONWAAR))="waar");"Niet gevonden";VERT.ZOEKEN((B1;Blad1!$A$1:$C$2000;1;ONWAAR))) Ik heb het op de volgende manier opgelost. De formule ISFOUT zoekt of de verticaal zoekfunctie een match oplevert. Als er geen match wordt gevonden geeft deze formule als antwoord WAAR (er is immers inderdaad sprake van een foutcode #N/B). Vervolgens bepaald de ALS-formule dat bij WAAR de tekst niet gevonden moet worden weergegeven, en dat in andere gevallen de verticaal zoek-formule moet worden toegepast.

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.