Vraag & Antwoord

Anders (software)

Meerdere criteria voor Excel optellen

Anoniem
None
3 antwoorden
  • Voor mijn leden administratie in Excel wil ik van de junioren en de senioren de dames en heren apart optellen.
    Senioren/jeugd kolom kan S of J ingevuld worden.
    Dames/heren kolom wordt D of H ingevuld.
    Nu wil ik b.v. alle senior dames opgeteld hebben. Hoe kan ik dat doen?

    Ik weet dat ik met aantal.als kan werken, maar hoe krijg ik het zover dat ik dus uit die twee kolommen de combinatie met S en D kan optellen!
  • Toch maar verder gegoogled en kwam de volgende formule tegen.

    =SOMPRODUCT((A2:A5="aa";)*(B2:B5="dd";))

    Na de kolommen en producten ("aa" en "dd";) te hebben aangepast, werkt het zoals ik wil.

    Misschien dat anderen er hier nog wat aan hebben!
  • [i:f0b6952a98]Ik denk dat het makkelijkste dat je kan doen is een 3e colom maken met daarin een formule die onderscheid maakt tussen de vier categorieën , J-H, J-D, S-H en S-D. Dan kan je doen met een serie ALS en EN logische formules.
    Als sex in de C kolom zou staan en J/S in de B kolom zou de formule in de derde kolom 2e rij, er ongeveer zo uitzien, waar ik de 4 categorieën even 1 2 3 en 4 noem:
    =ALS(EN(B2="S";C2="D";);1;ALS(EN(B2="S";C2="H";);2;ALS(EN(B2="J";C2="D";);3;ALS(EN(B2="J";C2="H";);4))))

    Dan zou je een output van 1, 2, 3 of 4 krijgen die je dan gewoon met je aantal.als (COUNTIF) op kan tellen.[/i:f0b6952a98]

    [b:f0b6952a98]Edit:[/b:f0b6952a98] Ja, jouw methode is wel wat minder omslachtig :D.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.