Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

Anders (software)

Excel 2003: Waarde negeren

None
3 antwoorden
  • Ik ben bezig met het maken van een urenoverzicht in Excel. Hierbij worden dagelijks gewerkte uren ingevuld, wekelijks opgeteld en vergeleken met de contracturen. Hieruit komt vervolgens een aantal overuren rollen.

    De overuren worden berekend aan de hand van de formule =SOM(A1-36), waarbij 36 staat voor het aantal contracturen. Wanneer er geen uren zijn ingevuld, staat er in deze kolom -36,00.

    De gewerkte uren en de overuren worden onderaan het overzicht weergegeven door middel van de formule: =SOM(A1:A5), wat feitelijk gewoon een optelsom is.

    Het probleem is, dat in het totaal van de overuren ook de waarde -36,00 steeds wordt meegenomen. Hoe kan ik die waarde in de kolom overuren negeren of op 0 stellen, totdat de uren voor een specifieke week zijn ingevuld? Is daar een formule voor?
  • in cel A1 de gewerkte uren
    in cel B1 de contract uren
    in cel C1 =ALS(ISGETAL(A1);A1-B1;0)
  • Ik heb eens even met je formule geëxperimenteerd. Het komt al in de buurt van wat ik bedoel, maar wanneer er in een rij nog geen gegevens zijn ingevoerd, staat het aantal overuren op -36,00 (A1=0 / B1=-36 / C1=-36).

    Deze 'niet bestaande overuren' worden wel meegenomen in de optelling onderaan en dat moet juist niet. Ik wil kunnen zien hoeveel overuren er [u:8e1817e6fe]tot op het moment van invullen[/u:8e1817e6fe] zijn verzameld. Als de waarde meegenomen wordt, krijg ik een groot negatief getal als resultaat.

    Dat is de reden dat in het totaal =SOM(C1:C52) de waarden van -36 genegeerd moeten worden, als je begrijpt wat ik bedoel :P !

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.