Vraag & Antwoord

Anders (software)

Excel 2003 Fout Tijdswaarde na 00:00

8 antwoorden
  • Ik moet een urenregestratie maken, nu zitten er enkele fouten in. Een van de fouten waar ik niet uit kom is de volgende: Gemaakt is de formule: Avond 20:00/ 22:00 =ALS(F20-E20=0;" ";F20-E20-H20) Rekent hij netjes uit dat dit 02:00 uur is. Maar zodra ik Nacht 22:00/ 06:00 krijgt hij problemen waarschijnlijk omdat dit na 00:00 is. Wie kan mij hier mee verder helpen? Alvast bedankt!
  • Gebruik dit: =ALS(F20-E20=0;" ";F20+(E20>F20)-E20-H20)
  • Hartsikke bedankt voor de snelle reactie! Mocht ik nog ergens tegen aan lopen, meld ik het wel. Maar in ieder geval nogmaals bedankt voor het verhelpen van mijn probleem.
  • je hebt hier eigenlijkhet grote probleem van de tijd notatie deze loopt van 0 tot 0,99999999 waarbij 0 voor 00.00 uur staat en 0,99999999 voor 23.59 uur staat moet je maar eens proberen af te trekken bij 00.40 - 22.00 uur je ziet netjes 2.40 staan, maar kijk eens als je het getal soort veranderd in algemeen zie je -0,???????? staan (vraagtekens zijn getallen) en dan bij op of aftrekken ga je in de fout
  • Klinkt logisch, alleen vindt ik het lastig om dat mee te nemen in het maken van een formule. Eerst maar eens de formule die ik gekregen heb proberen te begrijpen. Misschien moet ik maar eens energie steken in de theorie van het maken van formules in excel.
  • Aansluitend op het verhaal van Sjouwer: In feite betekent deze waardenotatie in Excel dat je ook de datum in de berekening (en dus invoer moet meenemen). Ik heb voor een test de celeigenschappen ingesteld op de notatie [i:d73c2cc6e8]dd-mm-jjjj uu:mm[/i:d73c2cc6e8] om e.e.a. goed zichtbaar te krijgen. Een medewerker die gewoon een dagdienst draait kan volstaan met een invoer in de trend van [i:d73c2cc6e8]7:00[/i:d73c2cc6e8] en [i:d73c2cc6e8]16:00[/i:d73c2cc6e8]. Excel ziet het als 2 waarden op een willekeurige (dezelfde) datum. Een gebruiker die echter de grens van 00:00 overgaat zal een invoer moeten doen in de trend van [i:d73c2cc6e8]20-10-2010 22:00[/i:d73c2cc6e8] en [i:d73c2cc6e8]21-10-2010 06:00[/i:d73c2cc6e8]. Indien een vaste gebruiker alle gewerkte uren van het personeelsbestand invoert, is dit waarschijnlijk geen probleem, maar als iedereen zelf zijn uren moet gaan invoeren wordt de sheet zo waarschijnlijk binnen de korste keren een rommeltje door invoerfouten.
  • [quote:149c9b286a="PS"]Een gebruiker die echter de grens van 00:00 overgaat zal een invoer moeten doen in de trend van [i:149c9b286a]20-10-2010 22:00[/i:149c9b286a] en [i:149c9b286a]21-10-2010 06:00[/i:149c9b286a].[/quote:149c9b286a]Nee hoor, dat is niet nodig. Als de formule gebruikt wordt die ik hierboven vermeldde, dan wordt de tijd correct weergegeven, ook na 24.00 (of 00:00) uur.
  • spannend!!!!!!!!!!!!!!!!

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.