Vraag & Antwoord

Anders (software)

EXCEL 2003, ALS (voorwaarde) formule opstellen

12 antwoorden
  • Beste forumgebruikers, Ik moet een formule gebruiken die een uur aftrekt van het totaal aantal uren. Daarna moet deze nog gedeeld worden door 2. Nu werk ik niet met ALS formules, maar doe dit meestal met een omweg. Wat nu het probleem is, is zodra ik 1 uur aftrek van het totaal werkt hij alleen als er meer dan 1 uur is. Anders komt hij namelijk in negatieve tijdswaarde en aangezien dit niet mogelijk is met tijdsbepaling krijg ik mijn minst favorite tekes #####. Ik moet dus een formule hebben die 1 uur van het totaal aftrekt en deze delen door twee wanneer de tijdswaarde hoger is dan 1:00. Is deze kleiner dan 1 uur dan moet de voorwaarde 0:00 zijn. Hoe stel ik zo`n formule op?
  • [quote:a60bf353c3="Janus89"]Ik moet dus een formule hebben die 1 uur van het totaal aftrekt en deze delen door twee wanneer de tijdswaarde hoger is dan 1:00. Is deze kleiner dan 1 uur dan moet de [b:a60bf353c3]voorwaarde[/b:a60bf353c3] 0:00 zijn. Hoe stel ik zo`n formule op?[/quote:a60bf353c3]In plaats van "voorwaarde" bedoel je "uitkomst" vermoed ik. Probeer dit, met de celeigenschappen ingesteld als "Tijd": =ALS(A1-1/2>1;A1/2;0)
  • Bedankt ik heb hem gelijk geprobeerd!, Zodra ik de formule gebruik krijg ik in ieder geval geen #. Dus hij is niet meer negatief. Hij deel hem nou wel keurig door twee, alleen moet er nog eerst een uur afgetrokken worden. Zou het even duidelijker toelichten met getallen: Totaal aantal uur A1 Totaal: 06:00 En dan in de volgende een formule die dit antwoord geeft A2 = 06:00(A1) -01:00 = 05:00/ 2= 02:30 P.s ik heb wel > omgedraait omdat hij anders ook niet werkte. Kan hier ook aan liggen?
  • Als die 06:00 uur in A1 staat, typ dan in een willekeurige andere cel: =ALS(A1-"01:00"<0;0;(A1-"01:00")/2) Daar komt dan 02:30 uit. Let op de aanhalingstekens!
  • op die manier moet je een totaal van 6 uur wel altijd als 6:00 invoeren. het kan ook zonder de celeigenschappen op tijd te zetten. A1 = 6 andere cel : =ALS(A1-1>0;((A1-1)/2);0) dan komt er gewoon 2,5 uit.
  • [quote:a7bcf75ca6="PepijnG"]het kan ook zonder de celeigenschappen op tijd te zetten. A1 = 6 andere cel : =ALS(A1-1>0;((A1-1)/2);0) dan komt er gewoon 2,5 uit.[/quote:a7bcf75ca6] Natuurlijk, maar uit de tekst van de vragensteller is af te leiden dat hij in- en uitvoer in tijdnotatie wenst.
  • Het is weer maandag, dus ik ga weer mee aan de slag Ik zal kijken of het mij nu lukt met de formule. Bedankt alvast
  • Bedankt de formule werkt, wat is het nut van de aanhalingstekens in deze formule dan?
  • [quote:f1c8d1a780="Janus89"]wat is het nut van de aanhalingstekens in deze formule dan?[/quote:f1c8d1a780]Omdat in tijdnotatie aanhalingstekens nu eenmaal gebruikt moeten worden. Als je ze niet gebruikt, dan werkt de formule niet, controleer maar eens.
  • Oke, geld dit ook voor woorden zoals Ja en Nee? Formule werkt trouwens prima, bedankt
  • [quote:27eb8ce6b8="Janus89"]Oke, geld dit ook voor woorden zoals Ja en Nee?[/quote:27eb8ce6b8] Ja, dat geldt ook voor woorden als "Ja" en "Nee". Dat kun je nagaan door die woorden met en zonder aanhalingstekens te proberen.
  • Oke wat als getal gelijk moet zijn, behalve als deze boven 01:00 uitkomt. Dus 12:00 of andere getallen die boven 01:00 = 01:00 Maar wanneer 0:30= 0:30 (J18) = 12:00 (J19) =ALS(J18>="01:00";"01:00";J18) (J19) = 01:00 Dan moet hier dus uitkomst 01:00 staan Hij geeft nu fout melding in deze formule, maar berekent hem wel goed.

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.