Vraag & Antwoord

Anders (software)

excell lijst

7 antwoorden
  • ik heb een kolom met getallen, waarbij steeds afhankelijk van de datum, getallen worden aan toegevoegd. Nu wil ik steeds een automatische berekening met het laatste getal wat is ingevoerd. voorbeeld: vandaag 100 200 350 475 dan moet de berekening uitgevoerd worden met 475. morgen 100 200 350 475 633 De formule moet dan ipv met 475 gaan rekenen met 633.
  • Stel dat die getallen in kolom A staan, beginnend in A1, en dat het niet meer dan 100 getallen zijn. Dan kun je als formule gebruiken: =INDIRECT("a"&AANTALARG(A1:A100)) . Dat levert je het laatste getal op, aannemend dat alle cellen vanaf A1 een waarde bevatten. Daarachter plaats je de bewerking die je wil doen. Wil je bv. het laatste getal met 2 vermenigvuldigen, dan wordt dat: =INDIRECT("a"&AANTALARG(A1:A100))*2
  • Het werkt wel, maar dan mogen de overige cellen geen waarde (ook geen nul) en ook geen formule's bevatten. En die staan er wel in, maar ook als ze "" of "-" of 0 als uitkomst hebben worden ze meegeteld en is de uitkomst leeg, - of 0.
  • [quote:2fa11070e2="Ro"]Het werkt wel, maar dan mogen de overige cellen geen waarde (ook geen nul) en ook geen formule's bevatten. En die staan er wel in, maar ook als ze "" of "-" of 0 als uitkomst hebben worden ze meegeteld en is de uitkomst leeg, - of 0.[/quote:2fa11070e2]Dat schreef ik toch ook? Wat wil je dan? Precies omschrijven a.u.b.
  • ik heb in een kolom 365 cellen, waarin de optelling komt van de saldo's van verschillende rekeningen. de formule in de cellen is =ALS(K11="-";"-";SOM(K11+AB11)) enz enz =ALS(K372="-";"-";SOM(K372+AB372)). Staat er dus geen waarde in cel K11 dan komt er een - en anders een getal. Dagelijks komt er dus een getal bij in de kolom. En steeds met het laatste getal wil ik een berekening uitvoeren ( en een automatische opmaak, maar dat is verder niet zo van belang). Ik heb het nu opgelost door de fomule aan te passen, zodat er in plaats van een - de warde van de vorige cel wordt gegenereerd. =ALS(K11="-";k10;SOM(K11+AB11)) enz enz tot =ALS(K372="-";k371;SOM(K372+AB372)). onderaan staat dan in een cel =INDIRECT("k"&AANTALARG(k1:k372)). Dat werkt maar verdient niet de schoonheidsprijs. Ik wil dus steeds gaan rekenen met het laatste getal in de kolom. (daar moet een prognose uitkomen, die dus iedere keer automatisch aangepast wordt)
  • Gebruik in plaats van =INDIRECT("k"&AANTALARG(k1:k372)), dit: =INDEX(K1:K372;VERGELIJKEN(9E+307;K1:K372))
  • [quote:9b8cc48227="alfa6591"]Gebruik in plaats van =INDIRECT("k"&AANTALARG(k1:k372)), dit: =INDEX(K1:K372;VERGELIJKEN(9E+307;K1:K372))[/quote:9b8cc48227] perfect :D mijn dank is groot Als ik zo vrij mag zijn: wat houdt die 9E+307 in?

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.