Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

Anders (software)

Excel vraagje

None
5 antwoorden
  • Hallo iedereen.

    Ik wil in excel een cel verwijderen. Daar is een verwijzing in een andere cel en zo gauw ik de eerste cel verwijdert, krijg je een fout in de cel die de verwijzing heb. Beetje lastig om uit te leggen.

    Bijv. in A1 staat 5. In D1 staat: =A1.
    Haal ik alleen cel A1 weg met de rechtermuisknop, en laat de rest van de cellen naar boven kopieert dan krijg ik een foutmelding in D1: #VERW!

    Weet iemand om deze foutmelding weg te krijgen?
    Zet ik in D1: =$A$1 dan krijg ik dezelfde fout.
    Heb op google gezocht maar kan het niet snel vinden.

    Alvast bedankt,
    Raymond.
  • [quote:2bcf55295c="Guppie880"]Hallo iedereen.
    Haal ik alleen cel A1 weg met de rechtermuisknop, en laat de rest van de cellen naar boven kopieert dan krijg ik een foutmelding in D1: #VERW!
    [/quote:2bcf55295c]

    Kun je dit anders verwoorden?
    Ik begrijp zo niet wat je probeert te doen.

    Ik zal een gokje wagen:
    In D1 moet dezelfde waarde komen als in A1.
    Als A1 leeg is komt er in D1 #VERW!.
    Je wilt D1 leeg houden als A1 leeg is.

    Zit ik nog op het gede spoor?

    In dat geval kun je deze formule in D1 zetten:
    [code:1:2bcf55295c]=ALS(A1="";"";(A1))[/code:1:2bcf55295c]
    Dit betekent:
    Als A1 leeg is, blijft D1 ook leeg, Als A1 niet leeg is wordt D1 gelijk aan A1.
  • Hallo PepijnG,

    Het klopt dat in D1 komt te staan wat in A1 staat. Heb deze voorbeeld even genomen om het simpel te houden.
    In de kolom A staan de gegevens. Dus bijv: A1 21; A2 70; A3 2
    Nu verwijder ik A1 en alles naar wordt naar boven verplaats. Dan krijg A1 de waarde 70 en A2 3.
    Zo gauw ik dit doe, dan krijg ik de foutmelding van #VERW! in D1.

    Heb dit als voorbeeld genomen om het simpel te houden.
    Wat ik wil is mijn rooster die in excel staat in outlook importeren. Daarvoor maak ik op een nieuwe tabblad de gegevens goed zodat ze via een bereik geïmporteerd worden. Had via iemand een begin gekregen om het te doen in VBA maar daar kom ik helemaal niet uit.
    Mijn kennis voor excel is ook totaal niet groot. Kan er formules mee maken en dan houdt het op.
    Ik hoop dat wat ik wil lukt, zo niet dan ga ik het rooster toch elke week met de hand in outlook zetten.
    Alvast bedankt voor het meedenken.
    Raymond.
  • De melding #VERW! komt alleen als je de cellen naar boven verplaatst.
    Op die manier verwijder je niet alleen de inhoud van A1, maar de hele cel en dan snapt excel het blijkbaar niet meer in D1.

    Hierbij maakt het niet uit welke formule je in D1 gebruikt. =A1 en =ALS(A1="";"";A1) geeft beide de melding #VERW! als je de cellen naar boven verplaatst.

    Als je A1 alleen maar leeg maakt, zonder de andere cellen naar boven te verplaatsen, gaat het wel goed. dus misschien kan het ook zonder het naar boven verplaatsen van de cellen.
  • Hallo PepijnG,

    Ik was er al bang voor dat dit niet kan.
    Heb verder gekeken en heb er een oplossing voor.
    Ik selecteer de gegevens en ga ze naar de goede cel copieren.
    Het is te doen, hoef het 1x per maand te doen. Dus daar kom ik wel overheen.

    Bedankt voor het meedenken.

    Raymond.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.