Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

Anders (software)

excel vraag

yug
12 antwoorden
  • Ik werk met 4 cijferige codes en wil op basis van de laatste twee cijfers zoeken en de waarden hiervan bij elkaar optellen.
    Welke formule kan ik hierbij gebruiken?
    Bijv: 1,200 = 1,2 uur werken
    1.509 = 1,5 uur vakantie etc.
    Wie kan mij helpen?
  • wil je nu wel of niet afronden?
    Kijk dan onder invoegen-functie-wiskunde.

    of in een verborgen kolom (onder venster)delen door 100?

    Maar dit klinkt te eenvoudig…
  • sorry vergeet dat delen door 100 maar
  • Ter ontleding(op blad1):

    (In B1) =WAARDE(LINKS(A1;3))
    en
    (In C1) =RECHTS(A1;2)

    Alletwee selecteren en naar beneden kopieren-naar rij tien-

    En verzamelen(beter op een ander blad):

    =SOM.ALS(Blad1!C$1:C$10;code of celverwijzing naast&naar codelijst;Blad1!B$1:B$10)

    Codelijst tevoren op Celeigenschappen > Tekst instellen om de codes met voorloopnul netjes weer te geven.

    [ Dit Bericht is bewerkt door: FlvanSon op 2002-03-28 01:10 ]
  • De formules met waarde rechts en links werken goed. Maar wat ik niet begrijp is de formule met som.als met name het middenstuk hiervan?Misschien moet ik nog iets verduidelijken. De viercijferige codes (5 incl. de komma)staan in een rij 1( 31 dagen van de maand)In rij 2 staan de waarden die ik ophaal via vertikaal zoeken vanuit een ander werkblad.Wat ik nu wil is dat de waarden van de betreffende codes die eindigen met 09 ,19,29,39, etc. apart getotaliseerd worden.

    [ Dit bericht is bewerkt door: yug op 2002-04-01 21:26 ]
  • Even verder met mijn voorbeeld hoor(voor wat het waard is):

    =SOM.ALS(Blad1!C$1:C$10;9;Blad1!B$1:B$10)
    =SOM.ALS(Blad1!C$1:C$10;19;Blad1!B$1:B$10)
    etc.

    Óf:
    =SOM.ALS(Blad1!C$1:C$10;A1;Blad1!B$1:B$10)
    =SOM.ALS(Blad1!C$1:C$10;A2;Blad1!B$1:B$10)
    etc.
    (met in A1, A2 etc. je codes)

  • De formules zoals je ze weergeeft werken perfect maar dit is niet wat ik nodig heb. Ik probeer het nog eens anders uit te leggen: Ik toets in elke cel een willekeurige code bijv: a1=1,209, b1=400, c1=7,219 ,d1=800, e1=3,619, f1=7,209 etc. Volgens de huidige manier laat ik via vertikaal zoeken de betreffende waarden onder de codes zetten (deze staan op een ander werkblad in kolom a en b).Vervolgens doe ik rechts van de rij totaliseren. Maar ik wil ook kunnen zien hoeveel uren van iedere afzonderlijke code in dit totaal zitten. Voorzover ik weet kan er met som.als maar een criterium opgegeven worden.Ik heb ook geprobeerd om bijv: waarde(rechts(09;2))als criterium op te geven maar dat pikt ie niet. Help!!
  • Je zal die codedelen eerst in een tussentabel moeten scheiden dmv de eerste twee formules.

    Daarna zet je achter de rijtotalen zoveel kolommen als je codes hebt met daarin de genoemde som.als() en verwijst naar de tussentabel.
  • Oke dat begrijp ik.
    Nu nog een andere vraag die hieruit voortvloeit. Met de formules waarde links en rechts is het mogelijk om een getal te splitsen. Maar wat ik nu probeerde is twee getallen samenvoegen tot een getal met de formule tekst.samenvoegen. Tot zover gaat alles goed maar als ik dan naar het betreffende getal ga zoeken met vertikaal.zoeken dan krijg je #N/B. typ ik dat zelfde getal rechtstreeks in de cel dan herkent hij het wel? Is hier iets aan te doen of moet ik toch alles handmatig invoeren.
  • [quote:020087328f]
    Op 04-04-2002 0:12 schreef yug:
    Oke dat begrijp ik.
    [/quote:020087328f]
    Dan begrijp ik het ook :smile: :cool:

    Hoezo voortvloeit?
    Je invoer IS toch handmatig?
    Waarom wil je nu weer samenvoegen(werkt overigens ook met "=A1&B1&C1" )?
    Gaarne wat meer verhaal.
  • Waarom dit nu weer. Nou ik moet nogal wat codes invoeren en ik dacht als ik dit nu kan doorvoeren zou dit handig zijn maar dit lukt niet omdat ik de volgende waardes wil ingeven 0,2,9/0,409/0,509/0,609/0,809/1,009 etc. t/m 8,809. En dit ook voor de 19/29 etc. codes. Dus dacht ik als ik de codes zelf al zou splitsen (dit lukt wel met doorvoeren van de reeks)en naderhand weer zou samenvoegen ik een hoop werk gespaard had. Helaas werken dan de zoekopdrachten niet.
  • [code:1:991ed31c3b]
    invoer uren code 9 19 29
    1,009 1,0 09 3,00 1,90 3,00
    2,009 2,0 09
    3,029 3,0 29
    1,519 1,5 19
    0,419 0,4 19
    [/code:1:991ed31c3b]
    ff testuh…


    [ Dit bericht is bewerkt door: FlvanSon op 2002-04-07 12:01 ]

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.