Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

Anders (software)

Formuleprobleem Excel

H. Strijkers
9 antwoorden
  • Hallo allemaal,

    Wie wil mij helpen met een formule in Excel 97 ?

    Ik probeer Excel te laten berekenen hoeveel onkostenvergoeding ik moet krijgen bij een bepaald aantal diensturen.

    Cel A1 begintijd
    Cel B1 eindtijd
    Cel C1 de volgende formule : =(B1-A1+(B1<A1))*24

    Als ik nou in cel D1 type C1*bedrag klopt de uitkomst maar bij de berekening van deze onkostenvergoeding moet ik met een aantal dingen rekening houden :

    begintijd voor 14.00 uur = aantal uren x bedrag

    begintijd na 14.00 uur [b:f3fbe95880]EN[/b:f3fbe95880] meer dan 12 diensturen = aantal uren x bedrag + een toeslag

    Hoe krijg ik dit in 1 formule gebakken ?

    Alvast bedankt

    Harry
  • Ik wil wel eens voor je kijken of ik het voor elkaar krijg (weet niet of het lukt) maar dan moet ik wel weten wat je precies probeert te doen. Wat is b.v. de formule in C1? =(B1-A1+(B1<A1))*24? B1-A1 leverd altijd true op en waarom vermenigvuldigen met 24?

    Verder heb je het over een bedrag in D1, maar om welk bedrag gaat het? Ik bedoel dan niet de hoeveelheid, maar de omschrijving. Als je verteld wat je precies wilt kan ik wel eens kijken

    [edit]
    Mag ik verder concluderen dat men zowiezo aantal uren maal bedrag krijgt? of je nu voor of na 14:00 begint, en dat het verschil 'm eigenlijk alleen zit in het langer dan 12 uur werken wanneer je na 14:00 begonnen bent? Dat maakt de formule er n.l. een stuk simpeler op.
    [/edit]
  • Ik heb 4 kolommen
    A: begintijd
    B: eindtijd
    C: aantal uren (b-a dus)
    D: totaal bedrag

    En in kolom D staat:
    =IF(begintijd<0.5833,aantal uren*bedrag,IF(aantal uren>12,aantal uren*bedrag+toeslag,aantal uren*bedrag))

    Ik heb het aantal uren in een aparte kolom gezet omdat deze zo vaak in de formule voorkomt. Als je dit niet doet dien je in de formule steeds "aantal uren" te vervangen voor (B1-A1)
    0.5833 is overigens de decimale weergave van 14:00 's middags
    Verder kan het zijn dat je de komma's voor puntkomma's moet vervangen. De ene Excel versie is de andere niet en ik heb Excel 2000 :)

    Is dit wat?
  • Zal eens probere om het over te brengen:

    Als je precies intypt wat ik hieronder schrijf moet het lukken:


    Typ in A1 TIJD:
    Typ in A2 BEDRAG:
    Typ in A3 TOESLAG:
    Typ in B1 14:00
    Typ in B2 100 (Je bedrag wat je per uur krijgt)
    Typ in B3 50 (De toeslag)

    Typ in A5 START
    Typ in B5 EIND
    Typ in C5 TYD
    Typ in D5 BEREKENING

    Typ in A7 Je starttijd, Bijv 15:00
    Typ in B7 Je eindtijd, Bijv 04:00
    Typ in C7 =(B7-A7+(B7<A7))*24
    Typ in D7 =ALS(A7<B1=(EN(C7>12));C7*B2;C7*B2+B3)

    Lijkt het te doen bij mij
    Is dit wat je bedoelt?

    Cheers, P de BB

    Naschrift:
    Kunt natuurlijk ook in de formule in D7 zoals hierboven B1 vervangen door 0,5833 en B2 door je bedrag per uur en B3 door je toeslag

    Succes
  • Paulus,

    Zoals jij de formule gemaakt hebt werkt ie bijna perfect, alleen wordt nou ook de toeslag erbij geteld als ik voor 14:00 uur begin en meer dan 12 uur maak.

    Is hier ook nog een oplossing voor ?

    Samengevat :

    Voor 14:00 uur beginnen aantal uren x bedrag (ongeacht hoeveel uur)
    Na 14:00 uur beginnen en minder dan 12 uur aantal uren x bedrag
    Na 14:00 uur beginnen en meer dan 12 uur aantal uren x bedrag + toeslag.

    Alvast bedankt weer.

    Harry
  • Hoi,

    Weet je het zeker

    Als ik bijv Starttijd 08:00 neem en Eindtijd 23:00 uur
    heb ik meer dan 12 uur gewerkt (15 uur) en ben ik voor 14:00 begonnen

    Toch rekent ie dan netjes 1500,- uit (15 uur * 100 piek) dus geen toeslag

    Maar je hebt gelijk datie iets fout doet: voor 14:00 beginnen en MINDER dan 12 uur werken =» dan telt ie de toeslag er bij op.

    kzal mijn hoofd er even over breken
    je hoort nog van mij

    Cheers,

    P de B(i)osbouter
  • =ALS(EN(A7>B1;C7>12);C7*B2+B3;C7*B2)
  • Yep, dat is ´m

    F$#k dat er net iemand voor was :wink:

    Cheers
  • (B1<A1) kende Fl nog niet(waarvoor bedankt).

    ;)

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.