Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

Anders (software)

(Standaard)functie in Excel (niet VBA)

trudge
4 antwoorden
  • Beste mensen,

    Ik wil in een range (in 1 kolom) van positieve en negatieve getallen de negatieve getallen eruitpikken en de som daarvan in 1 cel weergeven. Maar zonder het tussenstapje om in een aparte kolom eerst de negatieve getallen uit de range te halen.

    Twee vragen:

    1) Natuurlijk kan ik het in VBA met een FOR-lus doen, maar ik vraag me af of er in Excel zelf een standaardfunctie voor is, al dan niet in Excel zelf gedocumenteerd.

    2) Is er een boek of een site met daarin een overzicht van de functies die niet standaard in Excel zelf gedocumenteerd zijn?

    Bedankt voor de moeite
    trudge
  • Hoeft toch niet in een aparte kolom de neg. values er uit te halen?
    Als je de range sorteert kun je toch zo de neg. waardes eruitpikken en sommeren?
    Of is dat te gemakkelijk gedacht?
  • Als het om denken gaat kan het nooit makkelijk genoeg zijn.

    Maar kan het sorteren en het optellen van jou met behulp van één functie, beste Paulus, dat is het antwoord waar ik naar op zoek ben. Ik probeer juist het creëren van een aparte extra kolom te vermijden.

    In VBA zou ik met de FOR-lus de hele kolom aflopen, daarbij elke waarde checken op + of -, en indien negatief: cumulatief optellen.

    Maar ik ben nieuwsgierig of het ook zonder VBA in een handeling kan.

    Bedankt voor je vlotte reaktie.

    Groetjes
    trudge
  • Volgens mij kun je gewoon

    =SOM.ALS(A1:A10;"<0")

    gebruiken. (er van uit gaande dat je values in A1 tm A10 staan…….)

    (indien je eng versie van Excel hebt, is het volgens mij zoiets als:

    =COUNTIF(Range;"Criterium")

    probeer eens?

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.