Vraag & Antwoord

Anders (software)

excel-kolommen vergelijken

6 antwoorden
  • Ik heb een vraagje mbt excel. Ik heb een blad vol met verschillende type apparaten. Dit is 1 kolom en ongeveer 5000 regels. (elke regel is een type apparaat). Dit is noem ik het modellenboek. Nu heb ik een excel bestand, waarbij in een bepaalde kolom ook deze types voorkomen. Dit noem ik het werkrapport. Ik moet nu de type apparaten van het werkrapport vergelijken met het modellenboek (er moet gecheckt worden of de apparaten goed vermeld staan in het werkrapport. Het modellenboek is dus mijn controle-data). Het mooiste zou zijn als de verkeerde modellen direct vervangen worden door de juiste, maar het belangrijkste is eigenlijk: Hoe kan ik de controle tussen het werkrapport en modelleboek laten controleren zodat ik een melding krijg dat er een type in het werkrapport niet klopt? (alleen een melding welk model niet overeenkomt zou ook al te gek zijn). Alvast bedankt! vr gr Marco Neef
  • Je kan met de formule 'verticaal zoeken' nagaan of een model uit werkrapport in het modellenboek voorkomt. In de gevallen dat het matcht geeft deze formule dan de naam van het model in de andere gevallen krijg je #N/B =VERT.ZOEKEN(A1;modellenboek!A:A;1;ONWAAR) Waarbij A1 de cel in het werkrapport is die moet worden vergeleken en de modellen in kolom A van het tabblad modellenboek staan.
  • :lol: Perfekt!!! Te gek!! Werkt echt precies zoals het moet werken! Dit scheelt mij een hele hoop werk! Maar toch nog een vraagje: Ik probeer de formule ook te begrijpen en heb gezocht bij "help"maar 1 ding zie ik niet: Wat/waarvoor dient de reeks: modellenboek!A:A;1 ? Modellenboek! = het tabblad ;1 = volgens mij kolom 1 van het modellenboek A:A =????? Kan je mij ook nog daarmee helpen? Dan snap ik de formule ook! Is de formule trouwens ook aan te passen om het modellenboek uit een aparte file te halen ipv uit een tabblad? (ik zou de file iedere keer kunnen plakken in het tabblad, maar als er een mogelijkheid is om de data te lezen uit bijv Modellenboek.xls zou dat nog mooier zijn...) Alvast wederom bedankt! vr gr Marco Neef
  • Je kan onder invoegen/functie de formule opzoeken, dan werk je met een handig invulschermpje. Hierin kan je op een viertal regels alle waardes van de formule invullen. Per regel staat een duidelijke uitleg van wat er ingevuld moet worden. A:A in de formule staat voor de gehele kolom A (als je een range van rij 1 tm 100 aangeeft, moet je nl je formule aanpassen als er nieuwe producten worden toegevoegd). Koppelen naar een ander bestand ipv tabblad is mogelijk.
  • Wederom bedankt voor je snelle antwoord. (het scheelt mij iedere maand op mijn werk nu echt een verschrikkelijke tijd werk; echt te gek!!!) Is het misschien mogelijk voor jou om aan te geven hoe ik dit moet koppelen aan een ander bestand? Ik doe erg veel met excel, maar koppelen met bestanden en jouw andere uitleg had ik nog nooit gedaan. Ik hoop dat je me nog een keer wilt helpen door aan te geven hoe je dit moet koppelen met een ander bestand. Vriendelijke groet; Marco
  • =VERT.ZOEKEN(A1,[modellenboek.xls]modellenboek!A:A,1,ONWAAR) Probeer eens te werken met Invoegen, functie (zoals PS al aangaf) Kies dan voor Functie Categorie: Allemaal en voor Functie naam: VERT.ZOEKEN (Btw, ik heb een engelse excel versie, dus misschien klopt de vertaling niet helemaal.) Nu zie je een scherm met 4 regels (sleep dit even ergens anders op je scherm, anders staat ie zo vervelend over je kolom) 1) voor de VERT.ZOEKEN waarde, klik cel A1 aan. 2) voor de tabel (tweede regel) ga naar je (alvast geopende) modellenboek.xls en klik op kolom A 3) voor de index (regel 3) tik in: 1 4 voor de 4de regel, tik in ONWAAR Klaar! Nu de formule nog even doorcopieern naar beneden. P de BB

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.