Vraag & Antwoord

Anders (software)

Excel 2000

4 antwoorden
  • Ik loop tegen een vreemd probleem aan in Excel 2000 De cellen A1 t/m D1 staan ingesteld als Getal, 2 decimalen, negatieve getallen: -1.234,10 . E1 staat ingesteld als Standaard. In A1 staat: 8,60 In B1 staat: 0,00 (of B1 is blanco) In C1 staat: -58,60 In D1 staat: 50,00 In E1 staat: =SOM(A1:B1)=-SOM(C1:D1) en dit levert als resultaat WAAR op, wat juist is. [b:75dfca01f8]Maar[/b:75dfca01f8]: als ik in C1 typ: -68,60 en in D1: 60,00 (in A1 blijft 8,60 staan), dan verandert het resultaat in E1 in ONWAAR. Het klinkt ongelooflijk, maar het is toch echt waar. Hoe is dat mogelijk? (Het is geen virus). NB: Het probleem doet zich niet voor als in A1 8,50 staat en in C1 en D1 resp. -68,50 en 60,00 (en ook niet als in A1 8,70 staat en in C1 en D1 resp. -68,70 en 60,00). Maar weer wél als in A1 8,68 staat en in C1 en D1 resp. -68,68 en 60,00 . De cellen instellen als Financieel of Valuta geeft hetzelfde probleem.
  • Gelukkig kan ie wel afronden: =AFRONDEN(SOM(A1:B1);2)=AFRONDEN(-SOM(C1:D1);2) Verder wel frapperend :o Moet je eens kijken wat ie achter de komma doet in een reeks die telkens met 0,01 verhoogt :o :o
  • Ik veronderstelde dat het probleem zich alleen op mijn computer voordeed, maar uit je antwoord meen ik indirect te mogen opmaken dat het kennelijk "eigen" is aan Excel 2000. De aangedragen oplossing voldoet prima. Bedankt voor de hint!
  • Voor het lezen van je post had ik nog rustig kritieke betonconstructies met excel berekend(als ik dat zou kunnen :wink: )... IS ER EEN COMPUTEROLOOG IN DE ZAAL?

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.