Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

Anders (software)

datum excel

PS
8 antwoorden
  • ik wil een datum invoeren in een cel (b.v. A1) als in B1 een getal getypt wordt, maar dan geen systeem datum maar een datum die staan blijft als het werkblad de volgende dag geopend wordt.
  • Ja en wat is de vraag?
  • De formule in A1 wordt iets als: =ALS(B1=0;"-";NU())

    Hierbij staat er een streepje als B1 leeg is, anders de systeemdatum. (eventueel celeigenschappen aanpassen naar datumopmaak).

    Vervolgens kan je met 'plakken speciaal' de gevulde datumvelden naar 'waarden' omzetten. Handmatig werkt dit zeker, maar mogelijk kan dit ook automatisch met een macro bij afsluiten ?
  • [code:1:d724c63cdb]Private Sub Workbook_SheetChange(ByVal Sh As Object, ByVal Target As Range)
    Dim regel, kol
    regel = ActiveCell.Row
    kol = ActiveCell.Column
    If kol = 2 Then Cells(regel, 1) = Now()
    End Sub[/code:1:d724c63cdb]
    Hiermee wordt de datum ingevuld als er iets veranderd in kolom 2
    De datum wordt op de active regel in kolom 1 ingevuld.
    Let op dat de Enter toets niet naar het volgende regel verwijst (extra - opties - bewerken)

    Wim
  • In de twee laatste antwoorden wordt de functie NU() dan wel NOW() gebruikt,
    wat bij iedere nieuwe dag zal leiden tot een andere datum.
    Wat de vragensteller precies wil is mij (evenals Belg) niet duidelijk, maar uit
    zijn tekst is wel op te maken dat hij een [b:b2a5a85d79]onveranderlijke[/b:b2a5a85d79] datum wil !
  • :roll:
    Ctrl + ; (maar dan automatisch zodra er iets in een andere cel wordt ingevuld)
  • [quote:36794741eb]In de twee laatste antwoorden wordt de functie NU() dan wel NOW() gebruikt,
    wat bij iedere nieuwe dag zal leiden tot een andere datum.
    Wat de vragensteller precies wil is mij (evenals Belg) niet duidelijk, maar uit
    zijn tekst is wel op te maken dat hij een onveranderlijke datum wil ![/quote:36794741eb]Er wordt alleen een datum ingevuld als er iets wijzigd in kolom 2!
    Dus toch een soort vaste datum.
    Eventueel aan te passen dat de datum maar eenmalig ingevuld wordt.

    Wim
  • als de formule =ALS(B1=0;"-";NU()) in C1 staat dan wordt de systeem datum in C1 geplaatst als in B1 iets ingevult wordt maar (na de formule gekopieerd te hebben naar beneden C2 totC10)en de volgende dag wordt in B2 iets ingevult dan veranderd de datum in C1 ook, die veranderd in vandaag en ik wil graag dat ik kan zien waneer er b.v. iets in in B1 ingevult is ?

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.