Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

Anders (software)

Excel formule maken voor toekennen van een waarde!!!

FlvanSon
20 antwoorden
  • Beste Forum bezoekers,

    Ik zit met een MEGA probleem. Ik wil in Excel werkboek, die bestaat uit een aantal werkbladen (tabbladen) een nieuw kolom toevoegen die daarna een bepaalde waarde toegekend krijgt, afhankelijk van de waarde in een ander kolom.

    Situatie:
    Blad;4 : Kolom;A nieuw kolom in blad
    B bevat standaard invoer
    C bevat namen die geïmporteert worden uit een ander applicatie.

    Blad;3 : Bevat de namen die ook in kolom C van Blad 4 voorkomen, echter gesorteerd op afdeling.

    Nu wil ik in kolom A van Blad 4 een formule invoeren die de namen uit kolom C vergelijkt, met de namen uit blad 3 (ook kolom C) en als deze overeenkomt, in kolom A (van blad 4) een waarde (afdeling) toekent.

    Nu heb ik dit met de Functies ALS en OF geprobeert, echter zonder resultaat.
    FORMULE: =ALS(OF(<blad4>!C:C=<bereik>!$C$**;"WAARDE";""),(<blad4>!C:C=<bereik>!$C$**;"WAARDE";""),(<blad4>!C:C=<bereik>!$C$**;"WAARDE";"")

    De formule moet de kolommen uit de twee werkbladen vergelijken en bij WAAR een waarde aan kolom A toekennen,… hierna kan ik dan het blad hersorteren op afdeling om daarna een rapport te kunnen presenteren.

    Als ik deze formule gebruik als enkele "zoek, vergelijk en invoer" formule
    ALS(<blad4>!C:C=<blad3-CEL>!$C$**;"WAARDE";"") dan heb ik geen probleem echter ik kan onmogelijk in de formule alle cellen gaan definiëren, daar de geïmporteerde gegevens per dag veranderen. Ik ben aan het eind van mijn Latijn en weet niet meer hoe ik deze formule moet maken. Gaarne uw hulp hierbij.

    Versie: Excel97

    Rest mij voor nu u allen een gezond 2003 toe te wensen.
  • Als ik het goed begrijp wil je uitfilteren wie er rapporterenswaardig zijn:

    In A2 op Blad 4 [b:3c63f4f111][code:1:3c63f4f111]=AANTAL.ALS(Blad3!C:C;C2)[/code:1:3c63f4f111][/b:3c63f4f111]
  • [quote:c43f23d18b="FlvanSon"]Als ik het goed begrijp wil je uitfilteren wie er rapporterenswaardig zijn:

    In A2 op Blad 4 [b:c43f23d18b][code:1:c43f23d18b]=AANTAL.ALS(Blad3!C:C;C2)[/code:1:c43f23d18b][/b:c43f23d18b][/quote:c43f23d18b]

    Nee, het filteren gebeurt pas later, ik moet de gegevens (namen) eerst voorzien van een afdeling (die niet in de oorsprongkelijke applicatie aanwezig is) om deze daarna te sorteren en daarna via de menufunctie "Draaitabelrapport" te filteren in een nieuw blad. Hiermee zijn meerdere gegevens gemoeid. Het gaat hier puur om het toekennen van een afdeling (waarde) aan de namen. De gebruikte blad4 is ingedeeld als "database". De waarde die in kolom A ingevoerd dient te worden is afhankelijk van de kolommen C in blad 4 en 3, waarbij kolom C in blad 3 de waarde bepaald.

    Bedankt voor de reactie, ik hoop dat je nog meer ideën heb.

    Groeten, John
  • Nu is het mij toch ook niet meer duidelijk wat je wenst.
    Wil je nu in kolom A op blad 4 een aanduiding als een naam van blad3 óók op blad4 voorkomt, of als een naam van blad4 ook op blad3 voorkomt? Dat is niet hetzelfde en ik had - evenals FlvanSon - begrepen dat je het laatste wou.
    Je hebt de functie van FlvanSon toch wel vanuit A2 naar beneden gekopieerd?
    Als zijn oplossing niet datgene is wat je wenst, wat wil je dan wél?
  • ok, ik blijf schieten 8) :[code:1:4d5c53bbac]
    =ZOEKEN(C2;Blad3!C:C;Blad3!D:D)[/code:1:4d5c53bbac]
    (vereist "afdeling" in D-kolom blad 3)

    hij wil de afdeling(ik ga er van uit dat die in de invoer zit(denkelijk kwa dat iemand op meer afdelingen kan werken)
  • [quote:d3c62ecce2="Aimable"]Nu is het mij toch ook niet meer duidelijk wat je wenst.
    Wil je nu in kolom A op blad 4 een aanduiding als een naam van blad3 óók op blad4 voorkomt, of als een naam van blad4 ook op blad3 voorkomt? Dat is niet hetzelfde en ik had - evenals FlvanSon - begrepen dat je het laatste wou.
    Je hebt de functie van FlvanSon toch wel vanuit A2 naar beneden gekopieerd?
    Als zijn oplossing niet datgene is wat je wenst, wat wil je dan wél?[/quote:d3c62ecce2]

    :oops: Mischien ben ik niet erg duidelijk, waarschijnlijk omdat het hier toch om een meer dan ingewikkeld formule gaat.

    In dit verhaal komen drie kolommen aan bod die over twee werkbladen in
    één werkmap verdeeld zijn.
    In Werkblad 4 komen;
    kolom A (afdeling / in te voegen waarde) en
    kolom C (namen van de mdw., in totaal 50 namen die wel per dag tot 50 keer voor kunnen komen) voor.

    In werkblad 3 staan de namen (van de mdw.) in een nette vorm gegoten, in kolom C.

    De bedoeling is dat de formule naar de kolom C op blad 4 kijkt, vervolgens controleerd de formule of de naam die in Kolom C op Blad 4 voorkomt ook in een bereik (bv C2:C15) van Kolom C op Blad 3 voorkomt,… is dit het geval dan moet er in kolom A van blad 4 een waarde ingevoerd worden,.. dit is de Afdeling waar de mdw. onder valt.

    In totaal worden de mdw.s over drie afdelingen ingedeeld, dus moet de formule genestelde functies bevatten die allemaal in de kolom C van blad 4 zoeken en een waarde in kolom A invoeren.

    HELP :-?
  • [quote:f10c7b2bd3="Hillrjohn"] De bedoeling is dat de formule naar de kolom C op blad 4 kijkt, vervolgens controleert de formule of de naam die in Kolom C op Blad 4 voorkomt ook in een bereik (bv C2:C15) van Kolom C op Blad 3 voorkomt,… [/quote:f10c7b2bd3]
    En dat is nou precies wat de eerste formule van FlvanSon doet !
    [quote:f10c7b2bd3="Hillrjohn"]
    In totaal worden de mdw.s over drie afdelingen ingedeeld, dus moet de formule genestelde functies bevatten die allemaal in de kolom C van blad 4 zoeken en een waarde in kolom A invoeren.[/quote:f10c7b2bd3]
    Om hiermee rekening te houden moet bekend zijn wáár de gegevens over de afdelingen staan.
  • [quote:8f19d9241e="Hillrjohn"]Blad;3 : Bevat de namen die ook in kolom C van Blad 4 voorkomen, echter [i:8f19d9241e]gesorteerd[/i:8f19d9241e] op afdeling.[/quote:8f19d9241e]

    [quote:8f19d9241e="Hillrjohn"]In totaal worden de mdw.s over drie afdelingen ingedeeld, dus moet de formule genestelde functies bevatten die allemaal in de kolom C van blad 4 zoeken en een waarde in kolom A invoeren.
    [/quote:8f19d9241e]

    namen komen dus max. 3x voor op blad 3;
    in welke cel/kolom staat de afdeling op blad 3?

    welke informatie voer je in op blad 4 zodat in de a-kolom van blad 4 een afdeling bepaald kan worden en kan worden gecontroleerd op blad 3 of de medewerker is ingedeeld op die afdeling?

    houd moed ;)
  • [quote:b7dd6ebd56="FlvanSon"][quote:b7dd6ebd56="Hillrjohn"]Blad;3 : Bevat de namen die ook in kolom C van Blad 4 voorkomen, echter [i:b7dd6ebd56]gesorteerd[/i:b7dd6ebd56] op afdeling.[/quote:b7dd6ebd56]

    [quote:b7dd6ebd56="Hillrjohn"]In totaal worden de mdw.s over drie afdelingen ingedeeld, dus moet de formule genestelde functies bevatten die allemaal in de kolom C van blad 4 zoeken en een waarde in kolom A invoeren.
    [/quote:b7dd6ebd56]

    namen komen dus max. 3x voor op blad 3;
    in welke cel/kolom staat de afdeling op blad 3?

    welke informatie voer je in op blad 4 zodat in de a-kolom van blad 4 een afdeling bepaald kan worden en kan worden gecontroleerd op blad 3 of de medewerker is ingedeeld op die afdeling?

    houd moed ;)[/quote:b7dd6ebd56]


    Ik wil inderdaad de moed erin houden. De namen van de mdw's komen in totaal +/- 50 keer voor in blad 3. De afdelingen zijn echter maar drie. De formule zou (logische redenering mijnerzeijds) moeten zijn zoals beschreven in de Code 's
    [code:1:b7dd6ebd56]ALS(=ALS(AC!C:C='Personeel Indeling'!C2:C10;"KM";ALS(AC!C:C='Personeel Indeling'!C12:C36;"KL";ALS(AC!C:C='Personeel Indeling'!C38:C53;"DICO";"")))

    [/code:1:b7dd6ebd56]=ALS((ALS(OF(AC!C:C='Personeel Indeling'!$C$38:$C$53);"DICO"));(ALS(OF(AC!C:C='Personeel Indeling'!$C$12:$C$36);"KL"));(ALS(OF(AC!C:C='Personeel Indeling'!$C$2:$C$10);"KM")))

    Als we deze twee formules ontleden dan geeft dit een logische zoek-vind-waarde functie,… echter ik krijg de foutmelding #Waarde! Bij andere formules krijg ik foutmeldingen zoals #NAME! . De eerste formule is een geneste formule maar wil niet doen wat ik wil. :(

    Nogmaals ik wil de aantal keren dat een naam voorkomt niet bij elkaar optellen maar deze een waarde geven (in kolom A), in de vorm van de afdelingen "DICO" - "KM" - "KL"

    Enige idee??? :o
  • [code:1:733c845547]=ALS(AANTAL.ALS(Blad1!B2:B10;C1)>0;"KL";ALS(AANTAL.ALS(Blad1!B12:B36;Blad2!C1)>0;"KM";ALS(AANTAL.ALS(Blad1!B38:B58;Blad2!C1)>0;"DECO")))[/code:1:733c845547]
  • [quote:52f47da995="FlvanSon"][code:1:52f47da995]=ALS(AANTAL.ALS(Blad1!B2:B10;C1)>0;"KL";ALS(AANTAL.ALS(Blad1!B12:B36;Blad2!C1)>0;"KM";ALS(AANTAL.ALS(Blad1!B38:B58;Blad2!C1)>0;"DECO")))[/code:1:52f47da995][/quote:52f47da995]

    :( Ik ben er nog steeds niet uit met de aangedragen oplossingen,.. mogelijk is er iemand die mij kan helpen of weet met wie ik contact kan opnemen voor een passend oplossing. Alvast bedankt. 8)
  • Heb je in de formule van FlvanSon de cellen/kolommen wel aan jouw situatie (op je werkbladen) aangepast?
    Afgaande op de gegevens die je hebt verstrekt (en die zijn helaas nogal beperkt), moet op blad4 in A2 komen:
    [size=9:5f153b54c6]=ALS(AANTAL.ALS(Blad3!$C$2:$C$10;C2)>0;"KM";ALS(AANTAL.ALS(Blad3!$C$12:$C$36;C2);"KL";ALS(AANTAL.ALS(Blad3!$C$38:$C$53;C2)>0;"Dico";"")))[/size:5f153b54c6]
    Deze formule in kolom A naar beneden kopiëren.
  • [quote:19271c42bd="Aimable"]Heb je in de formule van FlvanSon de cellen/kolommen wel aan jouw situatie (op je werkbladen) aangepast?
    Afgaande op de gegevens die je hebt verstrekt (en die zijn helaas nogal beperkt), moet op blad4 in A2 komen:
    [size=9:19271c42bd]=ALS(AANTAL.ALS(Blad3!$C$2:$C$10;C2)>0;"KM";ALS(AANTAL.ALS(Blad3!$C$12:$C$36;C2);"KL";ALS(AANTAL.ALS(Blad3!$C$38:$C$53;C2)>0;"Dico";"")))[/size:19271c42bd]
    Deze formule in kolom A naar beneden kopiëren.[/quote:19271c42bd]

    :D :P Inderdaad, bij de vorige invoer heb ik een fout gemaakt. Bedankt, het werkt perfect.

    :o Ik heb echter een vervolg vraag. Met welke functie laat ik een waarde in kolom A zoeken (bv. een naam) om vervolgens een waarde in kolom C (op dezelfde rij) bij elkaar op te laten tellen??? Per mdw. wil ik de gemaakte acties in een ander kolom bij elkaar optellen, zodat ik van elk mdw. weet hoe de status van zijn acties zijn. Hopelijk is voor deze bewerking ook een simpele oplossing. Met vriendelijke groeten. John :wink:
  • We hadden je al bijna opgegeven ;)

    =SOM.ALS(A:A;gezochte naam of celverwijzing;C:C)
  • [quote:5b97ecc6c5="FlvanSon"]We hadden je al bijna opgegeven ;)

    =SOM.ALS(A:A;gezochte naam of celverwijzing;C:C)[/quote:5b97ecc6c5]

    :) Ben toch vereerd dat jullie mij gemist hebben :lol: Ik heb voor mijn probleem de volgende oplossing bedacht ; " =AANTAL(AANTAL.ALS('AC-Ma'!C:C;"(Timal, J.)");AANTAL.ALS('AC-Ma'!F:F;"Closed")) ", echter hiermee krijg ik constant de waarde 2, terwijl dit niet zo is, de waardes die bij elkaar opgetelt en weergegeven moeten worden komen van de F:F kolom, in dit geval "Closed", maar moeten wel coresponderen met de NAAM uit Kolom C:C. Bij het beginnen met =AANTAL.ALS( , krijg ik foutmeldingen die wijzen naar een verkeerd formule. Hoe moet deze formule eruit zien??? :roll:
  • Ik zie niet wat je met die formule wilt bereiken: je haalt de formules een beetje doorelkaar
    [quote:a981cd96a8]
    =AANTAL(AANTAL.ALS('AC-Ma'!C:C;"(Timal, J.)");AANTAL.ALS('AC-Ma'!F:F;"Closed"))[/quote:a981cd96a8]

    -die eerste AANTAL moet denkelijk ALS zijn?
    -AANTAL.ALS('AC-Ma'!C:C;"(Timal, J.)") kijkt hoe vaak Timal, J. in de lijst voorkomt
    -AANTAL.ALS('AC-Ma'!F:F;"Closed")) kijkt hoe vaak "Closed" in de lijst voorkomt
    >Maar met deze formule worden namen opgeteld in kolom C en F en niet zoals je vroeg zoeken naar een naam in kolom A en dan corresponderende getallen optellen in kolom C…

    Vertel gewoon wat je ermee wilt bereiken, dat voorkomt een hoop verwarring.

    ps Wat ik vaak doe bij ingewikkelde, meervoudige formules is ze in aparte cellen zetten; als je dan alle stappen werkend hebt ga je pas kijken hoe je het geheel in één cel kunt proppen.

    pps Gebruik ook de wizards bij de formules(klik in een cel op = en dan op het pijltje naast het naamvak(linksboven); als je daar de benodigde formule selecteert, vertelt excel je stap voor stap wat ie van je verwacht.
  • :oops: >>Nog ff naar zitten staren: Als je er een kolom G achter zet waarin je de naam(Timal, J.) en de specificatie(Closed) combineert in een cel d.m.v. de formule:

    =C1&F1

    en die naar beneden kopieert, kun je daarna met AANTAL.ALS() op die combinatie zoeken, bijv.:

    =AANTAL.ALS($G:$G;$A2&B$1)
    (in A2 heb ik Timal, J. en in B1 Closed)
  • [quote:0279832949="FlvanSon"]:oops: >>Nog ff naar zitten staren: Als je er een kolom G achter zet waarin je de naam(Timal, J.) en de specificatie(Closed) combineert in een cel d.m.v. de formule:

    =C1&F1

    en die naar beneden kopieert, kun je daarna met AANTAL.ALS() op die combinatie zoeken, bijv.:

    =AANTAL.ALS($G:$G;$A2&B$1)
    (in A2 heb ik Timal, J. en in B1 Closed)[/quote:0279832949]

    :o Goedenavond. Ik zal proberen om mijn doel van genoemde formule te beschrijven.

    Situatie; Aanwezig werkblad (AC-Ma) met de namen van de medewerkers in kolom C (namen komen x aantal keren voor, verschillend per mdw.) In dezelfde werkblad in kolom F komen waarden voor die verschillen van "Closed" of "Closed and verified" of "Assigned" van karakter zijn. Een mdw. wiens naam b.v. 10 keer voorkomt in kolom C kan in kolom F (zoals volgorde boven) "3" of "4"of "3" de waarde hebben. Nu wil ik deze waarden in een tweede werkblad (Perf.-Ma) ordenen zodat ik per mdw. één rij krijg met deze gegevens naast elkaar (tabelvorm). Voorbeeld:
    Kolom A —— Kolom B —— Kolom C —— Kolom D
    Naam —— Closed —— Closed and V..—— Assigned
    Timal —— 3 —— 4 —— 3
    Hill —— 5 —— 3 —— 2
    enz.

    De formule moet dus de de twee kolommen met elkaar vergelijken en als de waarden die overeenkomen met de naam bij elkaar optellen en deze plaatsen op het tweede werkblad. Ik hoop zo mijn doel te hebben verwoord. :roll: 8)
  • Plaats op blad acma in G1 de volgende formule:

    =C1&F1

    kopieer deze formule naar behoeven naar beneden

    zet de tabel Perfma op zoals je voorsteld

    Plaats in B2 de volgende formule:

    =AANTAL.ALS('AC-Ma'!$G:$G;$A2&B$1)

    enz.
  • [quote:2b7abac1ef="FlvanSon"]Plaats op blad acma in G1 de volgende formule:

    =C1&F1

    kopieer deze formule naar behoeven naar beneden

    zet de tabel Perfma op zoals je voorsteld

    Plaats in B2 de volgende formule:

    =AANTAL.ALS('AC-Ma'!$G:$G;$A2&B$1)

    enz.[/quote:2b7abac1ef]

    :P Bedankt, werkt inderdaad prima. Ik heb de formule wat aangepast (=AANTAL.ALS('AC-Ma'!$J:$J;"(Hill, J.)Closed")) hierdoor wordt dat bereikt wat ik wil. Nogmaals bedankt

    Hoe kan ik (met een macro of zo) een bepaalde invoer (formule of gewoon tekst) doorkopieëren naar beneden tot de regel waar geen invoer meer is zonder de functie slepen te gebruiken??? Je snapt natuurlijk dat dit een vervolgvraag is. :lol: Het gaat erom dat als de data in de werkblad geïnporteert is, de aantal regels elke dag anders is.

    Morgen heb ik nog een vraag over het optellen van datum en tijd notaties!!!
    Vriendelijke groeten, John :wink:

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.