Vraag & Antwoord

Anders (software)

excel vraagje

20 antwoorden
  • Op je vakantiekaart moet je "ouwe lullen" dagen noteren. Dit zijn per leeftijd een x aantal dagen per jaar. Deze wil ik automatisch via vert.zoeken laten invullen. In de eertse kolom staan de leeftijden 16 t/m 20 jaar en 45 jaar en hoger. In de tweede kolom de bijbehorende uren of dagen. Het probleem nu is dat als ik via deze formule laat zoeken en er 22 staat ik #NB ingevuld krijg. Dit wil ik niet. Ik zou willen dat als bijv; iemand 22 jaar is en dus geen recht heeft op deze uren er een 0 verschijnt. Hoe moet dit via een formule? :(
  • ALS(ISFOUT()) in een aparte kolom erbij, werkelijke resultaat verbergen is het wat?
  • Dat kan met de functie =vert.zoeken
  • [quote:6a22d487a3="yug"]als ik via deze formule laat zoeken[/quote:6a22d487a3] Wakker blijven Belg: nog een paar uur :lol:
  • Oeps. [img:ae4146e039]http://www.mediawatchers.nl/smileys/hiding.gif[/img:ae4146e039]
  • Maarre je hebt toch 1 kolom met de leeftijden en daarnaast de kolom met de ouwe lullendagen? Dus naast 21 t/m 44 staat 0 en dat vult hij dan toch in?
  • Neej: die heeft ie weggelaten; daarom krijgt ie N/B: ze zijn Niet Beschikbaar Dus. [quote:a9f9d0f01f]In de eertse kolom staan de leeftijden 16 t/m 20 jaar en 45 jaar en hoger[/quote:a9f9d0f01f]zie je?
  • Dan maak je die toch, buiten beeld weliswaar. Dat is het eenvoudigste.
  • Niet té bijdehand worden, hé? :x :wink:
  • Tja.. Eigenlijk ben ik Lotus123 gebruiker. Ik denk een van de laatste...
  • [quote:1c58fee196="yug"]... Ik zou willen dat als bijv. iemand 22 jaar is en dus geen recht heeft op deze uren er een 0 verschijnt. Hoe moet dit via een formule?[/quote:1c58fee196] Stel dat de leeftijden in A1:A30 staan en de bijbehorende dagen in B1:B30; stel bovendien dat de zoekleeftijd in D1 wordt ingevuld: [size=9:1c58fee196]=SOMPRODUCT((A1:A30=D1)*(B1:B30))[/size:1c58fee196]
  • Voor de aandachtige luisteraar: In Lotus zijn de cellen grote platen graniet waar je met hamer en beitel weken bezig bent om een eenvoudige formule te ehhh... formuleren; je kijkt dus wel twee keer uit voor je teveel werk verricht.
  • Ja ik ben er eenmaal aan gewend en heb geen zin om al die commando's opnieuw te leren.
  • Zonder een Belg in verlegenheid te brengen. Lotus 123 gebruiker zinds?, mensen heugenis! :o Heaas heeft exel, lotus bijna geheel over genomen (geen nieuws,M$ neemtbjna alles over). Greetz bye mike
  • Mannen hartstikke bedankt voor de spontane uitleg. De oplossing van aimable is voor mij de meest gunstige omdat ik nu geen extra kolom hoef te gebruiken. Nogmaals bedankt :P
  • Met gebruik van ISFOUT hoef je ook geen extra kolom te gebruiken hoor: [size=9:f8a6bce069]=ALS(ISFOUT(VERT.ZOEKEN(D1;A1:B30;2;0));0;VERT.ZOEKEN(D1;A1:B30;2;0))[/size:f8a6bce069] En in plaats van bovenstaande formule zou je er ook een kunnen maken die 0 als resultaat geeft als de ingevoerde leeftijd te hoog of te laag is. Kortom: mogelijkheden volop.
  • Ook deze formule met isfout werkt perfect jullie zijn geweldig. Volgens mij geeft hij al een 0 als resutaat als ik leeftijden invul die niet in de matrix staan. Alleen de formule met somproduct snap ik niet. Kun je mij uitleggen met woorden wat er nu precies gebeurt? :(
  • Hetzelfde als SOM.ALS(A1:A30;D1;B1:B30) Zoekt aan de hand van een waarde in D1 in A1:A30 en telt corresponderende waarden in B1:B30 bij elkaar op.
  • [quote:5d1d69e4ee="FlvanSon"]Hetzelfde als SOM.ALS(A1:A30;D1;B1:B30) Zoekt aan de hand van een waarde in D1 in A1:A30 en telt corresponderende waarden in B1:B30 bij elkaar op.[/quote:5d1d69e4ee]Dat is juist, en de functie SOM.ALS is hier de eenvoudigste (en naar mijn mening daarom de fraaiste) oplossing. Evenals somproduct kan SOM.ALS hier worden gebruikt omdat op voorhand bekend is dat in kolom A elke leeftijd slechts 1 keer voorkomt. Moest dat niet het geval zijn, dan zouden beide functies voor dit probleem niet geschikt zijn.
  • >>je kunt bij deze dus alle getallen(in D1) invoeren tussen de grootste en de kleinste; met vert.zoeken kijkt ie alleen maar botweg of 't getal in tekst voorkomt; zonee: FOUT.

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.