Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

Anders (software)

SE-lijst in excel

Aimable
2 antwoorden
  • LS,

    Ik heb al enige tijd mijn SE-lijst (cijferlijst van school) in een excel bestand verwerkt. Dit is heel handig want zo kan ik direct mijn gemiddelde zien. Nu wil ik achter het gemiddelde, in woorden (zes, zeven acht) mijn gemiddelden automatisch laten zien. Hiervoor had ik dit commando bedacht: (AA6 is de waarde van het gemiddelde)

    [code:1:14ad6ce45b]
    =IF(AA6<1,5;"één";IF(AA6<2,5;"twee";IF(AA6<3,5;"drie";IF(AA6<4,5;"vier";IF(AA6<5,5;"vijf";IF(AA6<6,5;"zes";IF(AA6<7,5;"zeven";IF(AA6<8,5;"acht"IF(AA6<9,5;"negen";IF(AA6<10,5;"tien"))))))))))
    [/code:1:14ad6ce45b]

    Het probleem is dat excel niet zulke lange commando's ondersteund (denk ik) ik krijg hem er wel ingetypt maar exel geeft dan een foutmelding en pas als ik hem na 8 afkap dan doet hij het…

    Wie o wie weet of er een makkelijker commando voor dit doel is, of weet iemand een truuk om excel langere commando's te laten ondersteunen?

    Bij voorbaat dank,

    Joost
  • A1 t/m A10: 1 t/m 10
    B1 t/m B10: een t/m tien

    Formule: =VERT.ZOEKEN(AFRONDEN(AA6;0);A1:B10;2)

    nog mooier; matrixje [i:36b8bf7d67]in[/i:36b8bf7d67] de formule:
    [code:1:36b8bf7d67]=VERT.ZOEKEN(AFRONDEN(AA6;0);{1;"een"\2;"twee"\3;"drie"\4;"vier"\5;"vijf"\6;"zes"\7;"zeven"\8;"acht"\9;"negen"\10;"tien"};2)[/code:1:36b8bf7d67]

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.