Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

Webdesign (HTML, CSS, Flash)

Streaming beelden met webcam

BasHamar
4 antwoorden
  • Doordat we drie jaar naar het buitenland vertrekken ben ik bezig met een website in elkaar te zetten waar we voor geautoriseerde familieleden en vrienden een live webcam op willen zetten. Als programma voor de webcam gebruik ik Webcam XP. Als ik binnen dit programma de http server (op mijnn eigen pc) activeer dan heb ik op mijn website streaming beelden, geen probleem dus. Maar dat kost, zeker vanuit het buitenland veel bandbreedte. Daarom wil het het laten lopen via ftp auto opload.
    Hieronder de instellingen:
    [u:6d39259841][b:6d39259841]Instelling via PC via webcam xp (http server)[/b:6d39259841][/u:6d39259841]
    <OBJECT classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,0,0" WIDTH="320" HEIGHT="240" id="webcamXP" ALIGN="">
    <PARAM NAME=movie VALUE="webcamXP.swf?webcam=http://80.100.123.11:1234/cam_1.jpg&refresh=15"><PARAM NAME=loop VALUE=false> <PARAM NAME=menu VALUE=false> <PARAM NAME=quality VALUE=high> <PARAM NAME=scale VALUE=noscale> <PARAM NAME=salign VALUE=LT> <PARAM NAME=wmode VALUE=opaque>
    <EMBED src="webcamXP.swf?webcam=http://80.100.123.11:1234/cam_1.jpg&refresh=15" quality=high WIDTH="320" HEIGHT="240" NAME="webcamXP" ALIGN="" TYPE="application/x-shockwave-flash" PLUGINSPAGE="http://www.macromedia.com/go/getflashplayer"></EMBED></OBJECT>
    [u:6d39259841][b:6d39259841]Instelling via ftp van webcam XP:[/b:6d39259841][/u:6d39259841]
    <OBJECT classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,0,0" WIDTH="320" HEIGHT="240" id="webcamXP" ALIGN="">
    <PARAM NAME=movie VALUE="webcamXP.swf?webcam=cam_1.jpg&refresh=15"><PARAM NAME=loop VALUE=false> <PARAM NAME=menu VALUE=false> <PARAM NAME=quality VALUE=high> <PARAM NAME=scale VALUE=noscale> <PARAM NAME=salign VALUE=LT> <PARAM NAME=wmode VALUE=opaque>
    <EMBED src="webcamXP.swf?webcam=cam_1.jpg&refresh=15" quality=high WIDTH="320" HEIGHT="240" NAME="webcamXP" ALIGN="" TYPE="application/x-shockwave-flash" PLUGINSPAGE="http://www.macromedia.com/go/getflashplayer"></EMBED></OBJECT>

    Via deze bovenstaande instelling lukt het dus niet via ftp auto upload.
    Heeft iemand enig idee wat ik bij webcam xp precies moet instellen en of bovenstaande code goed is?

    Alvast bedankt voor de moeite.

    p.s: http://home.hccnet.nl/l.g.ike
  • het lijkt wel of webcamXP het webcam plaatje niet upload; ik mis "cam_1.jpg" op de server.

    t.
  • Het rare is dat als we het via ftp autoupload laten lopen op de server in de root het bestand cam1.jpg staat. In de map index_bestanden hebben we het bestand webcamXP.swf gezet.

    [b:ffb3ed9710]Instelling via ftp van webcam XP: [/b:ffb3ed9710]
    <OBJECT classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,0,0" WIDTH="320" HEIGHT="240" id="webcamXP" ALIGN="">
    <PARAM NAME=movie VALUE="[b:ffb3ed9710]webcamXP.swf[/b:ffb3ed9710]?webcam=[b:ffb3ed9710]cam_1.jpg[/b:ffb3ed9710]&refresh=15"><PARAM NAME=loop VALUE=false> <PARAM NAME=menu VALUE=false> <PARAM NAME=quality VALUE=high> <PARAM NAME=scale VALUE=noscale> <PARAM NAME=salign VALUE=LT> <PARAM NAME=wmode VALUE=opaque>
    <EMBED src="webcamXP.swf?webcam=[b:ffb3ed9710]cam_1.jpg[/b:ffb3ed9710]&refresh=15" quality=high WIDTH="320" HEIGHT="240" NAME="webcamXP" ALIGN="" TYPE="application/x-shockwave-flash" PLUGINSPAGE="http://www.macromedia.com/go/getflashplayer"></EMBED></OBJECT>
    [b:ffb3ed9710]

    Zou het kunnen liggen aan de instelling van webcam xp? en zo ja, heeft iemand enig idee wat de juiste dan zouden kunnen zijn?
    [/b:ffb3ed9710]
  • [b:9362691627]Met deze instellingen:[/b:9362691627]
    <OBJECT classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,0,0" WIDTH="320" HEIGHT="240" id="webcamXP" ALIGN="">
    <PARAM NAME=movie VALUE="webcamXP.swf?webcam=http://home.hccnet.nl/l.g.ike/ftpcam_1.jpg&refresh=15"><PARAM NAME=loop VALUE=false> <PARAM NAME=menu VALUE=false> <PARAM NAME=quality VALUE=high> <PARAM NAME=scale VALUE=noscale> <PARAM NAME=salign VALUE=LT> <PARAM NAME=wmode VALUE=opaque>
    <EMBED src="webcamXP.swf?webcam=http://home.hccnet.nl/l.g.ike/webcamXP.swf/&refresh=15" quality=high WIDTH="320" HEIGHT="240" NAME="webcamXP" ALIGN="" TYPE="application/x-shockwave-flash" PLUGINSPAGE="http://www.macromedia.com/go/getflashplayer"></EMBED></OBJECT>

    lukt het nu om beelden op de site te krijgen. Alleen moet je op refresh (f5) drukken om een nieuw beeldje te voorschijn te toveren. Is het ook mogelijk om dat zonder tussenkomst van f5 te doen? Dus als je de pagina voor je hebt, b.v elke paar seconden het beeldje automatisch refreshed?

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.