Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

Webdesign (HTML, CSS, Flash)

Dreamweaver geeft backgrounds niet goed weer

carlobernardini
6 antwoorden
  • Ik heb een probleem, en ik weet niet zeker of het aan Dreamweaer ligt, dat als ik een preview van een site die ik aan het maken ben in dreamweaver wil zien, Internet Explorer de backrounds niet weergeeft… Hoe komt dit?

    Alvast bedankt
  • Ja, dat is moeilijk zo te zeggen. Kan meerdere oorzaken hebben.
    Kun je even de broncode plaatsen?
  • de broncode moet ok zijn, aangezien deze in Opera 7 gewoon werkt en door dreamweaver aangemaakt is. Nu deot hij het ineens wel nadat ik er een input box op geplaatst heb, maar toch is het vervelen omdat dit wel vaker gebeurd…

    Hier is de code:

    [code:1:c9fccf370d]<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
    <html>
    <head>
    <title>Test</title>
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
    </head>

    <body background="bg_dir/bg_bg_01.gif">
    <table width="650" border="0" align="center" cellpadding="0" cellspacing="0">
    <tr>
    <td width="150" height="100"><div align="right"> </div></td>
    <td height="100" colspan="3" background="bg_dir/bg_gamenation_topsite.gif"><div align="right">
    <table width="149" height="70" border="0" cellpadding="0" cellspacing="0">
    <tr>
    <td height="58" valign="top"><p><font color="#CCCCCC" size="1" face="Arial, Helvetica, sans-serif">Search
    for:<br>
    <input name="textfield" type="text" size="15" style="font-face:Arial,Helvetica,sans-serif; font-size:9; color:#333333; ">
    </font></p></td>
    </tr>
    </table>
    </div></td>
    </tr>
    <tr>
    <td width="150" height="400" rowspan="4"><table width="150" height="400" border="0" cellpadding="0" cellspacing="0">
    <tr>
    <td height="40" background="bg_dir/bg_menu_header.gif">&nbsp;</td>
    </tr>
    <tr>
    <td valign="top" background="bg_dir/bg_menu_content.gif"><blockquote>
    <p><font color="#333333" size="1" face="Arial, Helvetica, sans-serif">Forums</font></p>
    <p><font color="#333333" size="1" face="Arial, Helvetica, sans-serif">Workshops</font></p>
    <p><font color="#333333" size="1" face="Arial, Helvetica, sans-serif">News</font></p>
    <p><font color="#333333" size="1" face="Arial, Helvetica, sans-serif">Reviews</font></p>
    <p><font color="#333333" size="1" face="Arial, Helvetica, sans-serif">Search</font></p>
    <p><font color="#333333" size="1" face="Arial, Helvetica, sans-serif">Videocards</font></p>
    <p><font color="#333333" size="1" face="Arial, Helvetica, sans-serif">Awards</font></p>
    <p>&nbsp;</p>
    <p><span id=tick2>
    </span>

    <script>

    function show2(){
    if (!document.all&&!document.getElementById)
    return
    thelement=document.getElementById? document.getElementById("tick2"): document.all.tick2
    var Digital=new Date()
    var hours=Digital.getHours()
    var minutes=Digital.getMinutes()
    var seconds=Digital.getSeconds()
    var dn="PM"
    if (hours<12)
    dn="AM"
    if (hours>12)
    hours=hours-12
    if (hours==0)
    hours=12
    if (minutes<=9)
    minutes="0"+minutes
    if (seconds<=9)
    seconds="0"+seconds
    var ctime=hours+":"+minutes+":"+seconds+" "+dn
    thelement.innerHTML="<b style='font-size:12;color:lightgrey;font-face:Arial;'>"+ctime+"</b>"
    setTimeout("show2()",1000)
    }
    window.onload=show2
    //–>
    </script></p>
    </blockquote></td>
    </tr>
    </table></td>
    <td height="20" colspan="3" background="bg_dir/bg_header_topic_01.gif"><p><font color="#CCCCCC" size="1" face="Arial, Helvetica, sans-serif">
    &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Welcome at Game Nation</font></p></td>
    </tr>
    <tr>
    <td width="20" height="100" background="bg_dir/bg_topic_side.gif">&nbsp;</td>
    <td width="460" height="100" valign="top" background="bg_dir/bg_bg_02.gif"><p><font color="#CCCCCC" size="1" face="Arial, Helvetica, sans-serif">Testbox</font></p></td>
    <td width="20" height="100" background="bg_dir/bg_topics_rightside.gif">&nbsp;</td>
    </tr>
    <tr>
    <td height="20" colspan="3" background="bg_dir/bg_bottom_topic_01.gif">&nbsp;</td>
    </tr>
    <tr>
    <td height="137" colspan="3">&nbsp;</td>
    </tr>
    </table>
    </body>
    </html>[/code:1:c9fccf370d]
    Let maar niet op de rommeligheid ervan :wink:
  • ik heb zelf ook met dit probleem te maken gehad.
    Soms (vraag me niet waarom) zet dreamweaver een "/" voor de link naar je img.

    In jou geval kan het dus zijn dat dreamweaver er dit:

    [quote:d2dd87c632]<body background="/bg_dir/bg_bg_01.gif">[/quote:d2dd87c632]

    van heeft gemaakt. Dit veranderd dreamweaver soms zelf ook.
    Kortom goed letten op de "/"-en.
  • zou heel goed kunnen wat rullzer schrijft, de achtergond werkt bij mij in IE namelijk goed (ik heb het plaatje even vervangen door een eigen plaatje, zonder "/).
    Succes!
  • ooooh, ok, heel erg bedankt allemaal!
    Ik ga het vanmiddag even uitproberen, zal wel werken… Weer een minpuntje voor IE dus, Opera etc. herkennen dit wel gewoon :)

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.