Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

Webdesign (HTML, CSS, Flash)

div in div probleem met opera

Moos
5 antwoorden
  • Hallo allemaal,
    Ik heb een site gemaakt met daarin een achtergrond plaatje van een filmstrip aan de rechterkant met daarin een paar plaatjes die wisselen met een mouseover en/of aanklikbaar voor volgende pagina, in eerste instantie getest in IE6, alles goed.
    Toen ik ging kijken hoe dat eruit zag in Opera en Firefox kwam ik er achter dat de plaatjes in het filmstripje in FF net iets versprongen.
    Dat komt waarschijnlijk omdat FF padding en margins iets anders interpeteerd als IE en Opera.
    Dus ik had het idee om dan ook de plaatjes in een div te zetten om te kijken of het dan bij allemaal gelijk was en.. verdomd dat was zo.
    Dus alle pagina's aangepast, in IE en FF perfect maar in Opera waren de plaatjes ineens verdwenen, geprobeerd met z-index en allerlij andere dingen maar nix lukte, dus ik dacht ik maak even een voorbeeldje met wat ik bedoel om dat dan hier neer te zetten met de vraag " wat doe ik fout", wat blijkt.. het voorbeeld doet het wel en in de originele site werk het niet!!!
    Terwijl ik de code regels van HTML en CSS gewoon gecopieerd heb naar een nieuwe HTML en CSS en toch werkt het niet, HELP.
    Iemand enig idee!
    De testsite waar het wel werkt (in Opera) is: http://www.volcon.nl/test2/divindiv.htm en waar het niet werkt is http://www.volcon.nl iemand die kan kijken in Opera wat ik fout heb gedaan of zowiezo wat er mis is gegaan?? Ik ben er al de hele dag mee bezig maar kom er als nog niet uit.
    Moos
  • Kennelijk gebruikt niemand Opera gezien de reacties, ik heb het inmiddels opgelost met een relative positioning ipv absolute, maar het blijft vreemd.
    Moos
  • Ik heb wel Opera, maar wist simpelweg niet wat er aan de hand was :-?
    Gelukkig heb je het kunnen oplossen…
  • boelieboelie, was mijn verhaal niet duidelijk genoeg of kon je, net als ik, er niet achter komen waar het aan zou kunnen liggen?
    Moos
  • Het verhaal was niet helemaal duidelijk, maar het werd wel duidelijk toen ik met Opera die links bekeek.
    In de source zag ik inderdaad dat de html (en javascript) precies hetzelfde was, dus raar dat het toch verschilt. Kan misschien ook liggen aan een javascript-bug ofzo, ik gok maar wat, of misschien iets in je stylesheet, maar daar had ik niet uitvoerig naar gekeken, om eerlijk te zeggen.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.