Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

Webdesign (HTML, CSS, Flash)

Menuhulp - test

flabber
20 antwoorden
  • Hoi,

    Ik ben wezen knutselen met een menuutje, en vroeg me af of jullie 'm even kunnen testen voor me. Ik werk op 'n Mac en heb op dit moment geen PC met ie5 en 6 tot m'n beschikking.

    Ik heb 'n stuk menu gemaakt, met behulp van 'n website en Listamatic (website voor navs).

    Kunnen jullie me vertellen of dit menu ook goed werkt op de PC? Ik heb hem hier getest met Safari, en daar werkt hij prima. Onder ie/mac werkt hij niet naar behoren, en Firefox heb ik hier (nog) niet.

    Alvast bedankt!

    Joram

    ps.: http://www.motustudio.tk bevat de testpagina :)
  • Hij werkt in msie 6.0 (laatste) en ff 1.06. In MSIE zijn de uitklappers wat naar rechts verschoven (te ver). De opties in het menu doen overigens niks.
  • Hier in FF geen problemen
  • Topiie! :D

    Dat ie verschuift neem ik op de koop toe… hij werkt zo te horen verder prima. 't Kan inderdaad kloppen dat de linkjes het niet doen; die heb ik nog niet ingevoerd.

    Maar ie6 én Firefox doen het in 1x? Gewøldig! ;)
    Zien jullie de testschaduwtjes het ook trouwens? Waarschijnlijk zie je die alleen in Firefox en Safari, en niet in IE.
  • In IE 5.01/Win en IE 5.5/Win klapt Design uit onder Services, Services klapt uit onder Portfolio, etc.. Zoals Gerben al zei: het is verschoven.
  • Oh, zóveel verschoven? Ik dacht dat het om een paar pixels ging :(
    Is 't menu wel bruikbaar, of kun je daardoor niet bij 't dropdowngedeelte komen?

    Om dit goed te krijgen heb ik zeker een ie/win hack nodig? Of is er een gewoon stukje CSS wat ik kan toevoegen om het beter werkend te krijgen op ie/win?
  • Het menu verschuift inderdaad zoveel dat het moeilijk te gebruiken is.

    In IE is de link "web" onder "design" niet zichtbaar, en onder graphic staat een lege regel.

    Voor de rest vind ik de login onhandig, maargoed dat is mijn mening. :wink:
  • DIe login gaat nog weg… dat heb ik geprobeerd om te kijken of ik 't voor elkaar kreeg :P

    Maar ik heb ook een stukje code gekregen (ie-hack) die ik heb geïmplementeerd… hopelijk is ie nu wat ie-vriendelijker :)
  • ook al geupload? het geschuif is nog niet weg!
  • Ik heb een gewijzigde versie geupload, waarbij 't inlog gedeelte weg is.
    Ook zit er een extra stukje CSS in (gekregen) wat ervoor zou moeten zorgen dat 't menu wat gebruiksvriendelijker is in Internet Eplorer :)

    Iemand die dat voor me zou kunnen testen? :)
  • In IE is het geschuif nog steeds hetzelfde, waardoor de links moeilijk aan te klikken zijn.. In FF doet je menu het goed.
  • Bummer… dat extra stukje code hielp dus niet :(
    Iemand anders nog ideeën hoe dat verschuif van die submenu's zou kunnen worden opgelost? :o

    Safari en Firefox doen het goed in ieder geval, dus daar
    hoef ik me gelukkig niet zo'n zorgen om te maken, hehe.
  • Jammer dat de rest van de wereld surft met Internet explorer.
  • Wel of niet IE surfen maakt me eigenlijk niet zoveel uit, ook al is 't niet mijn voorkeur. IE (microsoft) zou eigenlijk eens een browser moeten maken die CSS wat beter ondersteund, want dit is natuurlijk 'bagger' ;)
  • Je moet de volgende code aan je css toevoegen:
    [code:1:c79fe20031]* html li ul {
    left: -36px;
    }
    [/code:1:c79fe20031]Het is getest dus…..

    het "* html" voor de "li ul" zegt dat het van toepassing is op een level hoger dan de <html> tag, die is er niet dus pakken de meeste browsers het niet, behalve IE!

    Gelijk even uploaden, dan kunnen we zien of het nu wel klopt!! :wink:
  • Ik heb 't stukje code toegevoegd, en vervangen voor een andere hack die er eerst in stond.

    Werkt ie nu wel goed onder IE/win? :roll:
  • Het werkt nu goed, behalve onder het menu design:
    [img:03f5b17980]http://havo.freewebsitehost.net/menutest.jpg[/img:03f5b17980]
    (Menu "design" in IE)

    Ik weet niet wat je fout doet…….. :cry:
  • Ik zie onder het menu Design geen fout …werkt prima volgens mij ..wat was de code doe je toegevoegd hebt ?

    greetz
    Fly
  • Het stukje van Cor wat hier een paar posts boven staat is het enige wat ik heb toegevoegd. Daarvoor versprong alle sybmenu's een stuk naar de zijkant :)
  • In FF 1.0.6 zit 'ie net iets naar links (i.p.v. dat de 'D' van Design in de dropdown recht onder D van Design staat, staat de 'e' onder die D (d.w.z. hij is één letter naar links verschoven).
    In IE6 zit het precies goed.
    In IE 5.x/Win is alles nog een beetje naar rechts (zo'n drie letters naar rechts), maar dat is niet zo heel storend.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.