Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

Webdesign (HTML, CSS, Flash)

CSS block werkt niet juist in IE7. Ik zit er doorheen.

thor2002
2 antwoorden
  • Diepe zucht. Jongens en meisjes, ik zit er even helemaal doorheen. Ik wil voor een kennis een leuke site in elkaar knutselen, maar loop telkens tegen gedonder met explorer aan.
    Heb ik in firefox eindelijk alles met behulp van CSS (grotendeels op Stu nichols' Cssplay gebaseerd) uitgelijnd en vormgegeven, zie ik plots in Explorer een paar giga storende zaken.
    Eerst even de voorbeeldsite: http://www.drimar.nl/test1.html

    Het gaat me alleen (nog maar) om de volgende twee 'rare' dingen:
    In css heb ik bij #foot een hoogte gedefinieerd van 18 px. Meer hoeft voor ij niet. Die stond nl. op 25. IN FF geen probleem, dat ding gaat in één moeite naar beneden. Niet in explorer. Daar blijft'ie lekker hangen!
    Dan een logo. Ik heb die in #foot2 gestoken. In CSS is dat een block, fixed met een vaste maat en uitgelijnd op links. Dat werkt leuk in FF. IN Explorer is het direct het begin van het eind…

    Wie kan mij een klein beetje op weg helpen, ik krijg zo genoeg van dat explorer…. :( :(

    Thor2002
  • [quote:952c38eefa="thor2002"]Het gaat me alleen (nog maar) om de volgende twee 'rare' dingen:
    In css heb ik bij #foot een hoogte gedefinieerd van 18 px. Meer hoeft voor ij niet. Die stond nl. op 25. IN FF geen probleem, dat ding gaat in één moeite naar beneden. Niet in explorer. Daar blijft'ie lekker hangen!
    [/quote:952c38eefa]Hm, die begrijp ik niet helemaal, bedoel je dat deze niet onder aan de pagina staat? Bij mij wel, met IE7.
    [quote:952c38eefa="thor2002"]
    Dan een logo. Ik heb die in #foot2 gestoken. In CSS is dat een block, fixed met een vaste maat en uitgelijnd op links. Dat werkt leuk in FF. IN Explorer is het direct het begin van het eind…
    [/quote:952c38eefa]Als je je css een beetje aanpast voor foot2, werkt het wel. Vervang[code:1:952c38eefa]background:url(logolinks.png)no-repeat;[/code:1:952c38eefa] eens door[code:1:952c38eefa]background-image:url('logolinks.png');background-repeat: no-repeat;[/code:1:952c38eefa]Moet het voor IE oplossen.

    Verder zag ik (met hulp van de W3C validator :wink:) dat er drie foutjes in je html staan: je gebruikt twee keer dezelfde id voor een div (pad3), volgens mij moet je daar een class van maken. Dan heb je rond regel 105 een div-afsluiter te veel staan. En als laatste: het is niet </br> maar <br /> (rond regel 128).

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.