Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

Webdesign (HTML, CSS, Flash)

Ik ben nieuw hier, en heb een simpel (?) vraagje.

Elegancedesign
10 antwoorden
  • Hoi Allemaal,

    Ik zal me eerst even voorstellen: Mijn naam is Karin, ik ben 41 jaar, en heb als hobby websites maken.

    Alhoewel ik nog een beginneling ben, de standaard html wel een beetje begrijp, probeer ik me beetje bij beetje te verdiepen in scripts en css. Tot nu toe werken de sites, die ik online gezet heb, best goed, en heb ik weinig 'online' problemen ondervonden.

    Maar nu heb ik voor iemand, die een eigen zaakje heeft opgezet, een voorlopige site (met enkel een logo en adresgegevens, in de vorm van een jpg-bestandje) online gezet.

    Ik krijg hem perfect geopend, maar volgens meneer krijgt hij thuis meteen de site van Google te zien, bij het intypen van de url. Ook andere mensen zouden hier 'last' van hebben.

    Waarschijnlijk is het probleem iets heel simpels, maar ik begrijp er echt niks van.

    Krijgen jullie DEZE[/color:aa72feadd9] site geopend? Heeft iemand een idee waar mijn probleem aan kan liggen?

    Groetjes Karin
  • Bij mij gaat het goed en in de broncode staat ook niets vreemds wat dat betreft (wel foute broncode, want geen doctype en depricated HTML, maar soit).

    Zou iets in de .htaccess kunnen zijn.
  • Hoi Ger,

    Dankje voor je snelle reactie…

    zoals gezegd ben ik nog een 'beginneling, en eerlijk gezegd zegt "doctype en depricated HTML" me niet zo heel veel. Heb snel even gegoogeld en kwam uit bij http://www.websonic.nl/tutorials/websitehtmlxhtml/html_doctypes.php

    Zou het hieraan kunnen liggen dat de site niet opent bij meneer?

    En kan ik het best de html voor Transitional gebruiken in de broncode?
  • Bij mij doet hij het ook.

    Anders moet je het even bij hem controleren. Misschien een probleem met ze pc…
  • [quote:c297571fc8="Elegancedesign"]zoals gezegd ben ik nog een 'beginneling, en eerlijk gezegd zegt "doctype en depricated HTML" me niet zo heel veel. [/quote:c297571fc8]Met alle respect, maar als dat je niet zoveel zegt, zou je eigenlijk nog flink wat moeten leren voordat je geld vraagt voor je diensten. Een goede doctype en goede code zijn essentieel om te kunnen zorgen dat de website zich gedraagt zoals je dat verwacht. Niet alleen in je eigen browser, maar in alle (moderne) browsers.
    [quote:c297571fc8="Elegancedesign"]Zou het hieraan kunnen liggen dat de site niet opent bij meneer?[/quote:c297571fc8]Nee. In je code staat *NIETS* wat het beschreven gedrag kan veroorzaken. Er staat simpelweg niets in wat linkt, niets wat doorverwijst of whatsoever. Dat zou je toch ook moeten zien als je zou weten wat je doet?
    Ik krijg het ook met geen mogelijkheid gereproduceerd, en de suggestie van blackhawdesign lijkt me ook veel logischer.
    [quote:c297571fc8="Elegancedesign"]
    En kan ik het best de html voor Transitional gebruiken in de broncode?[/quote:c297571fc8]"Het beste" is er niet. het ligt eraan wat je wil. De beste resultaten kun je over het algemeen bereiken met strict doctypes, maar dan moet je ook wel zorgen dat je code de declaratie van het stricte doctype volgt. Doet het dat niet, dan is transitional inderdaad vaak het meest voor de hand liggend, maar ook daar geldt dat het wel moet kloppen wat je doet.

    Echter maak jij je sites zo te zien in Frontpage. Ik heb daarom het idee (mede door wat je al eerder hebt opgemerkt) dat je zelf geen flauw idee hebt wat de code allemaal inhoudt. En dan wordt het lastig debuggen. Ook is je indeling met tabellen en allerlei inline html-styling een ramp. Ik bedoel maar:
    [code:1:c297571fc8] <tr>
    <td width="50%" height="20">
    <p align="center"><font size="1">&nbsp;</font></td>
    <td width="50%" align="center" valign="bottom" height="20">
    <font size="1">&nbsp;</font></td>

    <td width="50%" align="center" valign="bottom" height="20">
    <font size="1">&nbsp;</font></td>
    <td width="50%" align="center" valign="bottom" height="20">
    <font size="1">&nbsp;</font></td>
    <td width="50%" align="center" valign="bottom" height="20">
    <font size="1">&nbsp;</font></td>
    </tr>
    [/code:1:c297571fc8]Euh, 5x50%=250%… En waarvoor dient die hele rij eigenlijk? En waarom alles centreren, als er toch niets instaat? En waarom die font-size van 1 als er, wederom, toch niets instaat?

    Als je zou weten waar je mee bezig bent, zou je dit soort rare constructies niet op je site hebben staan.

    Bovenstaande komt misschien een beetje lullig over, maar ik vind dat als iemand geld vraagt voor haar diensten, diegene ook wel moet weten wat ze nu eigenlijk doet. In jouw geval denk ik dat een goed boek toch geen verkeerde investering is…
  • oefff… ik heb me ook een hobby uitgezocht… wordt meteen afgestraft :wink:

    Maar je hebt gelijk Ger, ik bak er niets van! Dat is ook een reden waarom ik hulp zoek! Neem aan dat jij ook 'ergens' begonnen bent, toch? Toch bedankt voor je advies hier! Ik zal er zeker wat mee doen!

    Ik denk inderdaad dat ik eens persoonlijk bij meneer van de site langs ga.
  • Als het al gebeurt bij het intypen van de URL, dan kan het nooit aan de website liggen. Zoals blackhawkdesign al zegt zou ik het eerder op de computer van de betreffende persoon zoeken.
    Ik heb het gechecked met Firefox, Internet Explorer, Safari, Opera en Chrome en ze doen het allemaal prima hier.

    Over de doctypes en deprecated HTML:
    Met een doctype vertel je de browser hoe hij de code moet interpreteren. Zonder goeie doctype kan een website 'onvoorspelbaar gedrag' geven omdat de browser soms als het ware iets anders begrijpt dan wat jij bedoeld.

    Deprecated HTML is HTML die je niet meer moet gebruiken. Dingen als <font> (niet meer toegestaan) en <b> (vervangen door <strong>) zijn deprecated. Ik zie ook dat je tabellen gebruikt voor je layout. Dat zijn allemaal dingen die je veel beter in je stylesheet kunt regelen. En juist dan is het verstandig om een goeie doctype te gebruiken.

    Maar dat staat allemaal los van het probleem van de Google doorverwijzing. Ik zou het echt op de computer van de gebruiker zoeken.
  • Geen probleem in Firefox 3.5.7 op Ubuntu Linux 9.10.

    Maar de code is bepaald niet foutloos:
    http://validator.w3.org/check?uri=http%3A%2F%2Fwww.joelectro.nl%2F&charset=%28detect+automatically%29&doctype=Inline&group=0

    Als je W3C-conform wil coderen, gebruik dan bijvoorbeeld de prima webpaginamaker Amaya (gratis ter beschikking gesteld door het W3C, om standaardconform website-ontwerp te stimuleren):
    http://www.w3.org/Amaya/

    Succes! :)
  • [quote:29dd14047f="pjotr123"]Geen probleem in Firefox 3.5.7 op Ubuntu Linux 9.10.

    Maar de code is bepaald niet foutloos:
    http://validator.w3.org/check?uri=http%3A%2F%2Fwww.joelectro.nl%2F&charset=%28detect+automatically%29&doctype=Inline&group=0

    Als je W3C-conform wil coderen, gebruik dan bijvoorbeeld de prima webpaginamaker Amaya (gratis ter beschikking gesteld door het W3C, om standaardconform website-ontwerp te stimuleren):
    http://www.w3.org/Amaya/

    Succes! :)[/quote:29dd14047f]

    Dankje Pjotr…. Hier heb ik dus ook écht wat aan!
    hihi, 't werkt intussen verslavend hoor! Die site is echt handig zeg! Ik heb 'm meteen bij mijn favorieten gezet.

    Maar nu duik ik mijn bed in. Morgen weer een nieuwe dag.

    Truste allemaal, en wellicht tot morgen!
  • Hoi,

    Ik weet niet of het probleem al opgelost is? Wat me opvalt is dat het domein pas een aantal dagen geregistreerd is (14-01-2010). Het kan soms even duren voordat het domein dan vanaf alle computers te bereiken is. Ook is het mogelijk dat de opdrachtgever het domein al bezocht heeft voordat deze actief was? In dat geval zou je hem even zijn dns records kunnen laten opruimen.. dan zou het moeten werken. Open hiervoor een DOS venster en voer het volgende commando uit: "ipconfig /flushdns". Dan zou het moeten werken.

    Gr

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.