Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

Webdesign (HTML, CSS, Flash)

[XHTML] Netscape 6 & Rowspan

None
8 antwoorden
  • Ik heb een forum gedownload en ben bezig deze 100% XHTML te maken. Op zich lukt dit aardig (ben er wel al 2 dagen mee bezig) maar nu ben ik tegen een probleem opgelopen.

    Als ik een thread bekijk met behulp van Netscape 6 dan krijg je bij het verticaal scrollen een probleem bij cellen die d.m.v. een rowspan meerdere rijen beslaan. Van deze cellen zie je namelijk de eigen achtergrondkleur niet meer maar de kleur van de pagina (of andere tabel in het geval van geneste tabellen). [Zie dit plaatje] [RealLife voorbeeld]

    Daarnaast is me ook opgevallen dat dit probleem zich alleen voordoet als je een tabel laat renderen via XHTML, dezelfde tabel in HTML werkt wel goed. Dit probleem is beperkt tot Netscape 6 (voor zover ik weet).

    Weet iemand een oplossing voor dit probleem? Alle hulp is welkom!

    Bij voorbaat dank,

    - Basje. [i:8ff9fde5cd](It's good to be back… :D )[/i:8ff9fde5cd]
  • Ik heb er in Mozilla geen last van, wellicht dus een van de vele onopgeloste bugs die nog in de mozillaversie zat die netscape heeft gebruikt. Ik vraag me af of het nuttig is om te proberen daaromheen te werken. In nieuwere versies zal het probleem zich hoogst waarschijnlijk niet meer voordoen.

    Je kunt je natuurlijk afvragen waarom je op dit moment het hele forum xhtml complient wil hebben. Dat wil zeggen.. hardstikke goed natuurlijk dat je je aan de standaard houdt, maar heeft het op dit moment een meerwaarde om als doctype xhtml mee te geven? Als dat het probleem is…
  • Bedankt voor je antwoord. Weet je toevallig of je Mozilla en Netscape 6 naast elkaar kan draaien? Verschillende browsers moet normaal gesproken natuurlijk kunnen, maar dit zijn eigenlijk dezelfde browsers en ik ben dan ook bang dat er bij de installatie gegevens van Netscape verloren gaan danwel niet meer toegankelijk zijn.

    En om je vraag te beantwoorden: ik vind gewoon dat een website zich moet conformeren aan een dergelijke standaard. In principe had dit natuurlijk net zo goed HTML 4.01 kunnen zijn, maar helaas is dat door praktische bekerkingen niet meer mogelijk. Ik gebruik namelijk de functie nl2br() en deze maakt in de huidige versie gebruik van <br />.

    Ik hoop dat je mijn nieuwe vraag kunt beantwoorden, maar sowieso bedankt voor je eerste reactie!

    - Basje.
  • Bij mijn weten zijn het twee aparte programma's die los naast elkaar kunnen draaien. Maaruh.. garantie tot aan de deur :p

    <br /> is overigens in principe ook correct html 4.
  • Een klein onderzoek van mijn kant heeft uitgewezen dat Netscape 6 alle gebruikerspecifieke bestanden opslaat in "C:\WINDOWS\Application Data\Mozilla\Profiles", en daarom acht ik de kans op problemen te groot om de twee naast elkaar te installeren.

    Dat wordt wachten op de volgende release van Netscape… :(

    - Basje.
  • Heb ik de DOCTYPE verandert, blijft het probleem! Alleen als ik de DOCTYPE volledig verwijder werkt het goed… Dan ga je toch twijfelen aan het programma, zoveel verschil kan het toch niet maken!? :-?

    Kloppen deze tags:[code:1:a96e8d0e7d]<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
    <!– Dit is een HTML 4.01 Transitional doctype –>

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <!– Dit is een XHTML 1.0 Transitional doctype –>
    [/code:1:a96e8d0e7d]

    Vááááááááááááááág! :o

    - Basje.
  • Ik heb al vaker gemerkt dat het een heel stuk kan schelen als je de doctype weglaat, vooral in ns6, maar ook in IE. Dingen die (volgens standaard) zouden moeten werken, werken opeens niet met een doctype erboven. Haal je die weg, dan loopt het als een zonnetje. Vandaar mijn eerdere opmerking.. Is het [i:49aac4a49d]op dit moment[/i:49aac4a49d] echt van toegevoegde waarde om die doctype erboven te zetten?
  • Antwoord: [b:68bdb34d98]NEE![/b:68bdb34d98]

    Bedankt voor alle hulp, ik vind het wel weer mooi zo… :)

    - Basje.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.