Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

Webdesign (HTML, CSS, Flash)

Loadmovie probleem met flash5, help me alsjeblieft.

None
1 antwoord
  • Load Movie probleem, Help Aub.

    Ik heb een movie gemaakt met een nieuwsscroller.
    Deze nieuwsscroller haalt de tekst uit een extrne .txt-file genaamd text.txt

    Hij scrollt dan de tekst die hij ophaalt uit de text.txt over een foto.

    Ik heb de file met onderstaand script gepubliceerd, en de output nieuwsscroller.swf werkt perfect.

    Dus wat is dan het probleem, kik even naar het script en daaronder vertel ik mijn probleem.


    Frame1
    x = 2;

    Frame2
    loadVariablesNum ("text.txt", 0);
    if (aaa ne "") {
    gotoAndPlay (4);
    }
    Frame3
    gotoAndPlay (2);


    Frame10
    gotoAndPlay (2);

    Frame12
    x = 1+((c/5000)*0.1);

    Frame13
    setProperty ("text", _y, 575-i);
    i = i+0.7*x;

    Frame 14
    if (i>=((c/20)*9)+(200-((340-c)*0.3))) {
    gotoAndPlay (10);
    } else {
    gotoAndPlay (13);
    }


    Nu wil ik deze movie in een andere movie laden met loadmovie.
    Ik laadt hem dan in een lege movieclip die ik op de stage heb geplaatst en de instancenaam placeholder heb gegeven.
    Ik gebruik daarvoor onderstaand script:

    loadMovie ("nieuwsscroller.swf", "placeholder");

    Dan gaat het mis,
    Als ik de movie start, dan zie ik dat hij netjes de achtergrondfoto van nieuwsscroller.swf laat zien, maar verder doet hij niets meer, ik zie geen text en scrollen doet hij dus ook niet.

    Ik heb natuurlijk al naar de debug informatie gekeken en daar komt het onderstaande uit.

    Debug info oject:

    Level #0: Frame=1
    Movie Clip: Frame=2 Target="_level0.placeholder"
    Movie Clip: Frame=1 Target="_level0.placeholder.instance1"
    Shape:
    Shape:

    Debug info variables:

    Level #0:
    Variable _level0.$version = "WIN 5,0,30,0"
    Variable _level0.aaa = "Welcome to our homepage, blablablabalbalbalbal "
    Movie Clip: Target="_level0.placeholder"
    Variable _level0.placeholder.x = "2"

    Wat ik hier uit kan halen is volgens mij dat de movie loopt tot frame 2 en dan stopt, ik snap echt niet waarom.
    Ik ben er al dagen mee bezig dus, alsjeblief help me.

    Tiny

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.