Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

Webdesign (HTML, CSS, Flash)

css stijlblok geeft geen weergave na uploaden

None
21 antwoorden
  • Wie kan mij helpen met het volgende:

    Ik heb een website gemaakt en daarin een stijlblok opgenomen. Vanaf mijn eigen computer wordt alles correct weergegeven, maar na uploaden kan ik helemaal geen pagina zien (melding: u heeft geen toegang). Als ik het stijlblok weghaal, is de pagina ook weer zichtbaar op internet.
    Ik heb het volgende ingevoegd:
    <STYLE TYPE="text/css">
    <!–
    BODY {
    font-size: 10pt; color: #990000; font-family: arial; text-decoration: none
    }
    TD {
    font-size: 10pt; color: #990000; font-family: arial; text-decoration: none
    }
    H1 {
    font-size: 14pt; color: #990000; font-family: arial; font-weight: normal;
    text-align: center
    }
    A {
    font-size: 10pt; cursor: hand; color: #990000; font-family: arial; text-decoration: none
    }
    A:hover {
    font-size: 10pt; cursor: hand; color: #990000; font-family: arial; text-decoration: underline
    }
    BODY {
    scrollbar-face-color: #ceccfb; scrollbar-arrow-color: #ffffff; scrollbar-track-color: #ffffff
    }

    –>
    </STYLE>

    Is er iemand van jullie die mij kan vertellen wat ik fout heb gedaan?
    Alvast heel hartelijk bedankt,

    Monique Janson


    :(
  • Je zowiezo 2 x een css deel voor de body opgenomen. Die kan je samenvoegen tot:
    BODY {
    font-size: 10pt; color: #990000; font-family: arial; text-decoration: none;scrollbar-face-color: #ceccfb; scrollbar-arrow-color: #ffffff; scrollbar-track-color: #ffffff;
    }

    Probeer verder elke css tag af te sluiten met een ";"
    Dus niet:
    TD {
    font-size: 10pt; color: #990000; font-family: arial; text-decoration: none
    }
    maar:
    TD {
    font-size: 10pt; color: #990000; font-family: arial; text-decoration: none[b:5bf8acf7d9];[/b:5bf8acf7d9][/color:5bf8acf7d9]
    }

    Verder kan je controleren of je de css code op de juiste plek in je pagina hebt gezet. Net voor </head> tag is een juiste plek.
  • [quote:d2ab1f0833="CyGho"]Je zowiezo 2 x een css deel voor de body opgenomen. Die kan je samenvoegen tot:
    BODY {
    font-size: 10pt; color: #990000; font-family: arial; text-decoration: none;scrollbar-face-color: #ceccfb; scrollbar-arrow-color: #ffffff; scrollbar-track-color: #ffffff;
    }

    Probeer verder elke css tag af te sluiten met een ";"
    Dus niet:
    TD {
    font-size: 10pt; color: #990000; font-family: arial; text-decoration: none
    }
    maar:
    TD {
    font-size: 10pt; color: #990000; font-family: arial; text-decoration: none[b:d2ab1f0833];[/b:d2ab1f0833][/color:d2ab1f0833]
    }

    Verder kan je controleren of je de css code op de juiste plek in je pagina hebt gezet. Net voor </head> tag is een juiste plek.[/quote:d2ab1f0833]

    Bedankt voor je hulp, maar helaas helpt het niet. Ik heb nog even de hele voorpagina toegevoegd (staat toch weinig in). Misschien kun je nog iets ontdekken aan tegenstrijdigheden of zo?
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
    <HTML><HEAD><TITLE>Mondi Talen, werelds in talen en communicatie</TITLE>
    <META http-equiv=Content-Type content="text/html; charset=windows-1252">
    <META content="M.J.M. Janson" name=author>
    <META content="Mondi Talen, werelds in talen en communicatie" name=organization>
    <META content=" 2002, M.J.M. Janson" name=copyright>
    <META NAME="keywords" LANG="nl" CONTENT="taleninstituten, taleninstituut, taaltrainingen, talenonderwijs,taalcursussen, talencursussen, talen, vertalingen, vertaalbureaus, bedrijfsopleidingen, copywriting,tekstschrijven, correctiewerkzaamheden, tolkservice, tolken">
    <LINK REL="start" HREF="http://kabel.netvisit.nl/~Janson01"
    <META NAME="description" LANG="nl" CONTENT="Mondi Talen is een unieke landelijke organisatie voor alle talen en communicatie, zoals taal- en communicatietrainingen, tekstschrijven, vertalingen en tolkservice.">
    <META NAME="robots" CONTENT="all, follow">
    <STYLE TYPE="text/css">
    <!–
    BODY {
    font-size: 10pt; color: #990000; font-family: arial; text-decoration: none;
    scrollbar-face-color: #ceccfb; scrollbar-arrow-color: #ffffff; scrollbar-track-color: #ffffff;

    }
    TD {
    font-size: 10pt; color: #990000; font-family: arial; text-decoration: none;
    }
    H1 {
    font-size: 14pt; color: #990000; font-family: arial; font-weight: normal;
    text-align: center;
    }
    A {
    font-size: 10pt; cursor: hand; color: #990000; font-family: arial; font-weight: bold; text-decoration: none
    }
    A:hover {
    font-size: 10pt; cursor: hand; color: #990000; font-family: arial; text-decoration: underline;
    }
    –>
    </STYLE>

    <META content="MSHTML 6.00.2800.1106" name=GENERATOR></HEAD>
    <body background="Mondi Talen_bestanden/janson1uitgerektjpg.JPG" bgcolor="#CCFFFF"
    text="#990000" link="#990000" aLink="#ff0000" vlink="#6600FF">
    <P align=center><IMG height=20
    <img src="Mondi Talen_bestanden/space.gif" width="580" height=20 alt="" align=bottom
    NATURALSIZEFLAG="0"><BR><BR>
    <P align=center> <H1>Welkom bij Mondi Talen</H1></P>
    <P align=center> <H1>Landelijke organisatie voor talen en communicatie</H1><BR><BR><BR></P>
    <P align=center>
    <IMG height=61 src="Mondi Talen_bestanden/space.gif" width=580 align=bottom border=0
    NATURALSIZEFLAG="0"><BR>
    <P align=center><img src="Mondi Talen_bestanden/Bol en naamjpg.JPG" alt="Mondi Talen, taal- en communicatiemanagement"
    border="0" NATURALSIZEFLAG="3"><br><br><br><P align=center><A
    href="Tekst_en_Beeld.html" TITLE="Copywriting, Redactie en Vertalingen" > <b>Tekst en Beeld</b></A> | <A
    href="trainingen.html" TITLE="Taal- en Communicatietrainingen" ><b>Trainingen</b> </A> | <A
    href="Zakelijke Communicatie.html" TITLE="Spreek- en Schrijfvaardigheden, Language Audits, PR" ><b>Zakelijke Communicatie</b></A><br><br> <A
    href="Info.html" TITLE="Informatie aanvragen" ><b>Informatie</b> </A> | <A
    href="Vacatures.html" TITLE="Ook een succesvolle, zelfstandige vestiging onder de naam Mondi Talen?" ><b>Vacatures</b></b></A>
    </P></FONT></CENTER></BODY></HTML>
  • 1: In Head:
    H1 {
    font-size: 14pt; color: #990000; font-family: arial; font-weight: normal;
    [b:5ebd416a59]text-align: center;[/b:5ebd416a59]
    }

    In body:
    <P align=center> <H1>Welkom bij Mondi Talen</H1></P>

    <p align=center> is overbodig, H1 staat door CSS altijd in het midden

    2: <body background="Mondi Talen_bestanden/janson1uitgerektjpg.JPG" bgcolor="#CCFFFF"
    text="#990000" link="#990000" aLink="#ff0000" vlink="#6600FF">
    <P align=center>
    Kan ook bij CSS worden gezet.
    a link, vlink en link bij:
    a: link, a: visited, a: active.
    (color: #990000;)


    3: ><[b:5ebd416a59]IMG height=20
    <img[/b:5ebd416a59] src="Mondi Talen_bestanden/space.gif" width="580" height=20 alt="" align=bottom
    NATURALSIZEFLAG="0">
    Dubbel <img.
    (en hoogte)
  • Ik heb je pagina even bij mij op de server gezet:
    http://www.cygho.nl/test.htm

    He tenige wat ik verwijdert heb was een halve image tag in regel 37:
    <IMG height=20

    Ziet het eruit zoals je bedoeld? Uiteraard zijn de plaatjes niet zichtbaar want die heb ik niet.
  • [code:1:26f98b9503]<LINK REL="start" HREF="http://kabel.netvisit.nl/~Janson01"[/code:1:26f98b9503]Hier mis ik wat aan het einde…
  • [quote:417ee2d038="CyGho"]Ik heb je pagina even bij mij op de server gezet:
    http://www.cygho.nl/test.htm

    He tenige wat ik verwijdert heb was een halve image tag in regel 37:
    <IMG height=20

    Ziet het eruit zoals je bedoeld? Uiteraard zijn de plaatjes niet zichtbaar want die heb ik niet.[/quote:417ee2d038]

    Geweldig! Het ziet er precies zo uit als ik bedoel. Nu moet ik nog even rustig bekijken wat ik precies heb fout gedaan. Maar eerst even een korte pauze, want mijn hoofd begint te draaien..
    Heb ook even op jouw website gekeken, ziet er leuk uit.

    En: hartelijk bedankt!!

    Monique
  • alles onder 1 body tag zetten heeft geen meerwaarde, alles afsluiten met een ; ook niet, het hoeft niet volgens de css specificatie. Het is wel netter, maar dat kan nooit zijn waarom het niet werkt.

    naast alle voorgaande opmerkingen ook nog deze:

    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">

    deze doctype is onbruikbaar, aangezien er verwezen moet worden naar een dtd op de server van het w3c, niet naar een dtd op je eigen server.

    http://www.htmlhelp.com/tools/validator/doctype.html
  • [quote:d85a7cf102="Jurriaan R"]alles onder 1 body tag zetten heeft geen meerwaarde, alles afsluiten met een ; ook niet, het hoeft niet volgens de css specificatie. Het is wel netter, maar dat kan nooit zijn waarom het niet werkt.
    [/quote:d85a7cf102]
    Klopt. Ik zei dat ook niet als zijnde een oplossing voor het probleem maar puur voor de netheid.
    Blijft vreemd dat de pagina bij mij op de server goed te zien is en bij haar niet
  • [quote:075f782f57="Jurriaan R"]<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">

    deze doctype is onbruikbaar, aangezien er verwezen moet worden naar een dtd op de server van het w3c, niet naar een dtd op je eigen server.[/quote:075f782f57]Waar je ook even alles hierover kunt lezen is op A List Apart

    - Basje.
  • [quote:04d64e2d72="BasHamar"][quote:04d64e2d72="Jurriaan R"]<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">

    deze doctype is onbruikbaar, aangezien er verwezen moet worden naar een dtd op de server van het w3c, niet naar een dtd op je eigen server.[/quote:04d64e2d72]Waar je ook even alles hierover kunt lezen is op A List Apart

    - Basje.[/quote:04d64e2d72]

    Nou, het is onbegrijpelijk. De pagina van Edwin kan ik prima zien, maar als ik die pagina zelf upload, krijg ik dezelfde foutmelding… Ik heb wel nog iets onder doctype toegevoegd, maar dat maakt hiervoor niets uit zo te zien :cry:

    Monique
  • [quote:2990263684="CyGho"][quote:2990263684="Jurriaan R"]alles onder 1 body tag zetten heeft geen meerwaarde, alles afsluiten met een ; ook niet, het hoeft niet volgens de css specificatie. Het is wel netter, maar dat kan nooit zijn waarom het niet werkt.
    [/quote:2990263684]
    Klopt. Ik zei dat ook niet als zijnde een oplossing voor het probleem maar puur voor de netheid.
    Blijft vreemd dat de pagina bij mij op de server goed te zien is en bij haar niet[/quote:2990263684]

    Dat is het inderdaad, en nog steeds werkt het niet en bij jou wel. Zou het nog iets te maken kunnen hebben met de manier van uploaden (doe ik in binary)?

    Groet,

    Monique
  • Aha! Daar ligt waarschijnlijk de fout, binary is alleen bedoeld voor plaatjes, programma's, MP3 enzovoorts. HTML en CSS moeten worden geupload in zgn plain text. Probeer dat eens, zal dan vast goed gaan.

    - Basje.
  • [quote:221eca253c="mjanson"]Zou het nog iets te maken kunnen hebben met de manier van uploaden (doe ik in binary)?[/quote:221eca253c]Ik gebruik ook altijd binary, nooit problemen mee gehad.
  • [quote:1202d4a7b5="BasHamar"]HTML en CSS moeten worden geupload in zgn plain text.[/quote:1202d4a7b5]Dus als ASCII?
    Nooit geweten, en nooit problemen gehad.
    Wat gebeurt er trouwens als ik "auto" gebruik? (WSftp).
  • [quote:a1d107e1c0="E gozeling"]Dus als ASCII?[/quote:a1d107e1c0]Ja.
    [quote:a1d107e1c0="E gozeling"]Wat gebeurt er trouwens als ik "auto" gebruik? WSftp.[/quote:a1d107e1c0]Dan bepaalt hij automatisch of het gewoon tekst of een binair bestand is en gebruikt automatisch de goede instelling.

    - Basje.
  • [quote:464cc59e5f="BasHamar"][quote:464cc59e5f="E gozeling"]Dus als ASCII?[/quote:464cc59e5f]Ja.
    [quote:464cc59e5f="E gozeling"]Wat gebeurt er trouwens als ik "auto" gebruik? WSftp.[/quote:464cc59e5f]Dan bepaalt hij automatisch of het gewoon tekst of een binair bestand is en gebruikt automatisch de goede instelling.

    - Basje.[/quote:464cc59e5f]

    Dan ga ik het nog één keer proberen,

    Monique
  • Ik heb de tekst van de pagina op het internet gezet, met een binary mode. Wordt gewoon goed weergegeven.
    (halve img tag verwijderd, die tag in de Head compleet gemaakt.)
  • [quote:1930137a65="E gozeling"]Ik heb de tekst van de pagina op het internet gezet, met een binary mode. Wordt gewoon goed weergegeven.
    (halve img tag verwijderd, die tag in de Head compleet gemaakt.)[/quote:1930137a65]

    Ik heb het nog even geprobeerd in ASCII maar het resultaat blijft onveranderd. Ik laat het nu eerst maar even rusten,

    In ieder geval alvast bedankt voor alle moeite en een fijne avond!

    Monique
  • Let ook even op dat in WSFTP LE de auto optie niet correct werkt.
    Probeer maar eens in de auto-modus een asci file te uploaden.
    Zul je zien dat ie gewoon in binary upload.
    Zit een foutje in heb ik gemerkt.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.