Vraag & Antwoord

Webprogrammeren & scripting

gd2 op windows 200o pro aan de praat krijgen

2 antwoorden
  • Beste mensen, Ik heb een image uploader 'in elkaar gezet'. Nu kun je zelf een thumbnail en plaatje tegelijk uploaden. leuk: maar ik wil alleen het plaatje uploaden; de website moet de thumbnail zelf maken. Ik heb het één en ander gelezen, maar ik snap nog niet helemaal waar de klepel hangt zullen we maar zeggen. Nu kan ik GD2 binaries? downloaden, maar mijn phpversie (4.3.1) ondersteund automatisch gd2, hiervoor moet ik in php.ini het volgende activeren: [b:625f696d05];extension=php_gd2.dll[/b:625f696d05] de '[b:625f696d05];[/b:625f696d05]' moet dan weg. Maar wanneer ik dat doe krijg ik de foutmelding: "Unknown(): Unable to load dynamic library './php_gd2.dll' - The specified module could not be found." Het probleem is dat hij de module niet kan laden. Dus ik op zoek naar het pad extension_dir. Daar ./extensions van gemaakt en het moet lukken: NEEN. Ik zoeken: logisch, in de php map bestaat niet eens een map extensions. Het ligt echt hieraan maar ik weet niet hoe ik dit op moet lossen. Mis ik nu een .dll bestand? Of moet ik die apart downloaden? (ik weet niet zeker of ik hier goed zit, maar aangezien het over php gaat.) d.
  • opgelost: (poe was wel ff zoeken) Heyyaa... I think I did it I didn't have extension_dir in my C:\PHP\ folder, so I just created one, and coppied all the .dll files into that folder. After that I change the line(in php.ini) extension_dir="./" to extension_dir="C:\PHP\extension_dir" and uncommented the extension=php_gd2.dll. and didn't get any error. Plus when I open phpinfo.php file in my browser, I see this: Quote: gd GD Support enabled GD Version bundled (2.0.15 compatible) FreeType Support enabled FreeType Linkage with freetype GIF Read Support enabled JPG Support enabled PNG Support enabled WBMP Support enabled XBM Support enabled

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.