Vraag & Antwoord

Webprogrammeren & scripting

[OPGELOST] Powerboard probleempje

6 antwoorden
  • Ik heb een forum geinstalleerd van Powerboard op mijn eigen PC-tje thuis. In eerste instantie had ik als adressen overal "Localhost" staan en tijdens het testen werkte alles naar behoren. Ik kon berichten plaatsen, registeren, mail sturen, alles. Het probleem begon toen mensen van buitenaf gingen proberen te registeren. Zij kregen een registratiemailtje met een link als http://www.localhost/blablablabla en dat werkt uiteraard niet. Vervolgens heb ik overal localhost veranderd in www.mijnsite.nl en vanaf dat moment kan iedereen van buitenaf bij mijn forum. Men kan registreren, berichten plaatsen, mailen, alles. Maaarrrrrrrrrrr, nu kan ik er vanaf mijn eigen PC-tje niet meer bij. Ik kan dus mijn eigen forum niet meer bekijken, administreren of wat dan ook :-( Voor de volledigheid zal ik er even bij vertellen dat ik een ADSL verbinding heb, dus ik kan geen gebruik maken van de URL www.eigensite.nl om mijn eigen site te bereiken, ik zal altijd gebruik moeten maken van localhost of mijn lokale IP-adres. Wie weet er een oplossing voor dit probleem ? John
  • Ik zie eigenlijk niet zo goed in waarom je niet gewoon http://www.mijnsite.nl/ kunt gebruiken... :-? Ook ik heb ADSL, maar via mijn eigen IP-adres - en dan bedoel ik niet het lokale adres - kom ik toch echt weer op mijn eigen server terecht, geheel naar verwachting dus. Weet je zeker dat je firewall wel goed is geconfigureerd e.d.? - Bas
  • Oké, nu begin ik even met mijn oren te klapperen :-( Het eerste dat ik uiteraard nu gedaan heb is mijn Firewall uitschakelen en het nog eens proberen maar ik krijg keurig netjes een melding dat de site niet gevonden is. Daaronder keurig netjes een aantal alternatieve sites genoemd die ik misschien zou kunnen zoeken met daartussen, jawel, mijn eigen site. Ik klik dus op de link naar mijn eigen site en wederom kan de site niet gevonden worden. Nu weet ik 100% zeker dat dit een probleem was wanneer je een eigen site lokaal ging draaien op het moment dat ik daar mee begon, ongeveer 4 jaar geleden ,toen ADSL net een beetje op begon te komen. De fora stonden toen vol met vragen waarom men zijn eigen site niet gewoon via de URL kon bereiken. Nu ik jouw verhaal lees begin ik onderhand te twijfelen of het soms een eigenschap kan zijn van het modem dat ik gebruik (ook al ruim 4 jaar oud dus) en dat het met modernere modems wel mogelijk is. Ik heb toendertijd het ISDN/ADSL ethernetmodem van meneer KPN bij mijn aanluiting gekregen (Alcatel Speedtouch Home). Is er hier misschien iemand die daar iets meer over weet ? Ik ben absoluut niet te beroerd om naar een ander modem uit te gaan kijken maar dan moet ik wel zeker weten dat ik daar iets mee opschiet. Alvast bedankt, John
  • Werkt je lokale ip adres (dus niet je ADSL ip adres) ook niet? Wat ik hier thuis doe is dat lokale IP adres toevoegen aan de hosts file van Windows en er dan hetzelfde domein als voor de buitenstaanders aan "knopen"...
  • Ja, het lokale IP-adres werkt absoluut wel maar het forum gebruikt de adressen zoals ik die in de configuratie heb opgegeven en dat is uiteraard de externe URL om de simpele reden dat gebruikers van buitenaf in de problemen komen wanneer ik daar het lokale adres invoer. Kun je mij vertellen hoe je dat "aan elkaar knopen" in een windows file doet ? Ik gebruik Windows XP Pro, dan wil ik dat wel eens proberen. Alvast bedankt, John
  • [quote:7fbd1b6ab6="John"]Kun je mij vertellen hoe je dat "aan elkaar knopen" in een windows file doet ?[/quote:7fbd1b6ab6]Gewoon een kwestie van het bestand [i:7fbd1b6ab6]hosts[/i:7fbd1b6ab6] zoeken (dus geen extensie) en er een regel aan toevoegen. Uitleg staat in het bestand zelf. Het pad is bij mij (WinXP Pro) [i:7fbd1b6ab6]C:\WINDOWS\system32\drivers\etc[/i:7fbd1b6ab6]. [quote:7fbd1b6ab6="John"]Nu ik jouw verhaal lees begin ik onderhand te twijfelen of het soms een eigenschap kan zijn van het modem dat ik gebruik [...] (Alcatel Speedtouch Home). [/quote:7fbd1b6ab6]Dat denk ik niet. Iig heb ik dezelfde modem, dus daar zal het niet aan liggen. Hooguit moet je de firmware updaten, maar dat is op eigen risico. Aangezien anderen 'm wel kunnen bereiken denk ik eerder dat het een configuratiefout is van Windows danwel de firewall of andere software dat met het netwerk te maken heeft. Probeer eerst wat Bill suggereert, grote kans dat het helpt. - Bas

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.