Vraag & Antwoord

Webprogrammeren & scripting

PHP onder Vista Ultimate 64bit werkt niet

8 antwoorden
  • Ik ben al maanden bezig om PHP aan de praat te krijgen onder Utimate 64 bit, helaas nog steeds zonder resultaat. Ik vond hier een handleiding: [url=http://3dohio.com/?p=14] LINK [/url] Deze kon ik probleemloos volgen t/m stap 12, de in de stap 13 genoemde map "AdminScripts" was niet op mijn systeem aanwezig. Deze map aangemaakt en het aangeroepen bestand, welk daar uiteraard ook niet stond, uitgevoerd nadat ik het gekopieerd had uit "Windows/system32". Dan een foutmelding dat het VBS script niet bestaat. Vervolgens C:/windows/system32/cscript.exe adsutil.vbs set W3SVC/AppPools/Enable32BitAppOnWin64 true geprobeert uit te voeren maar wederom met als resultaat dat het script niet bestond. Het probleem blijft dus denk ik dat ik de 32bits applicatie, wat php is, niet uit kan voeren. Wie kan mij aan een oplossing helpen dat ik php wel aan de praat krijg op mijn systeem ? Alvast bedankt, John
  • Een soortgelijk probleem kon ik oplossen door de optie 'Enable 32-bit Applications' aan te zetten in de ApplicationPool van betreffende site. Iets meer info vind je op onderstaande site en dan vnml. stap 7 en 8, al helpen die andere mss ook voor het aan de gang krijgen van PHP. [url]http://www.iishacks.com/index.php/2008/07/03/how-to-install-php-isapi-on-windows-2008-iis7-x64/[/url]
  • Na mezelf kleurenblind gezocht te hebben naar de application pool, de 32 bits applicaties ingeschakeld. Helaas nog zonder resultaat, ook na een reboot. Ik begreep dat er een application pool per website aan gemaakt kan worden, hier ga ik nog even mee aan de slag zodra ik gevonden heb hoe, zodat ik niet afhankelijk ben van de algemene application pool. Zijn er nog mensen met andere suggesties ?
  • Jaren geleden vond ik het zo typisch, dat kinderen van 13 een forum konden opzetten en dat het mij niet lukte. Totdat ik er bij toeval achterkwam waarom niet: Wat ik ook probeerde op m'n pc aan Apache of wat ook, het lukte van geen kant. Toen ik alles geupload had en het vanaf een server draaide ging het perfect !!!. Mijn advies aan jou is dus: neem een domeinnaam met webruimte (Transmega, 18 euro ex btw), dan ben je van een hoop problemen af EN je kunt er bij, waar ter wereld je ook bent. :wink:
  • hahaha, Ik heb zelfs een resellers account bij een hosting provider :) Het is mij er om te doen dat ik wijzigingen aan mijn websites niet online te hoeven doen met alle risico's van dien. Ik wil dus een kopie van mijn site's lokaal hebben draaien om te kunnen uitbreiden en testen maar dan wel gebruikmakend van dezelfde URL als waar de site opdraait en dezelfde database gegevens zodat het altijd werkt. :) Overigens heb ik PHP nu aan de praat, ik mis alleen nog een paar onderdelen. Ik heb ze al toegevoegd in het php.ini bestand maar nog even zonder resultaat. In ieder geval bedankt voor je reactie. John
  • :D :D :D Geinig ja. :lol:
  • Nadat ik PHP opnieuw geinstalleerd had, nu MET de installer zodat ook de DLL's geinstalleerd werden, heb ik alles aan de praat. Een ieder bedankt voor de hulp. John
  • had gewoon XAMPP gedownload ^^ werkt als een zonnetje

Beantwoord deze vraag

Weet jij het antwoord op deze vraag? Registreer of meld je aan met je account

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.