Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

Webprogrammeren & scripting

Php forum in frameset werkt niet?

Anoniem
E gozeling
10 antwoorden
  • Ik ben bezig met een nieuwe pagina te maken en hierbij maak ik gebruik
    van frames. Ik heb een het forum van webfanaat en die werkt prima maar
    als ik hem via de frameset probeer te benaderen dan doet hij het niet,
    ik krijg dan een foutmelding: "Fatal error: Unable to open
    gastenboek.php in Unknown on line 0". Ik heb ook geprobeerd hem in hem
    met javascript in een scherm bij 600 x 700 te openen maar dat lukt
    ook niet. Maar al bezoek ik het zonder frames werkt het wel.
  • Het lijkt erop dat de filename niet goed is.
  • Misschien een idee om te openen in een nieuw venster?
  • geef eens een URL?
  • Frameset staat niet online en het was trouwens het gastenboek maar dat maakt niet uit. De URL van het gastenboek: http://members.lycos.nl/simpage/gastenboek/gastenboek.php
  • vreemd, ik kan het gastenboek zonder problemen in een frameset plakken…

    gooi anders je frameset ook ff online..

    t.
  • Ik heb hem inmiddels in een frameset gekregen maar dan schakelt hij na een paar seconden door naar de begin directory bij lycos waar mijn forum in staat. (http://members.lycos.nl/simpage) Bij dat zelfde forum die ik er wel in kreeg schakelt hij na een paar seconden naar een heel scherm buiten de frameset om. hieronder staat de code van de frameset waar ik het gastenboek in geladen kreeg
    [code:1:47c5c7f38c]<html>
    <head><TITLE>Gastenboek</title>
    <FRAMESET rows="100%,*" scrolling=no border=0 framespacing=0 frameborder=0>
    <FRAME src=http://members.lycos.nl/simpage/gastenboek/gastenboek.php scrolling=auto border=0 frameborder=0 framespacing=0 >
    </FRAMESET>
    </head>
    <body>
    De browser die u gebruikt is niet geschikt om deze site te bekijken. U kunt het beste een nieuwe browser installeren. Deze is te downloaden bij <a href="http://www.microsoft.com">Microsoft</a> of bij <a href="http://www.netscape.com">Netscape</a>.
    </body>
    </html>[/code:1:47c5c7f38c]

    Alvast bedankt.
  • [quote:ca8a59096a]<FRAMESET rows="100%,*" scrolling=no border=0 framespacing=0 frameborder=0>
    <FRAME src=http://members.lycos.nl/simpage/gastenboek/gastenboek.php scrolling=auto border=0 frameborder=0 framespacing=0 >
    </FRAMESET>[/quote:ca8a59096a]
    Waarom staat er maar 1 frame, terwijl je bij frameset aangeeft dat er 2 zijn?
    [quote:ca8a59096a]</FRAMESET>
    </head> [/quote:ca8a59096a]
    Zet de frameset buiten de Head. (weet niet of het nodig is, maar zelf doe ik dat wel.
    [quote:ca8a59096a]<body>[/quote:ca8a59096a]
    Je kunt geen body combineren met frames, behalve als het iframes zijn.
    vervan <body> en </body> door <noframes> en </noframes>.
    (plaats die twee ook in de frameset.)
  • en dat is dan wel weer incorrect..

    gebuik [i:239d79e073]wel[/i:239d79e073] een <body> tag [i:239d79e073]binnen[/i:239d79e073] de <noframes> en zet die [i:239d79e073]buiten[/i:239d79e073] de frameset
  • Waar staat dan dat hij 2 frames gebruikt?

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.