Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

Webprogrammeren & scripting

PHPNuke vraag

Anoniem
sdk
4 antwoorden
  • Na geïnspireerd te zijn door het 4 delige artikel in de CT! over PHP en MySQL ben ik wat gaan expirimenteren met PHPnuke.

    1 site heb ik nu vlekkeloos draaien

    Nu mag ik van mijn provider 1 database hebben op mijn site, maar ik wil eingelijk 2 "sites" met phpnuke maken. en kan dus dmv een andere "prefix" extra tabellen toevoegen in de database.

    Standaard in phpnuke is de prefix "nuke-"
    als ik een nieuwe aanmaak (bv prefix "aragnite-") dan werkt het wel (twee sites in 1 db) op mijn eigen pc (apache en sql server geïnstalleerd) maar zodra ik de files upload naar mijn server, en de nieuwe tabellen aanmaak in de database, en de user, password, prefix en dbname etc aanpas in config krijg ik allemaal rare meldingen. (language fouten, theme fouten etc etc)

    als ik dan de foutmeldingen traceer zijn het foutmeldingen die ik niet kan plaatsen, want hij zou deze gegevens uit de database moeten halen. (na controle staat het ook goed in de tabellen!)

    ervaring leert me dat als ik alles verwijder en nogmaals upload en de database gegevens opnieuw opvoer dat het dan wel een keer moet lukken, maar niks!

    Heeft iemand hetzelfde probleem al eens gezien.?


    *extra gegevens*

    - heb phpnuke 6.9 EN 7.0 geprobeerd
    - gegevens lijken goed opgevoerd te zijn in de database
    - MySQL database
    - FlashFXP gebruikt om te uploaden
    - config in phpnuke aangepast (username, db, prefix)
    - diversen malen opnieuw ge-upload en db tabellen aangemaakt
  • ik meen dat er in config.php een $prefix en een $user_prifix te vinden zijn die standaard op "nuke" staan.

    misschien die veranderen bij de 2e site?
  • Dat heb ik juist ook uitgevoerd, want anders overschrijf je de reeds bestaande tabellen.

    Het vreemde is dat als ik het op mijn eigen pc simuleer gaat het goed, maar die ik hetzelfde bij mijn provider gaat het mis!

    Bedankt voor je reactie
  • http://dutchphpnuke.jokerwebs.com/
    Vragen stel je het liefst zo dicht mogelijk bij de bron.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.