Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

Webprogrammeren & scripting

localhost &jaar=2005, webserver &jaar=2

Anoniem
mosymuis
3 antwoorden
  • $jaar = $_GET["jaar"]+1;
    Als ik bovenstaand script op mijn laptop met lokale server draai krijg ik zowel in Internet Explorer als Firefox dit in de adresbalk "medew.php?mdw=1&jaar=2005"
    Als ik de pagina upload naar mijn webserver dan krijg ik in de adresbalk van Internet Explorer dit te zien: "medew.php?mdw=1&jaar=2"
    Vervolgens werkt het script dus niet meer, want die gaat uit van het jaartal dat in de adresbalk staat.
    Waar komt dit verschil vandaag en hoe kan ik het oplossen? Een php.ini-instelling?
    Misschien een versie-verschil? Op de lokale server heb ik versie 4.3.10 en op mijn laptop versie 5.0.3
  • Probeer eens om de waarde uit de querystring eerst expliciet te casten naar een integer, voor je er wat bij optelt.

    [i:8e234818b7](even uit m'n hoofd)[/i:8e234818b7]
    [code:1:8e234818b7]$jaar = ((integer) $_GET["jaar"]) + 1;[/code:1:8e234818b7]
  • Het probleem is al opgelost! Ik had op een andere pagina een verkeerde verwijzing getikt. Ik had daar mdw=$m_id&&jaar=$dit_jaar staat en op medew.php had ik overal de dubbele & weggehaald.
    :S

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.