Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

Webprogrammeren & scripting

Beveiligde pagina in beveiligde directory werkt niet.

Anoniem
Gooly
2 antwoorden
  • Wat ik probeer te doen:
    Ik wil een online webalbum installeren, maar dan in een beveiligde directory omdat dit album alleen toegankelijk moet zijn voor mensen met een wachtwoord. (Verder geen commerciele toestanden, maar een familie album en niet iedereen hoeft mijn gehele familie schermvullend in beeld te hebben of mijn dochtertje in haar luiertje te zien) Dit online webalbum heeft op zijn beurt weer een beveiligde admin pagina waar ik de instellingen kan wijzigen.

    Voorinformatie:
    Ik heb geen kaas gegeten van website beveiliging. Ik ben al blij dat ik met behulp van htaccess een beveilige directory heb kunnen maken. Maar geen idee hoe het allemaal precies zit met rechten e.d.

    Wat er goed gaat:
    Het bekijken van het album gaat prima. Als je de pagina opvraagt komt de browser met een standaard "wachtwoord popup prompt" en vraagt om inlognaam en wachtwoord. Nadat die zijn ingevuld is het album gewoon te bekijken.

    Wat er fout gaat:
    Wanneer ik naar het admin gedeelte wil komt de browser wederom met een popup en vraagt wederom om inlognaam en wachtwoord. (Lijkt me normaal, het admin gedeelte is namelijk afgeschermd) Deze worden echter niet geaccepteerd waardoor ik niet in staat ben om het admin gedeelte te bereiken.

    Ik heb de inlog naam en password van zowel beveiligde directory als de admin pagina hetzelfde gehouden, zodat er geen verwarring kan ontstaan.

    Ik heb het betreffende album ook in een niet-beveiligde directory geinstalleerd, en daar doet het probleem zich niet voor. Dan werkt alles prima.

    iemand enig idee hoe dit kan gebeuren, of nog beter, hoe het op te lossen?
  • Hallo,

    staat dit al ergens online ? Of kun je anders de source code plaatsen ?

    Groet,

    GNT

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.