Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

Webprogrammeren & scripting

Dropdown-menu-script geschikt maken voor Firefox

Anoniem
boelieboelie
4 antwoorden
  • Op http://simplythebest.net/scripts/DHTML_scripts/dhtml_script_101.html staat een "Horizontaal dropdown-menu-script".
    Dit script zou ik graag willen gebruiken, maar werkt helaas niet onder Firefox.
    Zou het misschien mogelijk zijn dit script met weinig middelen zo aan te passen dat ie het ook in Firefox doet? Voor de rest vind ik het namelijk een prima script.
  • In menu.js zie je af en toe [code:1:8e65cd1988]if(ie) //code

    else if(n) //code

    [/code:1:8e65cd1988]

    Er wordt dus alleen wat gedaan als of internet explorer of netscape navigator de browser is. als je "else if(n)" vervang door "else" verwacht ik dat het probleem opgelost is.

    Peter
  • Helaas, helpt niet.

    Ik herinner mij overigens nu iets over het gebruik van "layers" in JavaScript, dat Firefox dat niet zou ondersteunen of zo. En ik zie die term veelvuldig in het script voorkomen. Dit zou dan misschien betekenen dat ik toch een heel ander script nodig ga hebben, want er staat mij zoiets bij dat ik dat met een ander script heel lang geleden ook een keer moest doen. Kan dit kloppen?
  • mn javascript debugger zegt dat openclose niet te vinden is..

    tis misschien idd wel het beste om een ander menu te proberen. kijk eens op dynamic drive . daar zijn zat mooie te vinden!

    Peter

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.