Vraag & Antwoord

Webprogrammeren & scripting

ASP, mailto link maar éénmaal zichtbaar....?

Anoniem
None
3 antwoorden
  • Hoe zat het ook alweer….?

    Ik heb onderstaande code, waarin onderin een "mailto" link staat.
    [code:1:d01d2ace2a]
    while NOT RS.EOF
    %>
    <table width="500">
    <tr><td width="140" colspan="3" ></td>
    <td width="440" > </td>
    </tr>

    <tr><td width="20%"> </td>
    <td width="80%"><b><%=RS( "Woonplaats" )%></b></td>
    </tr>

    <tr><td width="5%"> </td>
    <td width="95%"><%=RS( "Voornaam" )%> <%=RS( "Achternaam" )%></td>
    </tr>

    <tr><td width="5%"> </td>
    <td width="95%"><%=RS( "Adres" )%> <%=RS( "Postcode" )%> <%=RS( "Woonplaats" )%></td>
    </tr>

    <tr><td width="5%"> </td>
    <td width="95%"><a href="mailto:<%=RS( "Emailadres" )%>"><%=RS( "Emailadres" )%></a></td>
    </tr>

    <tr><td width="140" colspan="3" ></td>
    <td width="440" > </td></tr>
    </table>
    <%
    RS.MoveNext
    WEND
    [/code:1:d01d2ace2a]
    Maar hij laat alleen de eerste emailadres zien…

    Ik heb in mijn css staan:
    [code:1:d01d2ace2a]
    body {font-family: Tahoma, Verdana, Arial;
    font-size: 8pt;
    background-color: #FFFFFF; }

    td {font-family: Tahoma, Verdana,Arial;
    font-size: 8pt;
    padding-left: 4pt;
    padding-right: 4pt;
    padding-top: 1pt;
    padding-bottom: 1pt;
    background-color: #FFFFFF;
    color: #000000; }

    a:link {color: #0033CC; text-decoration: none}
    a:visited {color: #0033CC; text-decoration: none}
    a:hover {color: #FF0000; text-decoration: none;}
    [/code:1:d01d2ace2a]
  • Hey! Ik herken die fout! Ik gebruikte een veld dat geen waarde had tijdens testen en was vervolgens verbaast dat ik geen waarde zag. Weet je zeker dat het veld dat je wilt hebben de juiste waarde heeft? :P
  • Jep, hij laat namelijk eenmaal een emailadres zien.

    Haal ik nu bijvoorbeeld dat "mailto" er voor weg, dan krijg ik alle waardes wel, maarja, dan zijn het geen mailto-hyperlinks meer.

    Dus het komt door "mailto", maar de vraag is waarom…

    wacht ff, deze fout KAN gewoon niet…..


    Shit, ik zie het al…het komt door de instellingen van Outlook.
    Die overrulen mijn CSS? Waardeloos….

    Oké, probleem opgelost.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.