Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

Anders (internet)

HTTP server in java en HTML forms

Anoniem
None
1 antwoord
  • Ik ben zelf bezig met het schrijven van een HTTP server, hij werkt nu grotendeels, maar als ik een HTML form naar de browser stuur, en dat form submit krijgt ik[quote:2e173a6318]De verbinding werd geherinitialiseerd[/quote:2e173a6318]
    De server laat wel zien dat de request binnen is gekomen, maar dat er niks in is gevult in het form, ookal is dat wel het geval.

    Met internet explorer werkt het wel gewoon, wat kan het probleem zijn?

    IE6 request
    [quote:2e173a6318]POST / HTTP/1.1
    Accept: image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, application/x-shockwave-flash, application/vnd.ms-excel, application/vnd.ms-powerpoint, application/msword, */*
    Referer: http://127.0.0.1/
    Accept-Language: nl
    Content-Type: application/x-www-form-urlencoded
    Accept-Encoding: gzip, deflate
    User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 2.0.50727; InfoPath.2)
    Host: 127.0.0.1
    Content-Length: 19
    Connection: Keep-Alive
    Cache-Control: no-cache

    test=Waarde+in+form[/quote:2e173a6318]
    FF2 request
    [quote:2e173a6318]POST / HTTP/1.1
    Host: 127.0.0.1
    User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
    Accept: text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
    Accept-Language: nl,en-us;q=0.7,en;q=0.3
    Accept-Encoding: gzip,deflate
    Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
    Keep-Alive: 300
    Connection: keep-alive
    Referer: http://127.0.0.1/
    Cookie: test=test[/quote:2e173a6318]

    Weet iemand wat dit probleem veroorzaakt?

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.