Vraag & Antwoord

Aanleg, installatie, instellingen

kan site niet online krijgen

Anoniem
.:ToBee:.
19 antwoorden
  • ik heb een site gemaakt maar heb problemen met het online zetten daarvan, de link begint met c: en dat levert de problemen op ik weet niet of ik op een verkeerde forum zit dus sorry daarvoor als dat zo is mss kunnen jullie mij helpen want ik ben het wel een beetje zat, er zitten uuren werk in die site en dan krijg ik hem niet online!!!
  • Wat heb je tot nu toe gedaan om hem on-line te zetten en waarmee?
  • je lost het probleem iig niet op door de crossposten:
    http://forum.computertotaal.nl/phpBB2/viewtopic.php?p=918391&highlight=#918391

    t.
  • je moet zorgen dat de site binnen je directory (map) werkt

    hierna alle linken langs lopen en de verwijzingen naar je harde schijf weghalen

    meestal beginnendn met c:/directory/directory

    dit zover weghalen tot je binnen je directory werkt

    heb je binnen je directory nog een gemaakt, moet je de laatste laten staan

    komt uit werkdirectory/subdirectory dan werkdirectory weghalen en de rest laten staan

    hierna weer test draaien of het nog werkt

    en dan pas uploaden
  • ik heb wel een xml bestand van de site en dat heeft de volgende link:

    C:\Program Files\Yahoo SiteBuilder\sites\test\site.xml

    maar dit kan ik zo niet online krijgen want het moet met http:// beginnen staat er dan als ik het probeer
  • C:\Program Files\Yahoo SiteBuilder\sites\test\site.xml

    je site staat dus in C:\Program Files\Yahoo SiteBuilder\sites\test\

    je moet minimaal een index.html hebben waar je site.xml aanroept

    heb je nog meer files/mappen in C:\Program Files\Yahoo SiteBuilder\sites\test\ staan?

    je site.xml nakijken op aanroepen van C:\Program Files\Yahoo SiteBuilder\sites\test\
    deze moeten alleen nog site.xml of betreffende map/file hebben

    je krijgt eigenlijk dan (provider/gebruiker/)bestandsnaam
    de (provider/gebruiker/) staat niet in je file.xml bestand
  • de map index.html staat daar inderdaad ook bij maar als ik die open zie ik geen template maar de rest van de site klopt
  • index.html is geen map maar een file die ook op je webstek moet staan
    dit is een ascii file
    met de belangrijkste delen van je site

    kijk hier is in en haal daar zeker de verwijzingen naar je c schijf weg

    je kan het in kladblok of een speciaal programma voor het bekijken van htm(l) bestanden openen

    bij het opslaan in kladblok wel even kijken of alle(*.*) bestanden geselecteerd staat als opslag plaats
  • even voor de duidelijk heid want ik ben hierin een beetje een n00b: wat is een webstek en moet ik index.html openen met kladblok en dan de verwijzingen naar de c-schijf weghalen? de bedoeling uiteindelijk is nm: ik heb al een bestaande .tk site en nu wil ik op diezelfde domeinnaam een andere site zetten, hoe dat moet weet ik want dat heb ik vaker gedaan maar toen had ik al een url want ik maakte die site's via een hulp site, nu doe ik dat dus niet en staat mijn site op de c-schijf als ik dan de nieuwe site op .tk wil zetten zeg hij dat de url met http:// moet beginnen dus moet ik gewoon de verwijzingen naar c: weghalen en http://ervoor zetten of de map op c: heel simpel ff via msn op het internet zetten(in de map rechterkant-dit bestand op het web publiceren en dan die url geven bij .tk of is er een betere manier of werkt dit niet?
  • [als aanvulling op sjouwer]
    Als ik het goed begrijp heb je met Yahoo SiteBuilder een site gemaakt op je eigen computer.
    die site is in de volgende map geplaatst; "sites"
    Die map staat op je C: schijf [b:e178a24582]in[/b:e178a24582] de map "Yahoo SiteBuilder" die vervolgens weer [b:e178a24582]in[/b:e178a24582] de map
    "Program Files" staat.
    Dat ziet er dus zo uit; "C:\Program Files\Yahoo SiteBuilder\sites"

    Maar waar het om gaat is de map "test" want daar zitten al je files in toch?

    De map "test" komt op de server te staan, dus on-line.
    In [b:e178a24582]die[/b:e178a24582] map moeten alle verwijzingen (links) eigenlijk beginnen met "test/" dus;

    _____test
    [list:e178a24582]|___site.xml[/list:u:e178a24582]

    De verwijzing vanuit index.html moet er dus zo uitzien; test/site.xml
    Maar: Als je vanuit een file [b:e178a24582]in[/b:e178a24582] de map "test" zelf naar een andere file [b:e178a24582]in[/b:e178a24582] de map "test" verwijst wordt het;
    file.html
    Als je [b:e178a24582]in[/b:e178a24582] de map "test" nog een andere map hebt staan b.v. "afbeeldingen" dan wordt de verwijzing vanuit index.html zo; test/afbeeldingen/afbeelding.gif

    Begint ie nu een beetje te vallen het kwartje?
  • <!–$sitebuilder version="2.1.1" md5="e676cb0dbde72356bc8c1b9b94c36bc3"$–>
    <!–$templateKey architectureStructureGrey$–>
    <html>
    <head>
    <title>Home</title>
    <meta name="generator" content="Yahoo! SiteBuilder/2.1.1/1.4.1_03">
    <!–$page size 900, 3000$–>
    <!–$fontFamily Arial$–>
    <!–$fontSize 10$–>
    <style type="text/css"><!–
    BODY {font-family:"Arial"; font-size:10;}
    P {font-family:"Arial"; font-size:10;}
    –></style>
    </head>
    <script>
    ns4 = document.layers && true;
    msie = document.all && true;
    function init() {
    }
    </script>
    <body bgcolor="#FFFFFF" text="#000000" link="#0000FF" vlink="#800080" onLoad="init()" onResize="if (ns4) history.go(0);" marginheight="0" marginwidth="1" topmargin="0" leftmargin="1" hspace="1" vspace="0">
    <table border="0" cellspacing="0" cellpadding="0" width="897" height="851">
    <tr>
    <td width="1" height="0"><!–$begin exclude$–><img src="sitebuilder/images/c.gif" height="1" width="1"><!–$end exclude$–></td>
    <td width="150" height="0"><!–$begin exclude$–><img src="sitebuilder/images/c.gif" height="1" width="150"><!–$end exclude$–></td>
    <td width="13" height="0"><!–$begin exclude$–><img src="sitebuilder/images/c.gif" height="1" width="13"><!–$end exclude$–></td>
    <td width="362" height="0"><!–$begin exclude$–><img src="sitebuilder/images/c.gif" height="1" width="362"><!–$end exclude$–></td>
    <td width="51" height="0"><!–$begin exclude$–><img src="sitebuilder/images/c.gif" height="1" width="51"><!–$end exclude$–></td>
    <td width="320" height="0"><!–$begin exclude$–><img src="sitebuilder/images/c.gif" height="1" width="320"><!–$end exclude$–></td>
    <td width="1" height="0"><!–$begin exclude$–><img src="sitebuilder/images/c.gif" height="1" width="1"><!–$end exclude$–></td>
    </tr>
    <tr>
    <td height="102" colspan="7" valign="top"><img src="clipart/pageHeaders/greenWindows.gif" width="898" height="102"></td>
    </tr>
    <tr>
    <td width="898" height="1" colspan="7"></td>
    </tr>
    <tr>
    <td width="1" height="382"></td>
    <td height="648" rowspan="4" valign="top"><img src="clipart/images/sidebars/BuildingGreyPhoto.gif" width="150" height="648"></td>
    <td width="426" height="382" colspan="3"></td>
    <td height="382" colspan="2" valign="top"><img src="images/lansink.gif" width="321" height="382"></td>
    </tr>
    <tr>
    <td width="1" height="11"></td>
    <td width="747" height="11" colspan="5"></td>
    </tr>
    <tr>
    <td width="1" height="66"></td>
    <td width="13" height="66"></td>
    <td nowrap height="66" valign="top"><span class="text"><b><font size="1"><span style="font-size:10px;line-height:13px;">Paragraph Title Here (What We Do)<br><br></span></font></b><font size="1"><span style="font-size:10px;line-height:13px;">Now that you've explained who you are, go ahead and say a little more <br soft>about what you do. Do you sell any products or services? Maybe you have <br soft>some industry-specific information to convey.<br soft></span></font></span></td>
    <td width="372" height="66" colspan="3"></td>
    </tr>
    <tr>
    <td width="1" height="189"></td>
    <td width="747" height="189" colspan="5"></td>
    </tr>
    <tr>
    <td width="898" height="100" colspan="7"></td>
    </tr>
    </table>
    <br><br>

    <div id="e4" style="position:absolute;left:239;top:33;width:174;height:34;"><span class="text"><font color="#FFFFFF" size="5"><span style="font-size:24px;line-height:29px;">dutch-horses.tk<br soft></span></font></span></div>
    <div id="e3" style="position:absolute;left:156;top:103;width:421;height:650;"><img src="images/actu_cso_dubbeldam.jpg" width="421" height="650"></div>
    <div id="e2" style="position:absolute;left:520;top:486;width:379;height:306;"><img src="images/ankey_2.jpg" width="379" height="306"></div>
    <div id="e1" style="position:absolute;left:379;top:709;width:160;height:143;"><img src="images/anky.jpg" width="160" height="143"></div>
    <div id="e0" style="position:absolute;left:5;top:108;width:140;height:125;"><!–$navbar
    name=dutch-horses.nav
    assetID=%NavbarAsset:/navigation_bars/dutch-horses.nav
    $–><!–$begin exclude$–><table border="0" cellspacing="0" cellpadding="0"><tr><td><a href="index.html" onMouseOver="document.images['i0'].src='sitebuilder/images/dutch-horses-0-mouseOver-85906.png'" onMouseOut="document.images['i0'].src='sitebuilder/images/dutch-horses-0-active-85812.png'"><img name="i0" src="sitebuilder/images/dutch-horses-0-active-85812.png" width="140" height="25" border="0" alt=""/></a></td></tr><tr><td><a href="aboutus.html" onMouseOver="document.images['i1'].src='sitebuilder/images/dutch-horses-1-mouseOver-86109.png'" onMouseOut="document.images['i1'].src='sitebuilder/images/dutch-horses-1-inactive-86000.png'"><img name="i1" src="sitebuilder/images/dutch-horses-1-inactive-86000.png" border="0" width="140" height="25" alt=""/></a></td></tr><tr><td><a href="contactus.html" onMouseOver="document.images['i2'].src='sitebuilder/images/dutch-horses-2-mouseOver-86296.png'" onMouseOut="document.images['i2'].src='sitebuilder/images/dutch-horses-2-inactive-86156.png'"><img name="i2" src="sitebuilder/images/dutch-horses-2-inactive-86156.png" border="0" width="140" height="25" alt=""/></a></td></tr><tr><td><a href="services.html" onMouseOver="document.images['i3'].src='sitebuilder/images/dutch-horses-3-mouseOver-86468.png'" onMouseOut="document.images['i3'].src='sitebuilder/images/dutch-horses-3-inactive-86343.png'"><img name="i3" src="sitebuilder/images/dutch-horses-3-inactive-86343.png" border="0" width="140" height="25" alt=""/></a></td></tr><tr><td><a href="blank.html" onMouseOver="document.images['i4'].src='sitebuilder/images/dutch-horses-4-mouseOver-86656.png'" onMouseOut="document.images['i4'].src='sitebuilder/images/dutch-horses-4-inactive-86515.png'"><img name="i4" src="sitebuilder/images/dutch-horses-4-inactive-86515.png" border="0" width="140" height="25" alt=""/></a></td></tr></table><!–$end exclude$–></div>
    <!–$begin exclude$–><div style="position:absolute;left:50;top:50;background:white"><font color=black>This file is not intended to be viewed directly using a web browser. To create a viewable file, use the <b>Preview in Browser</b> or <b>Publish to Yahoo! Web Hosting</b> commands from within Yahoo! SiteBuilder.</font></div><!–$end exclude$–>
    </body>
    </html>

    hierboven staat de index.html het begint dus niet met test/site.xml zoals je ziet en hieronder kan je de site.xml zien: dit is het eerste stuk:

    - <site>
    <preference key="MediaElement.path" value="C:\Documents and Settings\jeroenruit\Mijn documenten\Video's" />
    <preference key="OpenPageAction.recent" value="C:\Program Files\Yahoo SiteBuilder\sites\test\services.html|C:\Program Files\Yahoo SiteBuilder\sites\test\contactus.html|C:\Program Files\Yahoo SiteBuilder\sites\test\blank.html|C:\Program Files\Yahoo SiteBuilder\sites\test\aboutus.html|C:\Program Files\Yahoo SiteBuilder\sites\test\index.html" />
    <preference key="PictureElement.path" value="C:\Documents and Settings\jeroenruit\Mijn documenten\Mijn afbeeldingen" />
    <asset id="%LocalDirectoryAsset:/" />
    - <asset id="%PageAssetImpl:/aboutus.html">
    <refers-to id="%ImageAssetImpl:/sitebuilder/images/dutch-horses-0-inactive-85703.png" />
    <refers-to id="%PageAssetImpl:/contactus.html" />
    <refers-to id="%ImageAssetImpl:/sitebuilder/images/dutch-horses-3-inactive-86343.png" />
    <refers-to id="%ImageAssetImpl:/sitebuilder/images/thumbnails/navigation_bars/dutch-horses.png" />



    en dan nu het laatste stuk, alles wat in het midden staat laat ik achter wegen omdat het anders wel heel lang word:

    refers-to id="%PageAssetImpl:/sitebuilder/preview/aboutus.html" />
    <refers-to id="%ImageAssetImpl:/sitebuilder/preview/clipart/buttons/themes/chrome_teal/inactive.gif" />
    <refers-to id="%PageAssetImpl:/sitebuilder/preview/contactus.html" />
    <refers-to id="%ImageAssetImpl:/sitebuilder/images/dutch-horses-2-inactive-86156.png" />
    <refers-to id="%PageAssetImpl:/sitebuilder/preview/blank.html" />
    <refers-to id="%PageAssetImpl:/sitebuilder/preview/services.html" />
    <refers-to id="%ImageAssetImpl:/sitebuilder/images/dutch-horses-3-active-86406.png" />
    <refers-to id="%ImageAssetImpl:/sitebuilder/preview/clipart/buttons/themes/chrome_teal/mouseOver.gif" />
    <refers-to id="%ImageAssetImpl:/sitebuilder/images/dutch-horses-4-mouseOver-86656.png" />
    <refers-to id="%ImageAssetImpl:/sitebuilder/images/dutch-horses-1-active-86046.png" />
    <refers-to id="%ImageAssetImpl:/sitebuilder/preview/clipart/buttons/themes/chrome_teal/active.gif" />
    <refers-to id="%ImageAssetImpl:/sitebuilder/images/dutch-horses-2-mouseOver-86296.png" />
    <refers-to id="%ImageAssetImpl:/sitebuilder/images/dutch-horses-0-active-85812.png" />
    <refers-to id="%ImageAssetImpl:/sitebuilder/images/dutch-horses-1-inactive-86000.png" />
    <refers-to id="%NavbarAsset:/navigation_bars/dutch-horses.nav" />
    <refers-to id="%ImageAssetImpl:/sitebuilder/images/thumbnails/navigation_bars/dutch-horses.png" />
    <refers-to id="%NavbarAsset:/navigation_bars/dutch-horses.nav" />
    <refers-to id="%ImageAssetImpl:/sitebuilder/images/thumbnails/navigation_bars/dutch-horses.png" />
    <refers-to id="%NavbarAsset:/navigation_bars/dutch-horses.nav" />
    <refers-to id="%ImageAssetImpl:/sitebuilder/images/thumbnails/navigation_bars/dutch-horses.png" />
    </asset>
    </site>

    even om een idee tegeven wat er allemaal in staat en dit staat idd allemaal in de map: C:\Program Files\Yahoo SiteBuilder\sites\test
  • hoe zet je de site on-line?!
  • de bedoeling is uiteindelijk: ik heb al een bestaande .tk site en nu wil ik op diezelfde domeinnaam een andere site zetten(staat dus al op de c-schijf), hoe dat moet weet ik want dat heb ik vaker gedaan maar toen had ik al een url want ik maakte die site's via een hulp site, nu doe ik dat dus niet(yahoo sitebuilder) en staat mijn site op de c-schijf als ik dan de nieuwe site op .tk wil zetten zeg hij dat de url met http:// moet beginnen dus moet ik gewoon de verwijzingen naar c: weghalen en http://ervoor zetten of de map op c: heel simpel ff via msn op het internet zetten(in de map rechterkant-dit bestand op het web publiceren en dan die url geven bij .tk of is er een betere manier of werkt dit niet? misschien heeft een van jullie een betere manier o
  • [zucht!]
    Gebruik je een ftp programma om de site online te zetten of zit er een ftp mogelijkheid in het programa SiteBuilder of stuur je de site misschien per ptt post op?
    Dus hoe en waarmee?
  • C:\Documents and Settings\jeroenruit\Mijn documenten\Video's

    C:\Program Files\Yahoo SiteBuilder\sites\test\services.html|C:\Program Files\Yahoo

    dit gaat al niet

    je moet zorgen dat alles binnen een directory is

    C:\Program Files\Yahoo SiteBuilder\sites\test\

    alles wat hier buiten staat binnen deze directory maken en de links hierheen zetten

    je maakt, als het goed draait, dit weg – C:\Program Files\Yahoo SiteBuilder\sites\test\ –

    je maakt door dit weg te halen een floting directory van

    als je hierna nog een keer test moet het werken
  • ik heb het totaal anders geprobeerd en het met apache http server 2.0.52 geprobeerd een eigen site te hosten op mijn pc en heb gedaan wat hier stond: http://forum.fok.nl/topic/513268 maar nu heb ik mijn site op de juiste manier opgeslagen als daar staat uitgelegd maar dan doet ie het niet waar kan dat mee te maken hebben? omdat mijn ip: 82.215.3.81 is? ik zit namenlijk via draadloos netwerk tussen 3 pc's en router op het internet misschien is het nu ook wat duidelijker voor jullie
  • het gaat mij nu te ver naar wat ik weet.

    ik er hoop op dat andere je verder helpen

    groetjes arie
  • Het is misschien niet het beste idee om een eigen server te gaan beginnen, als qua html al een nieuweling bent. Dan is het installeren van een Apacheserver misschien een stap te ver, of je moet er al ervaring mee hebben.

    Is het niet een idee om eerst je site te hosten door een bestaande provider?

    De code die SiteBuilder van Yahoo uitspuugt is verder behoorlijk complex, aangezien SiteBuilder speciaal afgestemd is op de hostingmogelijkheden die Yahoo biedt.

    Ik denk dat de code van SiteBuilder laten werken op een eigen server een vrij onmogelijke klus is.

    In je html moeten verder alle verwijzingen naar "adressen" op je eigen computer weggehaald worden. Anders ga je op het internet verwijzen naar een map op je eigen computer, daar heeft een andere gebruiker uiteraard helemaal niets aan.
  • dus eigenlijk heb je twee problemen:

    1. juiste html schrijven.
    2. instellingen van je netwerk.

    Die laatste lijkt me even belangrijker (een eens je router goed instellen dan eens kijken of de pagina klopt).

    Dit topic heeft dus meer kans in netwerken.

    Move to…

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.