Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

Aanleg, installatie, instellingen

Netwerk: geen toegang tot XP

Nikki066
19 antwoorden
  • Ik heb op diverse fora de hele dag topics door zitten nemen maar het lukt me nog steeds niet om toegang te krijgen tot een XP-pc vanaf een Vista-pc (de Vista-pc is wel zichtbaar en bereikbaar met de XP-pc). Op beide pc's heb ik internet.

    De pc's zijn aangesloten bij dezelfde werkgroep en hebben verschillende pc-namen. Bij Vista staan netwerkdetectie, bestanden delen, openbare mappen delen en printers delen ingeschakeld, met wachtwoord delen staat uitgeschakeld. Op XP gedeelde mappen aangemaakt. Op beide pc's log ik in met een wachtwoord.

    Eigenschappen verbindingen:
    - Beide pc's hebben vaste IP-adressen (oplopend), subnetmask op beide pc's is 255.255.255.0, prim. & sec. DNS van internetprovider op beide pc's, NETBIOS via TCP/IP ingeschakeld op beide pc's.
    - Op beide pc's bestands- en printerdeling, client voor Microsoft netwerken, TCP/IPv4 en v6.

    Wat ik al heb gedaan:
    - Alle firewalls, antispyware en virusscanners uit.
    - Ping naar XP: doelhost niet gevonden.
    - Statische gewijzigd in dynamische ip-adressen.
    -Register gewijzigd op beide pc's, werd aangeraden op een ander forum (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa op 0 en HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters op 0)
    - LLTD-responder geïnstalleerd op XP-machine.
    - Radmin Advanced IP-scaner v1.5 gedraaid, resultaat: bij IP-adres vd XP machine geeft ie dead aan, terwijl de verbinding wel actief is (ik kan gewoon internetten en de Vista pc bereiken).

    Heeft er iemand nog tips?
  • Krijg je een foutmelding mbt onvoldoende rechten? Je ziet de XP machine ook niet op Vista?
  • Dank voor uw reactie. De Vista is te zien op de XP, ik kan in de mappen, shares aanmaken etc.

    Heb geen probleem met toegangsrechten. Als ik probeer van Vista op XP te komen dan is de XP niet te zien in het netwerkoverzicht en zodra ik \\pcnaam\gedeeldemap invoer krijg ik foutcode: "0x80070035. Kan het netwerkpad niet vinden". Shares aanmaken lukt ook niet. Uiteraard staan er op beide pc's mappen gedeeld.

    Nog wat extra info:
    Beide pc's hebben dezelfde gebruikersnaam + wachtwoord en de router heb ik diverse malen gereset.
  • kijk eens of je de lees schrijf rechten van de share wel hebt veranderd

    standaard geeft windows beperkte rechten
  • Ook dat heb ik gedaan, gebruikers mogen in de gedeelde mappen op de XP bestanden verwijderen en wijzigen.
  • De-installeer de antivirussoftware eens op beide machines.
    Dat is dus wat anders dan uitschakelen.
    Wat gebeurt er dan? (Wees in die tussentijd voorzichtig met internetten/mail openen)

    Ik had een soortgelijk probleem en vreemd genoeg bleek dat in de anti-virussoftware te zitten.
    De-activeren van de software was niet voldoende.
    Pas na de-installatie kon ik weer in mappen/bestanden kijken.
    Na herinstallatie van dezelfde AV-software werkte alles nog steeds naar behoren.
  • Bedankt voor de tip, ga ik morgen proberen. Dan ga ik eerst nog even de netwerkkaart eraf gooien en opnieuw installeren, kijken of dat helpt.
  • [quote:d5d6df9986="Nikki066"]Nog wat extra info:
    Beide pc's hebben dezelfde gebruikersnaam + wachtwoord en de router heb ik diverse malen gereset.[/quote:d5d6df9986]De router heeft niets met deze WIndows problemen te maken, te meer omdat er in ieder geval in 1 richting wel een goed verbinding is. Gebruikersnaam/wachtwoord zou bij een normaal Windows thuisnetwerk niet belangrijk zijn. Nu heeft Vista een optie die het wel belangrijk maakt, zelf zou ik die optie uitvinken.
  • Als je niet kunt pingen naar een bepaalde machine die volgens de routering wel beschikbaar zou moeten zijn, is het ICMP protocol niet geactiveerd / geblokkeerd. Hetzij in de router, hetzij in de PC (firewall, tcp/ip filtering)

    Staat er wellicht in de router dat verkeer naar bepaalde poorten ge- NAT moeten worden naar een specifieke machine ?
    Heb je static (persistent) route definities (ooit) op de XP machine gezet ?
    (controleer met start;uitvoeren;cmd;route print)

    Dit zou ook verklaren waarom je de shares op de XP machine niet kan benadren.
  • @ Ruud de Wit

    Dit was het probleem. Heb een permanente route toegevoegd op de xp. In Vista staat bij de permanente route de metric op standaard, bij XP op 1. Moet ie bij de XP ook op standaard staan en zo ja, hoe doe ik dat?

    Nu wel ping, maar XP is nog steeds niet zichtbaar in Vista…
  • Metric is alleen van toepassing bij een multirouted netwerk om zgn. 'preferred' routes op te geven. M.i heb je helemaal geen static routes nodig.
    Check tevens of de 'computer browser' service op de PC's gestart is, anders kun je niet op naam, maar enkel op ip. nr. shares koppelen (ervan uitgaande dat je geen WINS en/of DNS server in je netwerk hebt staan)
  • Computer browser service stond op beide pc gestart. Kan ik die static routes dus gewoon verwijderen van beide pc's? In de router staan alleen poorten geforward voor MSN en uTorrent.
  • Gewoon weggooien m.b.v. ROUTE DELETE . . . . .
  • Static route verwijderd van beide pc's: bij XP geen probleem, bij Vista internetverbinding kwijt. Ben het nu aan het herstellen op de Vista. Static route op de Vista was 0.0.0.0. subnet 0.0.0.0 dan 192.168.1.254 (adres router) en metric stond op standaard.
  • Heb op de Vista alles teruggezet, resultaat is nog steeds wel ping, maar XP niet zichtbaar op de Vista
  • Wat geeft ROUTE PRINT nu op je Vista machine, want je zou geen static routes nodig moeten hebben.
    Of je hebt een corrupte netwerkconfig op je Vista machine, of je hebt iets van malware op die machine die je routering in de war schopt.
  • Op de Vista:

    IPv4 routetabel
    ===========================================================================
    Actieve routes:
    Netwerkadres Netmasker Gateway Interface Metric
    0.0.0.0 0.0.0.0 192.168.1.254 192.168.1.21 281
    127.0.0.0 255.0.0.0 On-link 127.0.0.1 306
    127.0.0.1 255.255.255.255 On-link 127.0.0.1 306
    127.255.255.255 255.255.255.255 On-link 127.0.0.1 306
    192.168.1.0 255.255.255.0 On-link 192.168.1.21 281
    192.168.1.21 255.255.255.255 On-link 192.168.1.21 281
    192.168.1.255 255.255.255.255 On-link 192.168.1.21 281
    224.0.0.0 240.0.0.0 On-link 127.0.0.1 306
    224.0.0.0 240.0.0.0 On-link 192.168.1.21 281
    255.255.255.255 255.255.255.255 On-link 127.0.0.1 306
    255.255.255.255 255.255.255.255 On-link 192.168.1.21 281
    ===========================================================================
    Permanente routes:
    Netwerkadres Netmask Gateway-adres Metric
    0.0.0.0 0.0.0.0 192.168.1.254 Standaard
    ===========================================================================

    IPv6 routetabel
    ===========================================================================
    Actieve routes:
    Indien metrische netwerkbestemming Gateway
    1 306 ::1/128 On-link
    11 281 fe80::/64 On-link
    11 281 fe80::45a5:e66b:70b5:49fc/128
    On-link
    1 306 ff00::/8 On-link
    11 281 ff00::/8 On-link
    ===========================================================================
    Permanente routes:
    Geen


    Zodra ik die permanente route verwijder heb ik geen internetverbinding meer. Ik heb alles al gescand op virussen en spyware, niets gevonden…
    Het vreemde is dat ik de xp wel kan pingen maar 'm niet zie in Netwerk op de Vista (in verkenner typen lukt ook niet)
  • Een deel van het probleem is opgelost: er stond een foute IP in het Lmhosts bestand, dit heb ik aangepast. Het probleem ligt nu aan de firewall, zodra ik die uitzet heb ik volledig toegang tot beide pc's.
  • geef eens het lokale netwerk toestemming in je firewall

    bij zonealarm is dat door je lokale range vrij te geven in trusted zone

    ik weet namelijk niet welke je hebt

    maar de meeste hebben een mogelijkheid om je lokale netwerk vrij te geven

    even zoeken in de instellingen

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.