Vraag & Antwoord

Aanleg, installatie, instellingen

onduidelijk WiFi probleem Linksys WMP300N in PC

Anoniem
topdude
15 antwoorden
  • Snappen doe ik er helemaal niets van. Niet van (draadloze) netwerken en al helemaal niets van het probleem dat zich nu voordoet.
    Ik zal proberen het zo goed mogelijk te beschrijven.

    Ik heb een Zyxel 2602 modem. Daarvan weet ik zeker dat dat goed werkt. Provider heeft lijn gecheckt en is ok.
    Ik heb een Linksys WRT54G router. Versie 2.1 die is voorzien van Tomato 1.23 firmware.
    Ik heb een bijna 5 jaar oude laptop met XP Pro en servicepack 3 NL erop.
    Ik heb een redelijk nieuwe PC met Vista Ultimate, die draadloos moest na het omtoveren van mijn werkkamer tot kinderkamer en ik dus elders in het huis moest gaan zitten. Oud huis, geen beton.

    Met de laptop draadloos is er weinig aan de hand. Dat wil zeggen, als ik de laptop opstart gaat hij wachten op een IP-adres. Ik heb zowel bij de laptop als bij de pc automatisch IP adres krijgen ingesteld. Welnu, als de laptop is opgestart dan krijgt hij meestal een IP adres 192.168.1.118 of een hoger nummer. Internet werkt dan niet. Ik druk dan even op de knop draadloos op de laptop, ding gaat uit en aan en hij krijgt een nieuwe IP adres. Als dat adres is 192.168.1.33 of 34 of 35 is, dan werkt het internet zonder problemen. Alles snel en goed en een stabiele verbinding die blijft. Waar ik met de laptop zit maakt niet uit. Ook op zolder is er goede ontvangst.

    Met de pc is het een ander verhaal. Die zet ik aan en soms heb ik dan meteen internet, maar meestal dus niet. Ik weet niet hoe ik moet zien wel IP adres de pc krijgt in Vista. Maar in netwerkverbindingen moet ik dan de adapter eerst uitschakelen, dan weer inschakelen en dan heb ik verbinding. Soms blijft die 2 minuten, soms 20 minuten, soms 2 uur, soms een hele dag, er is geen pijl op te trekken.
    De adapter is goed geinstalleerd, geen foutmeldingen of zo. Als de verbinding er is, dan is die ook snel en de ontvangst op die plek is"zeer goed" volgens Vista.

    Nu is het ook zo dat die adapter het soms helemaal opgeeft. Dan kom ik met verbinding tot aan de router en krijg ik helemaal geen internet. Ik heb ondertussen ook een WMP54G kaartje geprobeerd, maar daarmee krijg ik helemaal niks. Geen enkele verbinding, terwijl is vastgesteld dat het kaartje wel werkt.
    Ik heb die 300N kaart ook al in een ander PCI slot gestopt, maar ook dat mocht niet baten. Het verschijnsel blijft hetzelfde.

    Het verschijnsel van de onderbroken verbinding doet zich voor of de laptop nu wel of niet aanstaat. Binnen het netwerk kunnen pc en laptop ook gewoon elkaar zien en zijn ze te benaderen.

    De PC verbinding zit soms ook te zeuren over DNS. De laptop hoor ik daar nooit over.

    Ondertussen is het om gek van te worden. Zoals gezegd heb ik er weinig kennis van en ook hulptroepen die ik heb ingeroepen kunnen het niet oplossen.

    Weet een expert hier misschien meer?
  • zou best een kanaalprobleem kunnen zijn, juist omdat het zo onvoorspelbaar is. op sommige plekken is sprake van storingen (door buren met ook een draadloze router bijv) en in hoeverre dat dan echt stoort hangt ook weer af van de apparatuur. dus twee päparaten naast elkaar kunnen heel verschillend reageren…
    lees even in de handleiding hoe je in de router komt om de instellingen aan te passen, en experimenteer dan eens even een tijdje met verschillende kanaalinstellingen.
    vergewis je ervan dat je in de routerinterface de wijzigen opslaat voordat je de pagina verlaat, anders haalt het natuurlijk niks uit.
    (het is niet ongebruikelijk dat je de draadloze pc/laptop even opnieuw moet opstarten na zo´n router-aanpassing)
  • Het mooie van tomato firmware is dat je dat ding kunt laten uitzoeken wat het beste kanaal is. Buren zitten op 2 en 6 en op 11 had ik het beste signaal, dus dat genomen.
  • tja, wellicht is 8 op die bewuste plek wel minder gevoelig…… :wink:
  • Overigens doet zich ook het volgende fenomeen voor:
    terwijl in firefox, danwel IE geen internetpagina's meer op te roepen zijn, gaat een download uit een nieuwsgroep met AltBinz wel met volle snelheid door. Er is dus wel een verbinding, maar niet met internetpagina's.

    Ik snapte het al niet, maar dit gaat ver boven mijn pet.
  • (quote)Ik heb een Zyxel 2602 modem. Daarvan weet ik zeker dat dat goed werkt. Provider heeft lijn gecheckt en is ok.
    Ik heb een Linksys WRT54G router. Versie 2.1 die is voorzien (/unquote)

    Ik vermoed dat beide routers (ik neem aan dat de zyxel in router mode staat) in het zelfde subnet zitten (lees IP range) Verander het start IP van de linksys naar 192.168.[b:fbea09aa40]2[/b:fbea09aa40].1
    Na save, wel even de clienten nieuw IP op laten vragen.
  • Maar dat verklaart toch niet waarom de laptop wel in contact blijft en de pc niet?
    Ook als de laptop niet aanstaat kan ik met de pc geen pagina's op internet meer openen. Ik heb zelf het idee dat het daar ergens zit.
  • Jammer dat je niet direct even bevestigd of beide routers in hetzelfde subnet zitten. Als dat het geval is en op beide ook dhcp draait, pakt die dan eens die en dan weer eens de ander (dat verklaard ook de verschillende/wisselende IP's). Als gevolg een loopback op de gateway en geen internet. Dus ff checken en aanpassen.
  • OK, ik kijk in de linksys en zie staan:

    connection type: DHCP
    IP adres: 0.0.0.0.0
    Gateway: 0.0.0.0
    Subnetmask: 0.0.0.0
    DNS:
    MTU: 1500

    LAN

    Router MAC Address 00:0F:66:57:4D:46
    Router IP Address 192.168.1.1
    Subnet Mask 255.255.255.0
    DHCP 192.168.1.100 - 192.168.1.149

    In de zyxel staat:

    DHCP: server
    Client IP Pool Starting Address: 192.168.1.33
    Size of Client IP Pool: 32
    Primary DNS Server: 0.0.0.0
    Secondary DNS Server: 0.0.0.0
    Remote DHCP Server: N/A

    TCP/IP

    IP Address: 192.168.1.254
    IP Subnet Mask: 255.255.255.0
    RIP Direction: None
    RIP Version: N/A

    Het zegt me allemaal niets en ik heb dan ook echt geen idee of ik nu de juiste informatie heb verstrekt.
  • Ok, Duidelijk dus dat je 2 dhcp server hebt draaien en daarnaast de WAN poort van de linksys niet gebruikt.
    Als je deze situatie wilt behouden, dan de Linksys vast IP geven 192.168.1.155 en de dhcp server op deze uit zetten.
    OF
    Als je de WAN poort wilt gebruiken, dan de linksys start IP veranderen naar 192.168.2.1 de kabel van de zyxel van lan naar WAN in de linksys. DHCP aan laten op beiden.
  • Nou, aangezien ik geen flauw benul heb van wat ik ga doen, laat ik de kabels maar zo zitten zoals ze zitten.
    Dan moet ik dus in de linksys een ip veranderen.
    Moet dat dan met een kabeltje erin en dan veranderen?
    En euh,

    Moet ik dan onder het hoofdstuk WAN/Internet in de linksys DISABLED aanvinken?
    En daaronder staat dan het huidige IP van 192.168.1.1 en dat moet ik veranderen in 192.168.1.155?

    Heb ik dat zo goed begrepen?

    En dan daarna de pc en laptop opnieuw opstarten?

    Ik ga dat dadelijk doen hoor, maar ik snap dan toch nog niet goed waarom de laptop dan wel continu in staat blijft om internetpagina's te openen en ik de netwerkkaart in de pc onder Vista/netwerkcentrum opnieuw moet laten instellen. Die doet het dan weer voor onbepaalde tijd en daarna moet ik dan de truc herhalen.
  • herhaling "Als je deze situatie wilt behouden, dan de Linksys vast IP geven 192.168.1.155 en de [b:3ade51e22c]dhcp server op deze uit [/b:3ade51e22c]zetten"
  • Ik heb het zojuist toegepast. Op de laptop was de verbinding al geen probleem, ik zal nu afwachten en berichten hoe de verbinding met de pc boven zich gaat houden.
  • update: Ik heb niet de hele tijd de pc aangehad wegens tijdgebrek, maar die keren dat ik hem aanhad, werkte het prima!!! :D

    peterkramer is een grootheid.

    Maar dan ben ik toch nog steeds heel benieuwd naar het WAAROM van het achterliggende probleem. Ok, ik snap nu dat 2 apparaten geen DHCP kunnen doen, maar waarom heeft mijn laptop hier dan geen last van en mijn pc wel?
  • Omdat de draadloze adapters wel op de linksys moesten aanmelden, die is immers draadloos, werd ook op deze dhcp server een lease (ip) aangevraagd. Dat de bedraade pc's op de zyxel een lease (ip) aanvroegen, is meer geluk dan wijsheid. Mogelijk dat de zyxel meer arp's stuurt dan de linksys en het principe wie het eerst komt ……

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.