Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

Servers

webserver

jeroen951
36 antwoorden
  • goedemorgen,

    ik heb de server die bij Windows XP Pro zit geinstalleerd.
    Hij staat nu op C:\Inetpub
    Hoe kan ik deze server van buitenaf bereiken? Is dat door mijn eigen ip adres in te typen?
    En ik zit achter een router, dus achter een firewall, moet ik dan in de router nog wat aanpassen met port redirection of iets dergelijks?
    En met welke poort zou ik dat dan moeten doen?
    Kan iemand me verder helpen en zeggen wat ik nu moet doen?

    Jeroen
  • Je eigen PC kun je benaderen door als IP adres 127.0.0.1 in te typen.

    Als je server vanaf het internet benaderbaar moet zijn moet je inderdaad een poort openzetten en op je router die port forwarden naar je PC. Welke poort dat is hangt af van het soort server. HTTP gebruikt poort 80, FTP poort 21 enz.
  • En hier je eigen IP-adres: :D


    [img:1302506075]http://www.danasoft.com/sig/Belg.jpg[/img:1302506075]
  • Het is een HTTP-server.
    Als ik 127.0.0.1 invoer in internet explorer moet ik een wachtwoord invullen, ik heb het wachtwoord dat ik gebruik om in te loggen op XP ingevuld, maar dat is het niet,dan zou ik het niet weten.
    Wat voor wachtwoord zou dat moeten zijn?
    En als ik de port-redirection moet instellen krijg ik een foutmelding.
    Eerst krijg ik dit scherm: [img:927d0364ba]http://home.wanadoo.nl/fam.vanweeghel/Jeroen
    outer1.JPG[/img:927d0364ba]
    Dat wat er staat heb ik dus ingevuld.
    Daarna krijg ik deze foutmelding: [img:927d0364ba]http://home.wanadoo.nl/fam.vanweeghel/Jeroen
    outer2.JPG[/img:927d0364ba]
    Ik heb geen idee wat het betekent, ik heb geprobeerd om in dat eerste scherm nog active aan te vinken, maar dat maakt ook geen verschil.
    Kan iemand me verder helpen?

  • [quote:ed38bf3860="Belg"]En hier je eigen IP-adres: :D


    [img:ed38bf3860]http://www.danasoft.com/sig/Belg.jpg[/img:ed38bf3860][/quote:ed38bf3860]

    hoe weet jij dat?
  • Als eerste moet je het probleem met 127.0.0.1 oplossen. Die andere problemen komen later wel.

    Als het goed is krijg je niet de vraag om een username/password, tenzij je een website hebt die daar speciaal om vraagt. Ik neem aan dat als dat zo is dat je dan ook je eigen username/password wel zal kennen.

    Heb je de root van je website wel goed ingesteld? Als dat niet zo is krijg je namelijk wel de vraag voor een username/password.

    Kun je de website wel gewoon openen vanaf je HD? Dus door C:\MyWebsite\index.htm (of iets dergelijks) in te typen in de adresregel?
  • En zou je misschien die plaatjes een (heel stuk) kunnen verkleinen. Dat vertraagt de boel hier enorm.
  • [quote:e1019ff5a7="jeroenvanweeghel"]
    hoe weet jij dat?[/quote:e1019ff5a7]
    Je moest 's weten wat ik allemaal weet.
  • [quote:209e9f0a72="Kamikaasje"]Als eerste moet je het probleem met 127.0.0.1 oplossen. Die andere problemen komen later wel.

    Als het goed is krijg je niet de vraag om een username/password, tenzij je een website hebt die daar speciaal om vraagt. Ik neem aan dat als dat zo is dat je dan ook je eigen username/password wel zal kennen.

    Heb je de root van je website wel goed ingesteld? Als dat niet zo is krijg je namelijk wel de vraag voor een username/password.

    Kun je de website wel gewoon openen vanaf je HD? Dus door C:\MyWebsite\index.htm (of iets dergelijks) in te typen in de adresregel?[/quote:209e9f0a72]
    Ik kan de website wel openen van de HD, door inderdaad zoiets in te typen.
    Hoe moet ik de root van mijn website eigenlijk instellen?
    Dat zou ik niet weten.
    Het staat allemaal in de map, C:\Inetpub\wwwroot
    Verder weet ik niet wat ik zou moeten instellen.
    Weet je dat wel?
  • [quote:04d1d03e2c="Belg"][quote:04d1d03e2c="jeroenvanweeghel"]
    hoe weet jij dat?[/quote:04d1d03e2c]
    Je moest 's weten wat ik allemaal weet.[/quote:04d1d03e2c]
    Wat dan allemaal?
  • [quote:79d3f8de30="Kamikaasje"]En zou je misschien die plaatjes een (heel stuk) kunnen verkleinen. Dat vertraagt de boel hier enorm.[/quote:79d3f8de30]
    hoe zou ik dat moeten doen?
  • [quote:5d1127abf0="jeroenvanweeghel"][quote:5d1127abf0="Kamikaasje"]En zou je misschien die plaatjes een (heel stuk) kunnen verkleinen. Dat vertraagt de boel hier enorm.[/quote:5d1127abf0]
    hoe zou ik dat moeten doen?[/quote:5d1127abf0]

    Uh? Je hebt die plaatjes toch zelf gemaakt? Kun je ze toch ff verkleinen met een tekenproggie. Ik weet niet wat je gebruikt, Photoshop, PaintShop etc. maar al die proggies hebben wel een mogelijkheid om een plaatje kleiner te maken.
  • Ja, het is kleiner.
    Zo beter?
    Zou je me nu verder kunnen helpen?
  • [quote:11ee49e8ea="jeroenvanweeghel"]hoe zou ik dat moeten doen?[/quote:11ee49e8ea]
    Zo:
    [img:11ee49e8ea]http://users.skynet.be/bk329292
    outer1.jpg[/img:11ee49e8ea]
  • [quote:902c6b1487="jeroenvanweeghel"]Wat dan allemaal?[/quote:902c6b1487]

    Dat plaatje is een scriptje dat kijkt van welk IP de aanvraag voor het plaatje komt en dat zet ie op het plaatje. Iedereen ziet dus een andere tekst staan op dat plaatje.. Belg zit weer eens te geinen.

    Bij je router kun je bij Online status ook je externe IP aflezen.

    [quote:902c6b1487="jeroenvanweeghel"]hoe zou ik dat moeten doen?[/quote:902c6b1487]

    Openen in Paint. Alles selecteren en dan kiezen voor uitrekken\hellen en gewoon 50% verkleinen ofzo.


    Ik heb ook een draytekrouter en wat je bij Port Redirection invult is goed. Als 192.168.1.12 maar jou ip is met de webserver. Je moet alleen nog Active aanvinken om hem actief te maken.

    EDIT:
    3 antwoorden terwijl ik zit te typen :-?
  • Alleen is de router op dit moment nog zijn belangrijkste probleem niet. Als hij zijn website niet met 127.0.0.1 aan de gang krijgt staat zijn webserver nog niet goed ingesteld.

    Wat heb je als root van je website ingegeven in de webserver?
  • Als ik je trouwens nog een tip mag geven, vergeet de Windows XP ingebouwde webserver. Als je een echt goede webserver wilt draaien, gebruik dan Apache. Dat is wereldwijd de meest gebruikte webserver. Het is bovendien open-source en gratis hier te downloaden. Apache kan ook perfect overweg met PHP (ook gratis) en met MySQL (ook gratis). Je kunt een eigen forum opzetten met phpBB (ook gratis, het C!T forum maakt hier gebruik van), je kunt je MySQL bestanden beheren met phpMyAdmin (ook gratis) enz. enz.

    Stel dat je daarentegen een super simpel klein websiteje wilt hosten, zonder scripts of andere toeters en bellen, en je wilt het binnen 2 minuten in de lucht hebben, dan kun je beter voor SimpleServer:WWW van AnalogX kiezen (ook gratis).
  • Voor beginners en wat testen van dingen vind ik PHPDev altijd wel een aanrader. Zit Apache, PHP, MySQL e.d allemaal al bij in en is makkelijk te installeren.

    PHPDEV
    * apache 1.3.27
    * php4.2.3
    * MySQL4a
    * Cerebus FTP server
    * phpmyadmin 2.3.2
    * InvisionBoard forum
    * PhpWebsite
    * mod_perl 1.27 (as an optional download)


    Ik zou btw http://localhost gebruiken ipc 127.0.0.1 om te testen.
  • Als ik 127.0.0.1 intyp in IE6 dan vraagt de pc wel om een wachtwoord, en als ik localhost intyp dan kom ik gewoon op mijn webserver terecht.
    waarom 127.0.0.1 wel om een wachtwoord vraagt weet ik niet.
    maar het gaat mij om dat routerprobleem, hoe los ik dat op.

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.