Vraag & Antwoord

Servers

Problemen met Apache en IPv6

Hoi, Thuis heb ik een Apache 2.0 webserver met een aantal sites, waaronder http://www.phedny.net welke zowel via IPv4 als IPv6 bereikbaar is. Als de site via IPv4 bekeken wordt, is er niets aan de hand. Wordt deze echter met IPv6 bekeken, dat willen de plaatjes niet tevoorschijn komen. Tijdelijk heb ik door dit probleem het logo even van de site gehaald, maar deze is via http://www.phedny.net/logo.png op te vragen (alleen met IPv4). Op http://www.phedny.net/logo.php staat het volgende script: [code:1:a8a2b641b5] <?php header( 'Content-Type: image/png' ); readfile( 'logo.png' ); ?> [/code:1:a8a2b641b5] Als deze pagina wordt bezocht komt het logo altijd in beeld, zowel via IPv4 als IPv6. Door met telnet een IPv6 verbinding met de server te maken en dan een [b:a8a2b641b5]GET /logo.png HTTP/1.1[/b:a8a2b641b5] geven, levert mij geen "troep" op, terwijl ik voor [b:a8a2b641b5]GET /logo.php HTTP/1.1[/b:a8a2b641b5] netjes de troep krijg die ik wil hebben. Ten slotte nog de mededeling dat de aanvraag voor de afbeelding netjes in de access_log file komt te staan: [code:1:a8a2b641b5] 3ffe:8114:2000:1e70:200:4cff:fe9e:beed - - [26/Nov/2003:10:18:58 +0100] "GET /logo.png HTTP/1.1" 200 8175 3ffe:8114:2000:1e70:200:4cff:fe9e:beed - - [26/Nov/2003:10:19:02 +0100] "GET /logo.php HTTP/1.1" 200 8175 [/code:1:a8a2b641b5] Nu weet ik echt niet meer wat het probleem is, weet iemand hier misschien raad mee? Alvast bedankt ! - Mark

Anoniem
Phedny

Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord