Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

Servers

[ftp] server onbereikbaar?

None
27 antwoorden
  • Ik zit met een netwerkje achter een E-tech ethernet adsl modem
    outer (hccnet).
    NATP is ingeschakeld. In virtual server heb ik poorten 20 en 21 public en private doorgezet naar het ip-nummer van de pc waarop de server draait.
    DHCP is ingeschakeld, maar ip-nummer server correspondeert met de routerinstellingen bij virtual server .
    Op mijn win xp pro-machine draait de ftp-server servu-u.
    Intern (loopback- of ip-adres) doet de server het prima. Ook volgens shields up (www.grc.com) staat poort 21 wagenwijd open. Via de website www.net2ftp.com kan ik de ftp-directory benaderen.

    Maar…. een vriend krijgt als hij contact zoekt met mijn ftp-server telkens de foutmelding: can't resolve hostname. Hij komt er echt niet door, want Serv-U registreert geen enkele activiteit.

    Ik kan in het forum geen info vinden om dit probleem op te lossen. Kan iemand mij uitleggen waarom nou toch die server onbereikbaar blijft?

    Peter
  • De melding can't resolve hostname duidt meer op een DNS-fout. Heb je een domeinnaam? Zo ja, gebruikt je vriend deze domeinnaam om te connecten, of je IP-adres?
  • Ik heb geen domeinnaam. Ik gebruik het vaste ip-adres van mijn adsl-verbinding.
  • het is in de meeste gevallen dat je een router hebt dat de ftp site d.m.v passive mode moet worden benaderd ik weet niet wat jouw instellingen zijn etc.. maar
    ik heb hier ook een e-tech router en daar is een speciaal invul vakje voor een passive ftp misschien moet je eens kijken of het daar aan ligt…
    en ook zorgen dan passive mode aan staat in het ftp programma waarmee je de ftp op probeert te komen…
    je kan ook je ftp hier posten dan kunnen wij jou ook helpen en direct feedback geven.. en dan weten wij excat wat er gebeurd (Log..)
  • Ik heb de blauwe 4-poorts analoge router met deze firmware: ETHADSL_USB_032002_REL5. Daarin vind ik niets om PASV in te stellen. Ik heb nu alleen poort 21 open staan, maar heb hier en daar gelezen dat je ook poort 20 zou moeten openzetten?
    Dit is het adres: (…) [i:6789901c7d]Heb ik voor nu maar even verwijderd. Dan maar paranoïde :D [/i:6789901c7d]
    Ik heb tijdelijk de anonieme toegang ingeschakeld.
    Benieuwd wat je ontdekt!
  • Ik neem aan dat je TCP poort 21 open hebt staan en doorgestuurd hebt naar je FTP-server?

    Weet je ook zeker of je provider niet een aantal poorten blockt? Kortom, welke provider heb je?
  • Ja poort 21 is bij virtual server doorgezet naar de pc waarop de server draait. En ik zit bij hccnet.
  • Ik denk dat The Game zich verspreekt, en dat hij "ik draai hier ook ServU" bedoeld ipv "ik heb hier ook een e-tech router"??

    Als het goed is heb je het zo ingesteld:

    * Op E-tech router poort 20 en 21 doorgezet naar IP-adres waarop server draait.

    * In Serv-U (ikzelf gebruik 4.1) is ingesteld dat er Passive FTP gebruikt mag worden in [b:e27d7a596c]Serv-U servers[/b:e27d7a596c] -> [b:e27d7a596c]<<Local Server>>[/b:e27d7a596c] -> [b:e27d7a596c]Domains[/b:e27d7a596c] -> [b:e27d7a596c]<Domeinnaam>[/b:e27d7a596c] -> [b:e27d7a596c]Settings[/b:e27d7a596c] -> [b:e27d7a596c]Advanced[/b:e27d7a596c]. Tevens heb je daar je WAN IP-adres ingevuld zodat de client die inlogd weet, waarnaar een 2e sessie opgebouwd moet worden.

    Doe je dit niet, dan zal de client denken dat hij een sessie moet opbouwen met het eigenlijke IP-adres van de server (dus 192.168.1.X ofzow, wat bij de client niet bestaat!).

    Ik heb ook onder [b:e27d7a596c]Serv-U servers[/b:e27d7a596c] -> [b:e27d7a596c]<<Local Server>>[/b:e27d7a596c] -> [b:e27d7a596c]Settings[/b:e27d7a596c] -> [b:e27d7a596c]Advanced[/b:e27d7a596c] nog een PASV port-range ingesteld. Doe jij dat ook, houdt er dan rekening mee dat die ingestelde poorten ook moet doorzetten in je router!

    En ja, dan moet de "andere kant" ook instellen dat er Passive FTP gebruikt wordt…

    Suc6!
  • Ik heb alles zo ingesteld als Anakin heeft gezegd; eigenlijk stond het al zo. Misschien wil Leo of Anakin (ander proefkonijn?) proberen anoniem toegang te krijgen?
  • [quote:a70017ee71="Anakin"]Ik denk dat The Game zich verspreekt, en dat hij "ik draai hier ook ServU" bedoeld ipv "ik heb hier ook een e-tech router"??
    [/quote:a70017ee71]
    nope ik heb buij mijn router instellingen een speciaal stukje om een passive ftp door te linken naar een intern ip… maar ik heb nu gezien dat we over 2 verschilende routers praten dus ik weet niet hoe dat bij hem zit
    de foutmelding:
    [quote:a70017ee71]
    *** CuteFTP Pro 3.3 - build Aug 25 2003 ***

    STATUS:> Getting listing "/"…
    STATUS:> Connecting to ftp server 80.100.71.103:21 (ip = 80.100.71.103)…
    ERROR:> Can't connect to remote server. Socket error = #10061.
    STATUS:> Waiting 30 seconds…
    [/quote:a70017ee71]

    en wat zeggen ze bij error #10061:
    Can't connect to remote server. The connection is actively refused by the server. Try switching from PASV to PORT mode

    maar dit gebeurd bij pasv en port mode… hmmm….
  • Nope, nog steeds niets.

    In principe hoeft poort 20 niet open gezet te worden. Toen ik alleen nog maar een NAT-router had draaien, stond deze poort ook niet open en het werkte perfect.

    Het is van afstand moelijk te zeggen wat hier mis gaat. De FTP-server draait op een XP-machine toch? Is de firewall op die machine ook uitgeschakeld?
  • @The Game, K, sorry.

    @Pyrrus, Ik kom niet op je server. Krijg gewoon helemaal geen verbinding. Kom dus waarschijnlijk niet eens door de router heen??

    Klinkt misschien stom, maar hoe zit het met een eventueel firewall op de PC zelf??

    Misschien een nog stommere vraag: Draait de server überhaupt wel? Ik weet van mijn PC dat dat groene U-tje niet uit zichzelf start (heb ik opgelost door een snelkoppeling te plaatsen in de map startup van het 'All users'-profiel). Misschien is de service gestopt?

    Tevens heb ik het geprobeerd vanaf die site die je noemde, www.net2ftp.com , maar ook daar vandaan kom ik er niet op hoor.

    Greetz!
  • ik ben blij met de [quote:a77811d6fd]hmmmmmmm[/quote:a77811d6fd] van The Game, want blijkbaar is er toch iets raars aan de hand.
    Voor de goede orde, ik heb echt de poorten 20 en 21 geforward naar de pc waarop de server draait en volgens shields up is de poort open. Desondanks geen toegang dus.
    Ik gebruik verder geen softwarefirewall, ook niet die van XP, dus daar kan het ook niet aan liggen.
    Verder is de router helemaal standaard ingesteld en zou ik sowieso niet weten welke instelling daar nog roet (rout…) in het eten zou kunnen gooien, maar mijn poorten staan wagenwijd open voor suggesties :-?

    Aanvulling: had via DHCP een nieuw ip-nummer (modem nogal vaak gereset bij het zoeken naar andere instellingen, maar op dit moment doet bijvoorbeeld www.net2ftp.com het weer. Wil iemand nog eens kijken of hij op de server kan komen?
  • [quote:1b87e5f793="Anakin"]
    @Pyrrus, Ik kom niet op je server. Krijg gewoon helemaal geen verbinding. Kom dus waarschijnlijk niet eens door de router heen??
    [/quote:1b87e5f793]
    Sorry, waarschijnlijk probeerde je het op een moment dat de instellingen even niet goed waren. Alles klopt nu weer (behalve de toegang dan :D )

    [quote:1b87e5f793="Anakin"]Klinkt misschien stom, maar hoe zit het met een eventueel firewall op de PC zelf??
    [/quote:1b87e5f793]
    Niets van dat al. En zoals je merkt is mijn router blijkbaar ruim voldoende om iedereen buiten de deur te houden :(

    [quote:1b87e5f793="Anakin"]Misschien een nog stommere vraag: Draait de server überhaupt wel? Ik weet van mijn PC dat dat groene U-tje niet uit zichzelf start (heb ik opgelost door een snelkoppeling te plaatsen in de map startup van het 'All users'-profiel). Misschien is de service gestopt?
    [/quote:1b87e5f793]
    Iemand zei ooit zeer terecht dat stomme vragen niet bestaan. En de server draait.

    [quote:1b87e5f793="Anakin"]Tevens heb ik het geprobeerd vanaf die site die je noemde, www.net2ftp.com , maar ook daar vandaan kom ik er niet op hoor.
    [/quote:1b87e5f793]
    Mijn schuld, had na de zoveelste routerreset niet gezien dat door DHCP het ip-nummer van de server niet meer klopte. Waarom schakel ik DHCP dan niet uit? Nou dat probeerde ik gisteren en toen had ik helemaal geen netwerk meer en ik wil even 1 probleme tegelijk proberen op te lossen. Tenzij iemand nu gaat uitleggen dat DHCP de oorzaak van alle problemen is :oops:
  • [off-topic]K, dus je gebruikt DHCP. Da's niet zo handig als je een server draait…

    Stel je netwerk als volgt in:

    * Ip-adres: Een adres dat buiten de DHCP-reeks valt. (DHCP begint meestal bij x.x.x.10 of x.x.x.100 ofzow. Kun je ook instellen trouwes)
    * Subnetmask: Zelfde als van je router aan LAN-zijde
    * Gateway: IP-adres van router
    * DNS-servers: Dat moet je ff nazoeken op de router. (Moeten dus de DNS-servers van je provider zijn!! Niet het IP-adres van de router.)

    Als het goed is werkt je netwerk dan gewoon en zul je altijd hetzelfde IP-adres op je PC hebben…[/off-topic]

    Maar goed, kan er nog steeds niet op via die website…? PC uit? :wink:

    Ik heb een poosje op het internet gezocht, maar kan nergens een handleiding (met plaatjes) vinden, aangezien ik niet zo'n e-tech heb… Wat een rotte site heeft dat bedrijf trouwes, en wat een handleiding… 2 pagina's…
  • [quote:762f503825="Anakin"][off-topic]K, dus je gebruikt DHCP. Da's niet zo handig als je een server draait…

    Stel je netwerk als volgt in:

    * Ip-adres: Een adres dat buiten de DHCP-reeks valt. (DHCP begint meestal bij x.x.x.10 of x.x.x.100 ofzow. Kun je ook instellen trouwes)
    * Subnetmask: Zelfde als van je router aan LAN-zijde
    * Gateway: IP-adres van router
    * DNS-servers: Dat moet je ff nazoeken op de router. (Moeten dus de DNS-servers van je provider zijn!! Niet het IP-adres van de router.)
    [/quote:762f503825]
    Tja, bij DNS gaat het dus mis. Bij HCCnet kan ik nergens een DSN-server vinden. Op de router staan ze op 0 met de instelling <Use autodiscovered servers only> en daarom kreeg ik static ip ook niet aan de praat. Er zit dus even niets anders op dan na een reset te controleren of de ip-nummers nog corresponderen met de ftp-serverinstellingen (op dit moment is dat zo).

    [quote:762f503825="Anakin"]
    Maar goed, kan er nog steeds niet op via die website…? PC uit? :wink:

    Ik heb een poosje op het internet gezocht, maar kan nergens een handleiding (met plaatjes) vinden, aangezien ik niet zo'n e-tech heb… Wat een rotte site heeft dat bedrijf trouwes, en wat een handleiding… 2 pagina's…[/quote:762f503825]

    Klopt, handleiding blinkt niet uit door duidelijkheid, alhoewel ik wel een wat uitgebreider Engels boekje heb. Maar dat veronderstelt meer kennis van netwerken dan ik heb :-?

    Inmiddels draait de server weer voor anonieme toegang. Als iemand wil proberen of hij op de ftp-server kan komen, houd ik me aanbevolen:
    ***knip ip-nummer*** het speelkwartier is voorbij :wink: ***
  • foutje, drievoudige posting…
  • foutje, drievoudige posting…
  • hallo !!

    ik kan wel op de ftp komen maar ik je testbestand niet openen

    groeten!

    sander
  • Het werkt. Ik kan je testbestandje lezen. Zowel PASV als PORT FTP werkt.

    Zet nu eens voor de gein poort 20 eens dicht, want volgens mij hoef je die helemaal niet te forwarden…

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.