Vraag & Antwoord

Servers

m'n webserver doet alleen intranet

Anoniem
t.bauhuis
13 antwoorden
  • Als kennismaking met linux heb ik een apache server geïnstalleerd en dat werkt :D
    Nou wil ik die server ook vanaf internet benaderen, maar dat wil niet lukken. Ik heb een alcatel speedtouch 510 ADSL modem. Daarin heb ik het ip adres van de server als default server ingesteld.
    Als ik nu het ip adres van de pc in de browser in typ, krijg ik de pagina in beeld. Als ik het "echte" ip adres op geef, dan krijg ik niets.
    Ik heb ook al geprobeerd om alleen poort 80 te forwarden, maar dat werkt ook niet.
    Ik heb zelfs op de server de firewall uitgeschakeld, helpt ook niet.
  • vreemd bij mijn weten zou het forwarden van poort 80 voldoende moeten zijn… (heb geen ervaring met deze router/modem)

    heb je wel naar het goede ip geforward?
  • Kunnen anderen wel je server benaderen op je ipadres. Ik heb namelijk ook dat ik mijn server in mijn eigen netwerk alleen kan benaderen op mijn lokale ip, en niet via het 'internet-ip'.
    Anderen kunnen daarintegen wel via het ip op de server.
  • Niet via het wan ip je eigen server kunnen benaderen is vreemd en naar mijn weten onmogelijk tenzij je een fout in de configuratie van de client pc hebt. :-?

    Hoewel ik snap dat Apache in Servers hoort, mag deze topic eigenlijk naar het Linux forum.

    Welke distributie gebruik je? Ik weet dat ik met Mandrake 9.2 ook enorm moeite had poort 80 open te krijgen. Hier zit wel de oplossing! Naar ik nog weet moet je even kijken bij de instellingen van de netwerkkaart. Daar heb ik ooit iets aangevinkt. Wat weet ik niet precies meer omdat ik er niet meer mee werk.

    Kijk dus even bij je kaart: deze is zelfs via het 'start' ( ms lolz) menu te vinden.

    d.
  • Tja het linux forum had ook gekund, maar ik heb meer het gevoel dat het in de router dan in de server zit.
    Lijkt me dat als ik via het lan wel de site op kan die poort 80 toch open moet staan. Dat aanvinken denk ik wel te weten wat dat is, ik gebruik Redhat 9.2 en dan kun je bij veiligheid aanvinken dat je ethernet kaart vertrouwd is.
    Wat dat ip nummer dat geforward is betreft, dat is inderdaad de juiste, dat is gewoon het ip dat wel werkt.
  • Als je DNS goed werkt, krijg van binnenuit NIET je website te zien als je je website naam intikt. Die verwijst dan namelijk naar de buitenkant van je router. Je kan wel op je lokale webserver tinydns o.i.d. draaien. Dan laat je hem eerst lokaal zoeken (maak een entry voor je eigen IP adres) en pas daarna de externe dns server. Lijkt mij dus een DNS probleempje.
  • Dit heeft niets met DNS te maken. Een SpeedTouch 510 kan niet dataverkeer terug routeren naar het interne netwerk, als de request ook van het interne netwerk komt. Veel routers hebben hier problemen mee. Kortom, je kan dus niet vanaf het interne netwerk een connectie maken naar een andere PC op je netwerk via je externe IP-adres.
  • Het ligt niet aan het terug routeren, ik heb ondertussen op een andere pc bij een kennis getest en ook die vind de server niet. Een ping naar het ip-adres kwam niet verder dan een time out :(
  • [quote:a7373cac5d="t.bauhuis"]Tja het linux forum had ook gekund, maar ik heb meer het gevoel dat het in de router dan in de server zit.
    Lijkt me dat als ik via het lan wel de site op kan die poort 80 toch open moet staan. Dat aanvinken denk ik wel te weten wat dat is, ik gebruik Redhat 9.2 en dan kun je bij veiligheid aanvinken dat je ethernet kaart vertrouwd is.
    Wat dat ip nummer dat geforward is betreft, dat is inderdaad de juiste, dat is gewoon het ip dat wel werkt.[/quote:a7373cac5d]


    neen, op de lan hoeft poort 80 niet openen: die is al open. anders zie jij je webpagina niet. heel simpel: je maakt toch een verbinding achter 'poort 80' binnen je lan? als het goed is zijn alle poorten binnen je lan te benaderen. dat je poort 80 open moet gooien is voor de buitenwereld.

    (hersenspinsel dilbert) de eerste tip die ik gaf was van toepassing als je zelfs binnen je lan de pagina niet ziet. foutje van mij.

    als ik dit nu allemaal lees denk ik toch echt dat het aan je modem ligt. ff prutsen dus. :)

    d.
  • Is het al gelukt?

    Ik heb ook dat modem en heb hem helemaal tot en met getest.

    Mail me als je er nog niet uit ben

    Gr.
  • (beetje laat ben ik…maar voor de mensen die net zoals ik naar dit ow zoeken:)

    Ik heb ook een websever (abyss 1.2.1 :P) draaien op mijn pc en ik kan via andere pc's in het netwerk op mijn server komen. Maar vanaf internet niet. Wat blijkt nu, moet ik de pport forwarden in de speedtouch 510. En das eigenlijk best wel simpel. In het menu vindt je onder 'Advanced' het menu 'NAPT'. Daar druk je dan op nieuw en voer je bij poorten allebij 80 (voor een webserver dan) in en bij lokaal ip het ipadres van je server en bij extern laat je het 0.0.0.0 . Als het goed is moet het dan werken.
  • Misschien een beetje laat, maar niet te laat. Ik was nog steeds in het bezit van het probleem. Sterker nog ik ben nog steeds in het bezit van het probleem.

    Die beschrijving die je gaf geeft bij mij geen oplossing, vanaf internet wordt mijn server niet gevonden. Als ik het instel zoals je zegt wordt de server niet gevonden, maak ik vervolgens de default server leeg (daar heb ik het ip adres al eens eerder ingevuld) dan kan ik vanaf internet mijn modem configureren.

    Nog ideeën?
  • ow, das minder…

    Met andere poorten lukt het bijna altijd, maar waarschijnlijk omdat de router/modem zelf gebruik maakt van een webserver (voor de webinterface) verbindt hij die door…

    Wat je nog zou kunnen proberen is te gaan klooien op de modem via telnet (start > uitvoeren > 'cmd') en dan 'telnet 10.0.0.138', daar kun je nog heel wat meer opties vinden. Daar worden de opties van de firewall ook weergegeven, en die kan ik niet vinden in de webinterface. Misschien dat hier nog iets instaat en dat je hier iets zou kunnen vinden dat je probleem kan oplossen… Ik zal zelf ook nog even kijken hoe je hier vanaf kunt komen…

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.