Op deze website gebruiken we cookies om content en advertenties te personaliseren, om functies voor social media te bieden en om ons websiteverkeer te analyseren. Ook delen we informatie over uw gebruik van onze site met onze partners voor social media, adverteren en analyse. Deze partners kunnen deze gegevens combineren met andere informatie die u aan ze heeft verstrekt of die ze hebben verzameld op basis van uw gebruik van hun services. Meer informatie.

Akkoord

Vraag & Antwoord

Servers

Apache Server opzetten

Hu'uruun
2 antwoorden
  • Ik heb zojuist Apache 2.0 gedownload (2.0.49 ofzoiets) en geïnstalleerd op een computer in het netwerk. Dat is niet dezelfde computer als die het internet heeft (het internet, dat via ADSL verloopt - usb modem - wordt op een andere comp gedeeld). Nu komt het probleem. Ik heb het ip-adres van de internetverbinding opgezocht met whatsmyipaddress en dat heb ik ingevuld bij de intstallatie van Apache. So far so good. Maar als ik nu http://localhost ter test invul in m'n browser krijg ik het volgende: Page cannot be displayed…

    Vrij logisch denk ik, aangezien ik alleen de Apache monitor heb aanstaan. Niet het programma zelf (daar kwam ik later achter). Echter, als ik 'control apache server' en daarin 'Start Apache in console' aanklik, krijg ik zo'n dosschermgeval, met een knipperend - die eerst normaal knippert en vervolgens tergend langzaam aan en uit gaat… En het scherm blijft maar staan. Ondertussen is de computer onwerkbaar geworden en kan reset als enige hulp bieden. Wat doe ik fout? Waarom crasht dat geval? Volgens een vriend van me, die het ook heeft draaien, moet dat scherm binnen enkele secondes weg zijn…

    Dit is m'n errorlog, overigens waren er nog veel meer van die foutmeldingen, exact hetzelfde, maar die heb ik er maar even uitgelaten..:

    [quote:dfe60101f5][Wed Mar 31 19:39:56 2004] [notice] Parent: Created child process -354341
    [Wed Mar 31 19:39:57 2004] [notice] Child -354341: Child process is running
    [Wed Mar 31 19:39:57 2004] [notice] Child -354341: Acquired the start mutex.
    [Wed Mar 31 19:39:57 2004] [notice] Child -354341: Starting 250 worker threads.
    [Wed Mar 31 19:46:41 2004] [notice] Parent: Created child process -281503
    [Wed Mar 31 19:46:42 2004] [notice] Child -281503: Child process is running
    [Wed Mar 31 19:46:42 2004] [notice] Child -281503: Acquired the start mutex.
    [Wed Mar 31 19:46:42 2004] [notice] Child -281503: Starting 250 worker threads.
    [Wed Mar 31 20:01:10 2004] [error] (OS 10045)Operation not supported on socket: Child -281503: Encountered too many errors accepting client connections. Possible causes: Unknown. Try using the Win32DisableAcceptEx directive.
    [Wed Mar 31 20:01:28 2004] [error] (OS 10045)Operation not supported on socket: Child -281503: Encountered too many errors accepting client connections. Possible causes: Unknown. Try using the Win32DisableAcceptEx directive.
    [Wed Mar 31 20:02:04 2004] [error] (OS 10045)Operation not supported on socket: Child -281503: Encountered too many errors accepting client connections. Possible causes: Unknown. Try using the Win32DisableAcceptEx directive.
    [/quote:dfe60101f5]

    Hoe disable ik die directive?
    Of is er iets anders aan de hand (moet ik die portmapper, analogx gebruiken om 80 door te verwijzen vanaf m'n internet-hebbende comp - ja ik heb het forum wel even doorzocht)?
  • Overigens, hier is wat meer info over dat gedoe, maar ik snap nog steeds niet wat ze bedoelen: http://httpd.apache.org/docs-2.0/mod/mpm_winnt.html

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.