Vraag & Antwoord

Servers

FTP server (Serv-U) icm SMC router

Anoniem
aemdenouden
4 antwoorden
  • Ik wil een FTP server draaien op m'n pc.
    systeem: WIN XP Pro
    router: SMC 7404WBRA Barricade

    Mijn pc heeft IP-adres: 192.168.2.100
    Ik heb op de router (via virtual server) poort 21 opengezet op het IP-adres van mijn PC.
    Via adress mapping heb ik het IP-adres van mijn router doorgelinkt naar 192.168.2.100.

    In Serv-U heb ik het volgende ingesteld:
    accounts aangemaakt
    81.204.xxx.xxx ingevuld als server adres
    Port 21 open

    PS:
    XP-firewall, Software firewall & Router Firewall staat uit


    Nu werkt de server echter nog niet.
    De server werkt wel als ik bij Serv-U instel dat het IP-adres van m'n server 192.168.2.100 is. Maar dat is dus gewoon m'n PC-ipadres. Dan werkt hij alleen binnen het netwerk.
    Vul ik het IP adres in van m'n router dan geeft hij geen respons maar zegt: [i:35f27bd99c]SERVER IS NOT LISTENING ON IP 81.204.xxx.xxx: Trying to use non-existent IP address?[/i:35f27bd99c]
    Ook werkt de server op 127.0.0.1. Dat snap ik helemaal niet waar hij dat IP-adres van daan haalt.


    Waar zit de fout volgens jullie?
  • 127.0.0.1 is je "localhost": een zogenaamde virtuele netwerrkverbinding met je eigen PC.

    Probeer je je server op z'n externe IP te bereiken vanaf de pc zelf?
    Dat vinden routers vaak niet zo fijn, ivm IPspoofing is dat geloof ik.
    Vraag dus een iemand anders het te testen (echt van buitenaf).

    Verder kan je effe kijken naar de "passive mode": die maakt soms dat andere poorten gebruikt worden (22?). Effe googlen zal helpen.
    helaas zit ik hier op mijn werk en kan dat niet voor je doen…
  • [img:946b18864e]http://members.lycos.nl/pinteboomtk/FTP/stap1.jpg[/img:946b18864e]
    [img:946b18864e]http://members.lycos.nl/pinteboomtk/FTP/stap2.jpg[/img:946b18864e]
    [img:946b18864e]http://members.lycos.nl/pinteboomtk/FTP/stap3.jpg[/img:946b18864e]

    zijn dit de goede instellingen of moet ik in een ander menu alles instellen.

    bij het laatste scherm krijg ik met de instelling 81.204.xxx.xxx (het ip adres van m'n router) de server niet op ONLINE (wat nu op het scherm wel te zien is)
  • hij werkt!

    heb het ip-adres ingesteld als "use any available IP adress"

Beantwoord deze vraag

Dit is een gearchiveerde pagina. Antwoorden is niet meer mogelijk.